New firmware v2.2.56 beta version for ZIDOO Z9S release

Discussion in 'ZIDOO Z9S' started by mirror, Mar 30, 2019.

  1. Zigourney

    Zigourney Active Member

    Watched another 4K HDR movie with Atmos Remux last night and, no blank screen issues :)

    Looking promising, looks like some real progress has been made on this firmware in terms of the 10 bit 444 blank screen issue.
  2. Miguel Ramos

    Miguel Ramos Member

    Awsome! I'll recebi my X10 again by tomorrow! I'll also test my 4K video file!
  3. x9suser

    x9suser Member

    Anyone knows how I can reset back the Browser selection at the main screen. I have two browsers installed, and previously ( by default) when I click the Browser button , it will give me a choice to run whichever browser I like. Now I have accidentally changed the selection button to run only one of the browsers. I want to change back to previously where it gives a choice to select either of the browsers.

    Any way to revert back?
  4. afss

    afss Active Member

    From my side the Z9S is now very stable with this new firmware - it has taken back the main player position on my HT ! Thanks Zidoo team for addressing the issues.

    Hopefully Zidoo can now start focusing on picture quality, specially the HDR to SDR conversion which was advertised as a key feature of this box.
    gymnos likes this.
  5. Emphyrio

    Emphyrio Member

    From my side the Z9s with this firmware doesn't resolve my black screen issue , hopefully they can continue focusing on this problem or propose me an exchange with a x9s ..
  6. Ovidiu Necula

    Ovidiu Necula Member

    Send an email to zidoo with this problem and your setup (TV, soundbar, cables, etc.)
  7. x9suser

    x9suser Member

    Quoting myself above....

    Most of you would already know that HT2 ver 2.1.9 was already released to fix the Auto Update Sources bug. But for those still unaware, the link's already updated on the 1st page.
    Last edited: Apr 9, 2019
    gymnos likes this.
  8. ICU2018

    ICU2018 Member

    Hello all, I'm still stuck on FW 2.1.30, do you advice me to upgrade to 2.2.56?? any comments would be appreciated.

    Cheers :)
    Last edited: Apr 9, 2019
  9. x9suser

    x9suser Member

    I would like to make the following request from Zidoo team

    1) Please add rmbv playback (the X9S fw 2.1.22 can play rmvb so Z9S shouldnt be a problem).
    2) For DVD, please enable the remote's 'Next' button to be used for skipping chapters. My 10 year old Realtek 1073 player can not only play DVD with full Menus , but it can also skip chapters using the Remote 'Next' button. So I don't see why it is so difficult for a new advanced Realtek 1296 to be unable to do this. Currently to skip chapters is a big hassle. I have to activate the Menu and navigate a series of button presses just to skip a chapter.

    Thank You.
    Last edited: Apr 10, 2019
  10. ikkjr

    ikkjr New Member

    After watched one 4K (24Hz HDR 10-b its) & one 1080p(24Hz) movie, I've to say that the 2.2.56 firmware is much better than 2.2.55.
    The 4K movie has no problem but I experienced a one-time freeze on the 1080p movie,
    however when I played the same time-slot of the 1080p movie again, it didn't have any problem!
    gymnos and Zigourney like this.
  11. Zigourney

    Zigourney Active Member

    Same for me, I have watched four 4K movies on this firmware and no blank screen issues so far. Before it happened on every single 4k file that I tried.

    I am also experiencing the issue you described above regarding 1080p files, that sometimes film plays with no video, but can hear audio only. However if I stop and replay it plays back fine.
  12. akan7

    akan7 Member

    Force Subtitles Not Working on
    v2.2.56. Been working fine for me on others.

    Last edited: Apr 10, 2019
    DELUCAS likes this.
  13. xtripsnova

    xtripsnova Member

    That was weird. I was almost happy with this build. I saw 3 full length UHD movies without black screens or audio dropouts. And then tonight I saw a 1080p movie and had 3 full black screens and audio dropouts.
  14. Nice Monkey

    Nice Monkey Well-Known Member Beta test group

    Eject is not working anymore (USB). That is to say when tried there is no immediate reaction it may take many minutes before the pop-up window comes for the confirmation. It in fact then works.
    gymnos likes this.
  15. talkron

    talkron New Member

    Thank, it really worked, at least for now 2.2.56 seam the most stable FW i used with Z9S. One thing i missing is ability to set 1080p/23Hz , as i usual watch HD or UHD i a row and set the player to 2160p/23hz or 1080p/23Hz, to reduce the black screen on the begimnning of the video when the resolution and framerate switches. Only shows 1080p /24 as possibility...
  16. xtripsnova

    xtripsnova Member

    Well, I was too quick to judge. As I said, I watched 3 UHD movies without any problems, then yesterday I had a black screen and audio dropouts on a 1080p movie, and finally today I had the whole shebang with a UHD movie (Man on the ledge).
    So, again, the Z9S goes back to the bedroom and will stay there. This time it will be hard for it to make bail.
    I put my eGreat A5 back where it belongs, my home theater.
    I kinda like it more and more.
  17. Zigourney

    Zigourney Active Member

    Ah man that's really unfortunate! I thought it was all sorted for you. :(
  18. Yes
    Yes I have the same problem with this firmware
  19. Nice Monkey

    Nice Monkey Well-Known Member Beta test group

    24P in fact is 24/1001 which you reference to as 23 Hz. There is no 23P so selecting 24P (=23,9760) will in fact do what you are looking for.
    Last edited: Apr 11, 2019
  20. gymnos

    gymnos Member

    Nope, for Zidoo players @23Hz = 23.976 fps while @24Hz = 24.000 fps

    In order to use 4K@23 and avoid HDMI handshake we have to set 'Ignore EDID' to On in the Developer Options.


Share This Page