Z9X - SMB playback issues while streaming from NAS

Discussion in 'HDD Media player(RTD 1619DR)' started by matty2k, Dec 30, 2020.

  1. Zidoo_API

    Zidoo_API New Member

    Can't. My NAS can only have highest SMB3 and lowest SMB2. Can't put lowest to SMB3 unfortunately.

    I'm not talking about peak bandwidth. But I get what you are getting at. I see no dips while transferring large files over the network, no dips at all. Still, the buffer probably should be bigger just to have more margin.
  2. sandyj

    sandyj Member

    The problem with my synology NAS seems to have all but disappear after I made some changes
    1. Add loads of Ram 16 GB +
    2. Added SSD read write cache - I know this one does not appear to make sense but does seem to have worked in my case.
    Changed some network settings in the NAS as well sorry don't have time right now to add them will do a write up if anyone is interested.
  3. Todd Z

    Todd Z New Member

    I'm have random freezing issues as well but have a different menu on the Z20 pro after clicking advanced, I enabled developer options but am not seeing a buffer setting in the list, I'm using a Qnap NAS and gigabit switch wired to the Zidoo 20 pro but have only 1 of the 4 movies I have tested has played all the way through without a freeze up, my Zappiti Neo is wired to the same switch and NAS and does not seem to have this issue. thoughts?
    Last edited: Sep 21, 2023
  4. glaugh

    glaugh New Member

    Same issue. The developer menu doesn't have performance mode or the ability to change buffer settings anymore?
  5. Todd Z

    Todd Z New Member

    not that I have been able to find, I have tested 4 4K movies and 1 1080p through SMB and they will all choke at about 1 hr and 40 min in, it feels like its running out of buffer but certainly related to the network because when I directly connected a drive the movie played through to the end. I am now testing the NFS server to see if that is any different. Oddly, my shield TV pro and Zappiti that are on the same network do not have this issue.
  6. Todd Z

    Todd Z New Member

    tested 2 movies with NFS and its much better than SMB but will drop frames with high bitrate 4ks at around 2 hours but not drop the audio track, still a deal breaker though and seems to be a buffer issue as again, the other players on the same network seem to be fine.
  7. Deano86

    Deano86 Active Member

    What are the movie files in question? Are they your own straight disc rips? Are they remuxes or downloaded from the internet?
  8. IanO

    IanO New Member

    My initial "success" of forcing the port speed to 1 Gbit was shortlived. Although this did stop the signifcant stuttering, I was still getting pauses of about 5 secs every so often throughout a film irrespective of bitrate be it 4K, Blu-ray or even DVD. I store my movies on a share on a QNAP NAS (TS-453Be). I increased the minimum SMB level to 2.1 and max to 3.0. This didn't actually help. I could see the Resource Monitor on the NAS, specifically the NICs and they seemed to drop off when I had the pause (going to zero on the line graph). I then switched on SMB multichannel on the NAS interface. I wasn't sure I needed to do this as I had already port bonded the two 1Gbit NICs on the NAS using 802.3AD link aggregation. I also decided to build a homelab server so moved, Roon, Plex and my UP'n'P servers to virtual machines on this new server. That allowed me to re-purpose the two 512GB NVMe M.2 drives on the NAS's QM2 card as a cache. I used a Read Only cache on the NAS and picked All I/O as the cache mode (which is their recommendation for media files). Now I can watch a movie (even 4K) with no pauses. I have tested this with mutliple films and my two different Zidoo players in different rooms. So I don't know if it was the SSD cache or SMB Multichannel that helped (or both) but that does seem to have resolved my issue.
  9. 3DBuff

    3DBuff Well-Known Member

    Maybe those servers on you QNAP were causing this pause. Typically you don't need much of processing power or special hardware to play movie from NAS on Zidoo players. I had RasperryPi 3 with USB hard drives running NAS out of Kodi setup. Zidoo was reading full 3D ISO files 45GB without a glitch over 1GB LAN. RPi 3 could not push more than 20MBps.
  10. Triumf001

    Triumf001 New Member

    I don’t know what the problem is, but the developers have a big minus for the z9x, SMB NFS, it lags everywhere if the movie is with a normal bitrate. 1522 16gb, Toshiba 18tb x3 raid 0, 2SSD 1tb read|write, 10gb Asus LAN

    I report, I sold this ill-fated box, a fiend from underground, I bought a Z9X PRO, I’ve been watching for a week - NO FREEZING, this is the best thing that’s happened in a while, I’ve already forgotten what it’s like to watch a smooth movie:)
  11. dr4go

    dr4go Member

    Never had those problems with the Z9X - besides the SMB, which was indeed goddamn slow, but only when using EXFAT as file system. Additionally I've had a fight with corrupted and / or disappearing files from the drive. Desperately I tried formatting the drive with NTFS afterwards and everything worked flawlessly since then.
  12. B0RN

    B0RN Active Member

    Anybody know about the Master Browser issue and its impact on SMB not showing up? And have any idea on how to make a older PC get off the network chain and make the new PC in the system the Master Browser to Zidoo can see SMB?
  13. Zaudio

    Zaudio Member

    I thought Microsoft fixed this a few years ago for windows 10. I recall have to mess with it long ago, but never since. My windows 10 pro PC has no problems accessing my synology nas, and my nvidia shield over SMB.
    I found this that might help you: http://www.boristheengineer.co.uk/networks/master_browser.htm
    dr4go likes this.
  14. RXP

    RXP New Member

    Omg this seems to have fixed my issue too. I've been avoiding using the zidoo for 2 years cause of this issue. How frustrating
  15. nmfrankl

    nmfrankl Member

    You seem comfortable with the Zidoo products and Synology. Any ideas as to why my Z9X Pro doesn't remember it has already scanned the shared folder on my NAS after the Z9X Pro has been powered off and then back on? My Z9X Pro finds my shared folder after I log into the NAS and scans it just fine...it populates HT4, but after powering the Z9X Pro off and then back on...it shows that source as unscanned and HT4 is not populated.
  16. Zaudio

    Zaudio Member

    My thoughts are:
    ensure your NAS and your Zidoo have a fixed IP from your router. By default devices connect by DHCP and get allocated a temporary IP on your LAN.
    then ensure you setup your media folders on the Zidoo using that fixed IP address for your NAS, and not it's name.
    This is how my Z9x is setup and it has never once had your issue. So unless this is a Pro version issue, you should be able to resolve it.
    nmfrankl and Netmask like this.
  17. nmfrankl

    nmfrankl Member


Share This Page