Z9X - SMB playback issues while streaming from NAS

Discussion in 'HDD Media player(RTD 1619DR)' started by matty2k, Dec 30, 2020.

  1. matty2k

    matty2k New Member

    I open one new thread for this topic since it seems to be a general problem of Zidoo firmware OR HT4 build OR SMB settings on NAS.

    My Setup: LG OLED C7, DENON AVR X1400H, Zidoo z9x (TV and Zidoo connected to AVR). Using Zidoo firmware v6.0.85. Operating gigabit LAN with Dell x-series switch. Checked internal LAN speed already. Zidoo network LED is blinking orange. And gigabit speed is recognized correct from switch. Watching with HT4 and all sources are SMB shares from NAS.

    Problem: When streaming movies from NAS after some minutes it starts to stutter and sometimes the whole HT4 crashes leading to Home Screen view!

    On NAS minimum SMB protocol was set to SMB2 and maximum SMB protocol to SMB3.
    However I deactivated the encryption for SMB3 without any improvement. HT4 crashed very quickly. Then I changed minimum SMB protocol to SMB1 with big improvement, only some light stutters and until now no crash. Unfortunately I cannot check, which protocol is used now.

    As I remember I had similar problems with z9s and SMB shares. Was using NFS instead.
    I would prefer SMB share and since SMB2 and SMB3 normally should have better performance and higher security level, this protocols should be supported well.

    Looking for your feedback and suggestions for setting adjustment.

    kind regards
  2. Armin Moesslacher

    Armin Moesslacher Active Member

    I use a Synology NAS cabled connection via Switch (1Gb) latency around 2ms, still drops when streaming movies over SMB (also stutters with NFS 2-4 times in a movie, tried several formats and sizes).

    I use SMBv3 and SMBv2 SMB as fallback options.
  3. cucnz

    cucnz Active Member

    patch .85
    NEVER had streaming issues with SMB for any content on previous firmwares , unlike thread creator

    5Th element played near perfect all the way thru except for 4 or 5 1/2-1 sec pauses ,but audio etc all stayed in synch

    Muxed Justice league Fel to a mel 7 and it too finally could play (past the old 3 mins stutter audio synch issue that .85 fixed) but via SMB it too did the EXACT same thing that 5th element did.with 5-10 near 1 sec pauses ,again with no audio synch issues after
    Running the movie again atm BUT usb3 hdd direct ,and almost to end of the movie NOT ONE issue with stutter or these 1 sec random pauses

    Definitly looking like an SMB lagging issue

    Doesnt effect normal 1080p 720p 2160p tv epis that ive watched since installing .85 firmwre

    Ill test another movie tonight via USB 3 since its had the ISSUE 2 from 2 full movie playbacks via SMB and update here
  4. cucnz

    cucnz Active Member

    War of the Worlds 4 minor stutters by 40 min mark playing via smb
    Swapped drive to usb 3 direct port , and finished the next 1 hr 20 ish with zero stutters

    defintely looking like an issue of some sort with the .85 patch

    DV DA part is working sweet thou SO DONT miss that up :p
  5. matty2k

    matty2k New Member

    I actually experienced the SMB issue with big files Dolby vision and HDR. Via USB3.0 HDD it seems to run perfectly.
    I experienced the problem with big files, e.g, LotR extended edition. But however, testing needs some time ..
  6. rozel

    rozel Well-Known Member

    Slightly related but over many years using various Windows OS's (currently Windows 10) I've never understood why possibly the majority of people use SMB and not NFS. I have always experienced issues with my NAS's when trying to set them up using SMB. Never had a single issue with NFS. So why is SMB more popular? Just curious so I can put this thread and others into perspective.
  7. Glorioso

    Glorioso Member

    I purchased my Z9X yesterday and connected it to my NAS where I have a SMB Puvlic share with my media files, I had to make a NFS share to access it, with SMB, altough the share was public, it kept prompting to inter user and pass credencials.
  8. I too have random stuttering.. Over wired gig Lan connection..
    My SMB share is from a mini pc win10 I made just to use a Nas for usb drives..

    All zidoo models prior to thr Z9X and every computer in house can play the same SMB share perfect with no stuttering..
    The Z9X at random points, will stert to stutter.. even on low bitrate scenes..

    I tried even adding SMB 1.0 and no go..
    Even tried NFS, and little better, but stutters still at random points..

    Again my z9s same wires, same switch, same ever thing, had 0 issues

    Anothr SMB issues is it will see a drive I'm sharing, i go into the share and can only see 1 of the 2 directories...
    All my other comouters and android devices can see both folders inside the share.. Just not the Z9X..

    I will try a flash firmware reset and try new x90 beta..

    Just borrowed my buddies x9s zidoo..

    X9s when using same wires (just swapped out Z9X) it played upto 350Mbs jelly fish files perfect.. not one stutter.
    Also tried few movies that Z9X had stutter, all works smooth and perfect with x9s and z9s NOT Z9X...

    Now to test when other players come.. but not looking good
  10. rozel

    rozel Well-Known Member

    Still trying to understand why people prefer SMB over NFS
  11. on zidoo at least last few versions, I found nfs to perform worse than SMB. On my dune player, I found nfs better.
    Even now after testing I still get stuttering with nfs and SMB.. but think maybe it's a faulty player the more I test.

    Also found nfs with zidoo, seems to skip over some files...
    example, if I use nfs for media browser app, I can see all my movies perfect.
    If I use the movie theater app, and point it to same nfs share, it missing over half of my movies..
    Very frustrating for sure, as media browser with nfs see all.

    SMB however seems for reliable. It get all the files all the time..
    rozel likes this.
  12. McBluna

    McBluna Well-Known Member

    From my experience with Z9S smb has 60 Mb/s and NFS has 40 MB/s. Jelly bean test 400 works with smb but not with NFS.
  13. Rob W

    Rob W Active Member

    The stutters were in original few firmware releases but were fixed for me. Issue was reported as IPv6 related.

    After flashing 85 firmware the stutters have returned is this a new freezing issue or have they forgot to include the IPv6 patch?

    Downloading 90 firmware now to see if it's working properly.
  14. I'm not sure.. i actually disabled the ipv6 in network settings in Windows as I heard that helps.
    But in my case no difference.. Even with new x90 beta..
    What versions worked stutter free for you? I can try that firmware.
  15. Rob W

    Rob W Active Member

    I believe it was fixed in x45.
  16. ok cool. I'll try that..
    Do I still keep ipv6 off in windows network settings..
    and what issue with stutter did you have exactly before fix
    thanks again..
  17. Rob W

    Rob W Active Member

    I don't think it matters what you set in Windows for the previous issue you had to disable IPv6 on the router and that is not always possible. In my case with BT it's not possible to disable IPv6.

    The issue I had was micro freeze that lasted under a second and happened every so often during a movie. It was completely fixed in 45 and the following firmware.

    I have since switched to a different server that is windows based and updated the Zidoo firmware at same time so can't blame the Zidoo yet but the issue does appear to be the same.
  18. Yup that is the exact same issue I'm getting..

    Just tried x45 and was finally able to watch a full 4k UHD backup..
    I ran the jellyfish files also.. They played smooth to 300Mbs and sometimes even at 400Mbs..That was hit and miss.


    With same files and shares being added to movie thester 4.0 app, I now only can play to 250Mbs on jellyfish..
    Even gojng back to media browser after loading the movie theater app lowered how high I can go..

    Seems like a memory issue here..

    But thanks so much for recommending x45... Was nice to actually watch a movie smooth..

    Now to test same movies using movie theater app and see if it give me stutter..

    With the newest beta, and previous beta, I had stutter no matter what I used to play movies..
  19. Rob W

    Rob W Active Member

    Thats good news I think I will have to do the same. Was it just a case of flashing the old firmware normally or do I have to perform a different procedure seeing as it's an older firmware.

    The freeze issue was also fixed in 60 for sure and I believe 66 was fine also. I think I will go to 66 because it had a lot of other fixes including improvements for HT4.0 which might help you. Version 80 had reports it was quite buggy and I never tested it.
  20. Cool. I'll try x66

    I rolled back, I had to recovery image flash method. (put image file on usb, and hold reset button while turn on power to zidoo)
    after the image was on zidoo, I then upgraded to whatever higher firmware your want thru the update app on zidoo.
    Last edited: Jan 3, 2021

Share This Page