Z9x Pro defaults to 1080p

Discussion in 'HDD Media player(RTD 1619BPD)' started by Duke Sweden, Mar 13, 2024.

  1. Markswift2003

    Markswift2003 Well-Known Member SUPER Administrator Beta test group Contributor

    Yes - Return is the bottom left arrow that sort of turns back on itself:

  2. Duke Sweden

    Duke Sweden Member

    ok, I've just about got it perfect, just a few bugs I've got to work out. I'll list them here, if they're known bugs let me know, if there's a fix let me know. Either way thanks for all your help.
    1. It still loses signal when I press a button on the home page. Have to switch HDMI inputs and then go back to Zidoo.
    2. Can I set it so that it doesn't default to subtitles "ON" on some movies? I've set it so in settings but most movies I've demo'd start with subtitles on.
    3. Some movies will pause/stutter and lose audio, I have to pause/unpause to fix it, which really gets me out of the movie. I've seen other complaints about that. Is there a fix. Firmware 1.075(?) the latest.
    4. Sometimes audio signal to my L/R mains and my subs turns off. Sometimes I can fix it by exiting out of the movie and then hitting play again. Other times I have to turn the AVR Off and On again.

    That should be it. It's been my experience that a lot of bugs fix themselves after a while, but if you're familiar with these 4 and there's a fix, please let me know.
  3. Markswift2003

    Markswift2003 Well-Known Member SUPER Administrator Beta test group Contributor

    1. The only reason I can think of for this is an IR conflict in the remote control between the Zidoo and the Emotiva - Pressing a button on the remote - Menu, Up Arrow etc etc, does not cause any change in the video signal - non whatsoever - the only way that happens is when you actually change video settings or play content (with differing framerate, HDR mode or resolution).

    Try covering the IR window on the Emotiva and see if that stops it happening.

    2. Yes - turn subtitles off:

    Settings/Playback/Default Language/Default Subtitles > Off


    While you're at it, turn forced subtitles on:

    Settings/Playback/Forced Subtitle > Auto


    3. This isn't a known bug - generally playback is absolutely rock solid as long as the files and the file delivery system is robust.

    There is a very very occasional bug that manifests in the playback sort of slowing down - a bit like the framerate is reduced - but from what you describe that doesn't sound like it.

    I use MKV files exclusively and they are delivered from several NAS drives many tens of meters away through 4 switches and never have any issues with playback. I haven't even seen the bug I mentioned above since last year as far as I recall.

    4. Very odd - if it's just L/R and Sub, assuming you're bitstreaming (Audio set to Auto or RAW) then that has to be an AVR issue since the box simply delivers a bitstream and it can't delineate between channels so couldn't "turn off" L/R and Sub but leave Surrounds etc on.
  4. Duke Sweden

    Duke Sweden Member

    Not sure why I would turn forced subtitles "ON" but ok. That's the only setting that differentiates from what I have now.
    Number 4 happened before with a Shield. My original Shield which I still used, weirded out on me a few months ago so I got another one. THe new one caused that L/R/subs problem, when I put the old Shield back it went away. But now that it's happening with the zidoo I have to agree that it's probably the MR1, I really need to get on their ass about it, it's caused me its own set of headaches. Thanks for responding at 4:59 a.m. ;-)
  5. Markswift2003

    Markswift2003 Well-Known Member SUPER Administrator Beta test group Contributor

    Wasn't 4:59am in the UK ;)

    I always keep Forced Subs on for, er, forced subs... But feel free to turn it off.
  6. Duke Sweden

    Duke Sweden Member

    Little by little the bugs are working themselves out. My main problem seems to be the MR1 now.
    Thanks again for all your help. U.K, eh? No wonder you're so chill. I'm from the Bronx ;-)
  7. Markswift2003

    Markswift2003 Well-Known Member SUPER Administrator Beta test group Contributor

    Have to admit I've not been out to the Bronx but NY is my favourite city in the entire world. Love it there. Been many times.
  8. Duke Sweden

    Duke Sweden Member

    Have you ever seen "A Bronx Tale"? That is my actual neighborhood. I went to Mt. Carmel church as a kid, my building was 2 block to the left of it as it appears in the movie, and my father, who was a boxer, had a friend who also was a boxer, who lived in building Robert DeNiro's character lived in. That front "stoop" was fake, a big cement monstrosity. The actual front entrance is just 2 wrought iron bannisters. If you ever go to the Bronx, go to Arthur Ave. and 187th, that's the same neighborhood. Food like you would not believe. And fairly safe. Used to be all Italian but now there's a lot of Puerto Ricans.
  9. Duke Sweden

    Duke Sweden Member

    btw, here's a weird thing. I have the Dolby Atmos Demo 2014. It plays fine in Plex, and it actually played on the zidoo, but now it doesn't. I'll hit play, it goes like it's going to start playing, but then returns to its info page.
  10. Markswift2003

    Markswift2003 Well-Known Member SUPER Administrator Beta test group Contributor

    No - not seen A Bronx Tale - I'm surprised that passed me by in the 90s!

    I assume that Dolby demo is a full disc rip? That's the one area that lets the Zidoos down - they're not so good at handling full menu discs rips.
  11. Duke Sweden

    Duke Sweden Member

    They just released a 4K of it. If you ever want to know where my anger comes from, watch it.
    The demo was an MakeMKV rip I did off a BluRay disc. It worked like twice when I first set up the Zidoo, but not since. Which reminds me, I tried playing 2 different ISO's. If I hit "Play" it will play the movie but if I hit "BD" it never loads, just the endless blue spinning circle. I thought Zidoo played ISO's.
  12. Markswift2003

    Markswift2003 Well-Known Member SUPER Administrator Beta test group Contributor

    MKVs should pose no problems to the player at all. If they do there's something up with them.

    ISOs are more problematic because Zidoo are not members of the BDA so have to write their own libraries for BDJava using open source code and the BDA don't make it easy with obfuscation techniques etc. I'd say ISO support is maybe 80-85% there.

    But bottom line, stick with MKVs rather than BD Menu time vampires.
  13. Duke Sweden

    Duke Sweden Member

    Geez, is there nothing you don't know? (A little Bronx talk for ya). I've seen the phrase time vampires here. What does that mean? And one other question. I bought my Z9x from Amazon, who've made a habit of selling returns as "new". When I complained about the included HDMI cable being defective (turns out it wasn't) they didn't even blink. Before I could finish my sentence the CSR had initiated a free replacement and said I could keep the one I already have. It came the next day. I've seen on unboxing videos that the manual is on top when you open the box. It was all the way on the bottom of the box with this first one I got. I haven't opened the new one yet, in case I want to sell it. A bit long winded question, but do you think with the manual being in the bottom of the box that this one may have been used/a return? Could that be the reason for the weird bugs I've experienced that others haven't had? BTW, watched Dungeons and Dragons last night with absolutely no glitches.
  14. Markswift2003

    Markswift2003 Well-Known Member SUPER Administrator Beta test group Contributor

    Lol - it's a term I often use to describe BD Menus - they suck time!

    One of the original reasons I got into media servers back in the day was to be rid of DVD menus and with the advent of BluRay they've only got worse - utterly pointless imho :)

    I wouldn't worry one bit about where the manual is in the packing. Depends on batch and who packed it or even where it was packed.
  15. Duke Sweden

    Duke Sweden Member

    Yeah I was never a fan of menus and extras and all. I got the new one hooked up, it appears to be less glitchy and it took a lot less time to scan my library. My only problem now is being caused by the MR1 with the L/R mains and the 2 subs losing signal. It happened before with the Shield so I'm sure it'll get it sorted out. Cheers!
  16. Markswift2003

    Markswift2003 Well-Known Member SUPER Administrator Beta test group Contributor

    I assume there are forums out there for the MR1?
  17. Duke Sweden

    Duke Sweden Member

    Yeah but unfortunately there aren't any Mark Swifts there. Nobody knows any more than any of the rest of us, and nobody ever seems to have the same problems I have. For example, here's the latest one (aside from the L/R thing.) Now that I've got the zidoo working pretty good I thought I'd check my levels. For some reason every speaker was pinning the SPL meter, I turned them down to -10 and they still were exceeding 80db with the main volume at 0.0db. Normally I have to set them around -3 to -5db. And the subs! Normally around -6db but I put them to -10db and they were still around 85db. I even turned the gain down on the subs from -10 to -20. I seriously doubt anybody on the MR1 forum has had the same problem. In fact I'm gonna go post this over there now. They're ready to kill me as it is, let's see what happens.
    Markswift2003 likes this.

Share This Page