Replace splash.png in ZDMC 19.4

Discussion in 'ZDMC for Zidoo' started by Reelyator, Oct 15, 2022.

  1. Reelyator

    Reelyator Active Member

    The Original splash screen of ZDMC looks pretty boring......not to mention the incorrect spelling;-)

    Therefore i was looking for the splash.png to replace it with a custom picture but could not find it in the media folder of the ZDMC installation on my Zidoo UHD3000.

    Has anybody here found the location of the splash.png?
  2. Franconian

    Franconian Active Member


    The location is: /data/data/com.zidoo.zdmc/cache/apk/assets/media/splash.jpg

    But your device needs to be rooted first, which is not really easy or safe with the 1619DR devices.

    What you can do is:

    a) open the firmware apk, replace the logo, repack and sign it. But same here, this is not for everybody.

    b) just disable the splash screen. I do this and there is no skill or risk involved:

    Create a .txt file on your PC containing:

    <advancedsettings version="1.0">

    Save it as advancedsettings.xml

    Install Total Commander or similar on your Zidoo and just copy this xml file to this path: Android/data/com.zidoo.zdmc/files/.kodi/userdata/
    hdmkv, Reelyator and azon1951 like this.
  3. Reelyator

    Reelyator Active Member

    Thank you Franconian!
    i will try to adjust my advancedsettings.xml accordingly and then use the custom start screen that some skins offer.
    E. g. Rapier.
    Franconian likes this.
  4. Reelyator

    Reelyator Active Member

    That worked pretty well.
    The ugly ZDMC splash screen is not displayed anymore. Im Rapier you can select custom pictures or videos when starting Kodi.
  5. tom.58

    tom.58 New Member

    I did so in ZDMC 20.2 and the splash screen is gone...
    But now there are long periods of system waiting (or searching?) e.g. after stopping a movie and you want to return to ZDMC.

    I tried to get rid of that advancedsettings.xml, I even just deleted it in "userdata". But now the behaviour is strange:
    Deleting that advancedsettings.xml does NOT bring back the splash screen any more. I deleted ZDMC from the system completely and installed a new one (20.2) clean. Instead of showing the splash screen, it's still gone ! I tried several times... no splash screen anymore.

    Please , how can I return to the original state of ZDMC ?
  6. Franconian

    Franconian Active Member

    I don’t think that is the issue of the waiting time.
    But have you tried setting false to true in the xml?
  7. tom.58

    tom.58 New Member

    Thanks for the hint... but yes I did ! Nothing happened, no splash screen appeared.

Share This Page