release naskit for X6(test only)

Discussion in 'ZIDOO X6 Pro' started by spring, Mar 28, 2016.

  1. spring

    spring Guest

    neamielu likes this.
  2. neamielu

    neamielu Member

    thanks a bunch! will test it right now.

    HDMEDIA Member

  4. grummel2005

    grummel2005 Well-Known Member

    what is this app for?
  5. neamielu

    neamielu Member

    installed and configured, so far so good, it accepted the attached hdd storage, will post as soon as I will have an opinion.

    later edit: this version of NASKit is only partial, basically it only contains a ftp server and a simplified version of transmission. this is not the one presented here, because:

    - NAS module is not implemented (probably related to x9 vs. x6 differences, lack hdd i suspect)
    - aria 2 is not available
    - transmission is a simplified version, not the presented one (see picture, left version for x9, right version implemented in x6).

    I hope they will add the missing functions, to avoid installing more apps for sharing reasons and to keep all together.

    Last edited: Mar 28, 2016
  6. spring

    spring Guest

    this is the first version, and we will add more protocol and continue to improve the function.
    neamielu likes this.
  7. neamielu

    neamielu Member

    great, thanks @spring, samba protocol for NAS function and an updated version of transmission I guess would be enough, aria is quite complicated to use.
  8. Rajiv

    Rajiv New Member

    Installed it. Samba is missing which is really important
  9. neamielu

    neamielu Member

    they said will add more functions soon. for the moment I am using sambadroid which works just fine for the moment.
  10. crocell

    crocell New Member

    As far as I know transmission, and according to the attached pic (2nd one, on the right), this is not any "simplified" version of transmission -> it is one of the official HTTP remote of transmission ;) (I have strictly the same on my NAS (nas4free) running under freeBSD ... and almost all usual functions/param are possible thru this remote ... see examples here on official site

    What version of Transmission is in use in NASKit for X6 ?
    Last edited: Mar 30, 2016
  11. neamielu

    neamielu Member

    @crocell - the about says „Transmission 2.82 (14160)”. my judgment was only based on the appearance. I use to own a NAS some time ago and indeed, it was quite similar with my 2nd pic (right side). I thought that the pictured one in tle left side is more like utorrent in options and aspect.
  12. crocell

    crocell New Member

    I use transmission for a while, and I have never seen any web interface like the one used on X9 devices ; maybe is it an improved version of standard http remote, especially build by zidoo team ?
  13. spring

    spring Guest

    this apk different of X9.
  14. neamielu

    neamielu Member

    Thanks for clarification, @spring. So I wasn't completely wrong.
    Anyway, I would be happy with the latest official Transmission version, rather the fancy utorrent looking version of X9, because I prefer safety versus nice interface. It seems the last version 2.92 is addressing same security issues.
    So far the implemented version is running smoothly, very fast, and very stable, nothing to complain about.

    Now, regarding the NAS part of the package. Not sure if anyone figured how to access Samba shares from smart TVs, for instance my Samsung only reads the content (the filenames) but it cannot play anything. Is there any workaround to make the share available as DLNA? Maybe to implement some sort of DLNA server instead of simple Samba protocol? The smart TVs are playing ok the content from a Serviio DLNA server installed on a PC, for example.
  15. mirror

    mirror Well-Known Member SUPER Administrator Zidoo TECH Supporter

    Maybe you can try "eHomeMediaCenter".X6 pre-installed it.It's a DLNA server
  16. neamielu

    neamielu Member

    I did but it didn't worked. Maybe I sould try harder (will dig into the settings to see if I can make it solve this problem). Thanks for head-up, @mirror.

    later edit: I tested again eHomeMediaCenter preinstalled on x6 and I got the same result on Samsung TV - the TV can see the filenames, but there is no thumbnail and the file is not playing (file not available error), the same as in Sambadroid case.

    I think this might be a filesystem issue or a difference in „serving” files, since the TV can play windows media shares or Serviio files from a PC without problem.
    Last edited: Mar 31, 2016
  17. PacoRabanne

    PacoRabanne Well-Known Member Beta test group

    Vu Asia, TWRP?
    Could you explain how you installed TWRP?

  18. Vu Asia

    Vu Asia New Member

    PacoRabanne likes this.
  19. gokushon

    gokushon New Member

    FTP password cannot be changed. Please correct it before releasing the final thing!.
    Also it will be great to be able to select standard port instead of 2121. I manually modified it in vsftpd.conf and it's working great
  20. neamielu

    neamielu Member

    @gokushon - i changed my ftp password without problem, maybe you should stop ftp service first?

Share This Page