Problem Aria2 does not start download.

Discussion in 'ZIDOO X9S' started by Pelayo, Oct 10, 2018.

  1. Fatih Durmus

    Fatih Durmus Member

    I can download using aria2 on last beta firmware.
     
  2. Pelayo

    Pelayo Member Beta test group

    In my case, the new firmware v2.1.19 beta version still presents exactly the same errors, with the addition that transmission is not even able to start correctly. I am not able to connect to transmission and try to download any torrent.
     
  3. Fatih Durmus

    Fatih Durmus Member

    This is my transmission config setting. It is working good.

    /mnt/A03C3916/torrent/android/config
    (Hdd name A03C3916)

    Downlod directory
    /mnt/A03C3916/torrent

    Can you share your settings.
     
  4. Pelayo

    Pelayo Member Beta test group

    The test torrent is:
    http://torrent.unix-ag.uni-kl.de/torrents/KNOPPIX_V8.2-2018-05-10-EN.torrent

    Next I expose the adjustments that I have placed already I have tried with different hard disks and configurations, nothing works.
    Screenshot_20181230-215957_Chrome.jpg Screenshot_20181230-220537_Chrome.jpg Screenshot_20181230-220545_Chrome.jpg
    As you can see it gives error to connect with the trackers or remains trying to connect to any torrent that I add, both with aria2 and with transmission.
    Screenshot_20181230-222247_Chrome.jpg Screenshot_20181230-222251_Chrome.jpg
    Test with the same torrent, using an application for my mobile that is connected to the same network as the Zidoo.
    Screenshot_20181230-221537_Flud.jpg Screenshot_20181230-221544_Flud.jpg
    Anything that is needed to fix the error I am happy to provide it.
    P.S. All the errors happen in the two Zidoos that you buy.
    All the settings are made with the openwrt formatted first to avoid any errors.
     
  5. Fatih Durmus

    Fatih Durmus Member

    This is my config setting

    /mnt/A03C3916/torrent/android/config
    (Hdd name A03C3916)

    Downlod directory
     
  6. Fatih Durmus

    Fatih Durmus Member

    Can you set your config file same download directory.
     

    Attached Files:

  7. Pelayo

    Pelayo Member Beta test group

    Screenshot_20181230-231307_Chrome.jpg Screenshot_20181230-231254_Chrome.jpg
    Screenshot_20181230-231242_Chrome.jpg
    It does not work.
    If you can think of anything that can solve it, I'll try it without problem. Thank you.
     
    Last edited: Dec 30, 2018
  8. Fatih Durmus

    Fatih Durmus Member

    Can you try different directory? For example
    /mnt/069e4786/torrent/android/config
    /mnt/069e4786/torrent
     
  9. Pelayo

    Pelayo Member Beta test group

    If I have also tried it.
    Try using only the zidoo that gives the bug in my network.
    Try to change it from the network, that is, create an access point with the mobile phone in case it was my home internet.
    Try changing the hard drive for another.
    Try changing the firmware and restore it from the factory.
    Try changing the DNS and static IP and Dhcp.
    The only thing that has worked is to change the firmware to version 1.4 but after a few days it fails again, the internet in the zidoo works ping perfectly from openwrt but I am unable to understand and solve because I do not download the torrents
    Also try with the command "chmod 777 -R / mnt" to give permission to all the folders where I try to download.
    Changing the directory is the first thing I do to test if it works .
    I do not think it's a problem in the directory if you read the error it produces is a connection error with the tracker. For some strange reason it is not able to connect giving error.
    Although the directory was not accessible to the openwrt it would not download anything but it would not give that error.
     
  10. Pelayo

    Pelayo Member Beta test group

    I have discovered why neither transmission nor aria2 works.
    The flash image 1.4.12 and I have installed all the firmware to discover from which the error occurs.
    Firmware 1.4.12 OK
    Firmware 1.4.16 OK
    Firmware 1.4.6 OK
    Firmware 1.5.0 OK
    Firmware 2.0.5 OK
    Firmware 2.0.15 OK
    Firmware 2.0.25 FAIL
    Firmware 2.0.34 FAIL
    Firmware 2.1.14 FAIL
    Firmware 2.1.22 FAIL

    Up to firmware 2.0.15 transmission and aria2 work perfectly.
    FIRMWARE 2.0.15
    Screenshot_20190118-000956_Chrome.jpg Screenshot_20190118-001030_Chrome.jpg Screenshot_20190118-001332_Chrome.jpg
    FIRMWARE 2.0.25
    Screenshot_20190118-005313_Chrome.jpg Screenshot_20190118-005337_Chrome.jpg Screenshot_20190118-005520_Chrome.jpg
    The problem is that openwrt is not able to connect to the DNS and therefore is not able to resolve the tracker of transmission or aria2, or ping any url.
    FIRMWARE 2.0.15
    Screenshot_20190118-000605_Chrome.jpg Screenshot_20190118-000615_Chrome.jpg Screenshot_20190118-000644_Chrome.jpg
    FIRMWARE 2.0.25
    Screenshot_20190118-004951_Chrome.jpg Screenshot_20190118-005004_Chrome.jpg Screenshot_20190118-005022_Chrome.jpg Screenshot_20190118-005100_JuiceSSH.jpg
    I noticed that in version 2.0.15 the openwrt is: "Powered by LuCI QA160627-nuplayer_Kylin_2017-05-11_SQA_Dailybuild_NAS Release (git-17.130.47916-3e80cb1) / OpenWrt Chaos Calmer 15.05.1"
    and in version 2.0.25 it is:
    "Powered by LuCI QA170623_Kylin_2017-08-21_SQA_Dailybuild_2in1_NAS-1-gdc12a34 Release (git-17.233.32017-dc12a34) / OpenWrt Chaos Calmer 15.05.1"
    Some problem has the openwrt when I update it Zidoo that breaks the aria2 and transmission.

    Please can any administrator check the error or tell me how to fix it.
    I can provide all the data that is needed to solve this problem at once, it is not a problem of my Zidoo because I have two and in both the same thing happens.
    There is only one thing that I do not understand that only I complain about this problem should happen to more people.
    Thanks.
     

    Attached Files:

  11. dzsur

    dzsur New Member

    This is my problem too,but for me already 2.0.15 is not good
     
    Pelayo likes this.
  12. Pelayo

    Pelayo Member Beta test group

    Do you also have problems to ping a url?
     
  13. dzsur

    dzsur New Member

  14. SandySemenov

    SandySemenov New Member

    one more here: openwrt can not resolve names on firmware later than 2.0.15
     
    Pelayo likes this.
  15. Pelayo

    Pelayo Member Beta test group

    Thanks for informing.;) The more we are with the problem, the more importance the Zidoo team should give to the problem.
     
  16. slavensiz

    slavensiz New Member

Share This Page