Occasional jerky/choppy playback

Discussion in 'HDD Media player(RTD 1619BPD)' started by Markswift2003, Dec 24, 2023.

  1. Sanctrum

    Sanctrum Active Member

    It's a common knowledge. Valid for all USB ports also for PCs etc. So why are you surprised also seeing Zidoo's very small external power supply with low power?

    Z9x Pro is able to power external HDD (2.5' or 3.5') but up to the limit of the power it can provide via seleceted port (SATA port or via USB port) and this sums up vs the limit of the power supply substracted by the power consumption of Z9x Pro main board Realtek chip takes. So you have no more power than PSU can provide minus the power of Z9x Pro consumption during its most power consuming tasks like video playback. And this remaining power is distributed to ports (probably not evenly so according to specific port limitation) when it is needed by connected drive. PSU always try to deliver as much power as the receiver/drive consumes - this is physics and how all electronics works. If it is too much than PSU can provide or the main board can pass via some port then lost of thing can overheat including damaging some chips.

    Do the math at your setup.
  2. cucnz

    cucnz Active Member

    as i said above , i permanently have 2 x 4 tb USB powered drives attached to my Z9X Pro ( and my Z9X in bedroom has 2 as well)
    and i never haver this or any issues with stutter or the jerky choppy playback from this thread

    I do have the Pro box lifted up on legs about an inch cos it was having some issues with getting very hot 40 deg or so and would get wonky ( it is summer here and room temp was 35 plus)
    but none since i raised it
    in fact i just finished Monster Hunter complete iso with zero issues and box is 30 degree and amp on shelf below is 39 with room temp of 27
  3. Markswift2003

    Markswift2003 Well-Known Member SUPER Administrator Beta test group Contributor

    As said previously, it's kind of common knowledge, but I understand that this won't be obvious to everyone.

    But we're still surmising that this is the issue here. Probably the worst that would happen if you overload the USB ports is the voltage regs will pop - they will certainly get warm though. It's just your description of "hot" that is worrying - these things will warm up, particularly if ambient temp is high as in @cucnz 's case, but "hot" is a different matter.

    Whatever the issue here, it's not within the experience of the vast majority of users and the only way to identify the problem is a process of elimination.
  4. KJC

    KJC Member

    I think the problem is with my Z9X pro. Been talk with the seller. He agreed to send it for repair.
    blenky likes this.
  5. chrisolson91

    chrisolson91 New Member

    I have no idea if this is related to anything you're referring to here but I've seen an issue where if I add a new movie to my SMB and then turn on my Z9X Pro and try and play that movie right after scanning it will often skip and stutter. I've found if I reboot the system after having it scan the new movies then it will play just fine. Not a clue why...
  6. cucnz

    cucnz Active Member

    the last 4 movies ive moved from pc to 4tb hdd on Pros usb port and played them all with no stutters either as soon as they transfered or soon after (ie Monster hunter iso ...Passengers iso ... Beverly hills cop iso and Leviathan iso ) thats pretty much last 4 nights of movies :p
  7. cucnz

    cucnz Active Member

    wrong thread :p
  8. TheRedDevil7

    TheRedDevil7 New Member

    Well, it's annoying, but I had my first case of picture dropout (not sound) on the Remux UHD DUNE PART ONE (DV and DTHD) on a UHD5000 in version .075
    I'd watched a dozen films in the same configurations without any problem, with super-smooth playback.
    A brief pause and return to playback restored the image's stability.
    Less than 1/4 hour later, I had a single flicker again, and without doing anything I was able to finish my film without any problem.
    It's a real pity, because apart from that, which is essential to its proper use, it's the main purpose of this 1000€ machine... It's a very good player.

    Translated with DeepL.com (free version)
    gymnos, altcoinfanatic and Pete B like this.
  9. Terry73

    Terry73 New Member


    The same !
    altcoinfanatic likes this.
  10. lbos

    lbos New Member

    I am using the Z9X Pro w/ v1.0.75 firmware and my unit is having the choppy playback issue on all VC-1 mkvs upon resume. All of these videos (Amadeus, 9, Star Trek TOS episodes, etc.) all start up from the beginning with no issues. From this clean start I can pause/resume, skip forward or backwards without any problems. But if I stop the video and then resume the playback it ALWAYS looks as though it's running at half the frame rate (audio is fine). I have tried changing every setting, completed a factory reset, flashed the .75-G firmware - all with no change. It doesn't appear that I can downgrade the firmware back to v1.0.52. I have also noticed a rare choppy playback on other movies, but these seem to be corrected with a skip back or a restart. Thanks for any suggestions or help.
    altcoinfanatic and Pete B like this.
  11. sandyj

    sandyj Member

    I don't seem to have this issue anymore but it was happening very frequently before I made a bunch of changes to my NAS which appears to have largely solved the problem which I documented somewhere here. I only experienced it once since and all I did was power off the zidoo unit fully and reboot back on and its never happen again its very rare that I fully power it off. Do others here use a synology NAS and have this problem ?
    Last edited: Mar 5, 2024
  12. Azrael

    Azrael Member

    havent seen stutters on QNAP NAS
  13. blenky

    blenky Well-Known Member

    I have a synology NAS and see the occasional jerky playback that is fixed with jump back or stop/start.
    Pete B likes this.
  14. sandyj

    sandyj Member

    Yes that was exactly what was happening to me I have not seen it for months now.
  15. Visconti12

    Visconti12 Active Member

    Well that's an issue I'm facing for some time in my ZX9 and Z9X Pro
    Pete B likes this.
  16. sandyj

    sandyj Member

    I had the same issue with my Z1000 pro so what I am saying is I appear to have fixed the issue in my case by tweaking the NAS set up.
  17. Andy2023

    Andy2023 New Member

    Since changing the display settings from 12BIT to 10BIT like the recommended settings. I've no more problems with jerky/choppy playback on VC1 MKV's and other H264/H265 MKV's on the firmware 1.0.75 (Z20 Pro)
    Little bit crazy why the problem is on 12BIT?!

    My Change:
    Display/Color Settings/4K 50~60Hz: Priority YUV422 12BIT -> Priority YUV422 10BIT
    Display/Color Settings/4K 23~30Hz: Priority YUV444 12BIT -> Priority YUV444 10BIT
    Display/Color Settings/Non-4K: Priority YUV444 12BIT -> Priority YUV444 10BIT
    gymnos likes this.
  18. sandyj

    sandyj Member

    I would not be surprised if there is more than one thing that causes this issue that's why its hard to nail down.
    Pete B likes this.
  19. Visconti12

    Visconti12 Active Member

    Obviously the NAS set-up must be the best possible like full connection (by two Ethernet cables if device got two network cards) but there are not many other tweaks. The real issue is the occasional jerky/choppy playback from NAS. It doesn't happen when playing the same files in PC but in Zidoo. Most probably is produced by certain decoded files that must be fixed.
  20. sandyj

    sandyj Member

    Take a look here wrote this some time ago and have not had issues since

Share This Page