New version 1.2.50/1.2.80 for DMP-A6/DMP-A8 release

Discussion in 'Eversolo DMP-A6' started by mirror, Jan 31, 2024.

  1. protosingel

    protosingel New Member

    About: "32. Added the ability for SACD to retrieve audio information through XML files"

    I tested this new functionality using Ella Fitzgerald's album "Like Someone In Love" which is in the file "Ella Fitzgerald - Like Someone In Love.iso".

    I created via Foobar2000 an xml-file for it, changing the album name beforehand, adding a suffix "[SACD]" -> "Like Someone In Love [SACD]". I am attaching the resulting file "Ella Fitzgerald - Like Someone In Love.xml" as a PDF file (the forum does not allow xml files to be submitted). From that point on in Foobar2000 it was under the new name.

    After "Import" in JRiver of the two files (iso&xml) the album appeared with the new name!!!

    I added the xml-file in the same directory as the iso-file of the internal SSD in the A6. From the main screen of the A6 I ran "Music -> Library -> Update". Then “Restart”.

    The name of the album in the library did not change from “Like Someone In Love” to “Like Someone In Love [SACD]”.

    Can someone provide more information on "the ability for SACD to retrieve audio information through XML files":

    1. What is the format of the xml-file that would be read by the DMP-A6?
    2. Does the Update function consider adding an xml file to change the description of an album in the library?
    3. What are the steps to update SACD album information via xml-files?
    4. Does it matter how the iso & xml files are titled to the library internals?

    Thanks in advance for the responses from the developers!

    Attached Files:

  2. bob

    bob Active Member Zidoo TECH Supporter

    Can you try "Rebuild"?
    It may not be a new audio, only the XML file has been updated.
    Eki Shaw likes this.
  3. protosingel

    protosingel New Member

    I haven't tried Rebuild. And I believe it is not serious to rebuild a whole library after adding one small file. I will do a rebuild and get back to you.
  4. Nutul

    Nutul Well-Known Member

    I was reading through all this about squeezebox appearing after a reboot. I mean, seriously, don't you always reboot after an update? The applications the A6 / A8 find most probably depend on an underlying layer (say a library whose function is to enumerate streaming services). Until you restart that, no change will be effective, and sice you don't have any "reset" button, the reboot is the closest way of ensuring a restart of the thing...
    I'm actually not surprised at all seeing a reboot brought the thing back in...
  5. mp1405

    mp1405 New Member

    It is not only a reboot, they had fixed something and after that a reboot has the affect...
  6. protosingel

    protosingel New Member

    After 30+ minutes of "Rebuild" - no changes.
    After "Restart" - no changes.

    I'll remove the entire directory with iso&xml files. I'll do Update -> Restart. I guess the album will disappear.
    I will add the entire directory with iso&xml files. I'll do Update -> Restart. I guess the album will show up.
    I will describe the result.
  7. Stuj

    Stuj Member

    Thank you as always for your great insight
  8. protosingel

    protosingel New Member

    After removing the entire directory with iso&xml files, updating and restarting - the album disappears.
    After adding the entire directory with iso&xml files and updating - the album appeared, but without the changes I expected.
    Xml-file was not used. After reboot - the same. :(

    Could you please send an example of an xml file that was successfully used when changing the album information in the library.

    It would be helpful for me and other forum members to get some answers to the four questions I posed in my first post in this thread.
  9. mirror

    mirror Well-Known Member SUPER Administrator Zidoo TECH Supporter


    Attached Files:

  10. Path8022

    Path8022 Member

    Hey @mirror. There seems to be a further regression with Squeeze Control. At least on my system. Where on the previous beta the A6 would lose connection to the server after a restart of LMS ; you kindly explained about the 5 scan limit to improve playback performance, now the A6 loses connection once any non-LMS function is played on the A6 if LMS had been playing previously. This issue is harder to mitigate.
  11. Nutul

    Nutul Well-Known Member

    So you are telling me that Eversolo has control of your device over the internet? It must be some sort of UDP punching though, as your router won't know to whom to redirect incoming packets...
    I really don't believe so... it might have required two reboots, this is an option, or it might have been time-activated, or maybe activated locally, after the A6 made an enquiry at Eversolo servers and got a positive response... this indeed could be a valid option.
  12. MaSi

    MaSi New Member

    Unfortunately the error has not yet been fixed. I've noticed several times that the wrong title/artwork is being displayed. It's happened when I'm playing a list and instead of playing the next song on the list I decide to play another one. It plays this one but shows the title/artwork of the next one before this change
    Uwe likes this.
  13. neoitata

    neoitata Member

    In this new fw version, it takes a long, long time to recognise and read external HDD.
    When reading external disk, A6 go to some sort of standby with black screen and until finish of reading
    you can't do nothing. In previous versions it was fast.
    And maybe some kind of placebo effect, but on my system, sound is definetly better now :D
    Last edited: Feb 1, 2024
  14. Path8022

    Path8022 Member

    The functionality of Squeeze Connect was still working after the update, just the icon to configure its settings was missing. A reboot after the update didn't remedy this at the time either. I tried twice, one commentator even factory reset his device to no avail. Something changed a number of hours later and a reboot did reinstate the icon. Bizarre, I don't understand the process, maybe your last suggestion of a query response is likely?
    Nutul likes this.
  15. protosingel

    protosingel New Member

    Hi @mirror,
    I have one request - would you please try changing the information in the library with the xml file I am attaching. I changed the artist name, album name and track names - all in English.
    And then please post a screenshot of the A6 showing the changed tags.

    Attached Files:

  16. SergioB

    SergioB New Member

    Hi to All,
    I'm from Italy, today I got the new firmware 1.2.50 from network but after installation the DMP-A6 started to have the word 'eversolo' looping on the screen togheter with the light on volume knob.
    I tried to reset the machine without succes .
    Can someone help me..
  17. Breizhspirit

    Breizhspirit New Member

    Hello Mirror,
    Well you have solved the last little display problem that I had on my Samsung Galaxy Z Fold 3, 4 and 5 smartphones, namely the hiding of the volume slider by the navigation bar which prevented me from accessing it. . The new version 1.2.50 fixed the problem and for my part your app is now perfect. Don't touch anything anymore :D. Thanks for all your work, this machine is very hard to beat now.
  18. Xanderzdad

    Xanderzdad New Member

    I had the same - I switched it off at the mains, waited 20 seconds and then switched back on - worked for me.
    Nutul likes this.
  19. Matild

    Matild New Member

    How Replay gain works?
    Does he (Eversolo) scan the files or do we have to scan with some program (eg Mp3Gain)?
  20. Mister L

    Mister L Active Member

    He does.
    Matild likes this.

Share This Page