New Firmware v2.3.32 (Release Version - Fix for Seamless Branching)

Discussion in 'ZIDOO Z9S' started by Markswift2003, Jun 10, 2020.

  1. Markswift2003

    Markswift2003 Active Member

    Last edited: Jun 18, 2020
    Galactic likes this.
  2. Nice Monkey

    Nice Monkey Well-Known Member Beta test group

    It is a good idea!

    For those wanting to give it a try. The first testers including me think Zidoo really solved Seamless Branching with it.
    It is also general stable and safe to install.
    Installed just fine. Still needed re-running GAPP's obviously when using it.

    A general FW release including this fix is expected to come soon and be made available for all models.

    Zidoo needs to fix the problems with Google Services though for those having that installed like I have. My update went smooth but I was coming from FW v2.3.30 with Gapps v1.2.4.apk installed. Obviously with the need to re-run GAPP's myself too. Problems seem to be much bigger coming from older versions.

    The safest recipe for those running Google Services seems to be:
    - Uninstall Google Store and Gapps totally
    - Do the update via the USB procedure
    - Re-install gapps GappsInstaller-rtk-7.1_v1.2.4.apk
    You need to registered at Google Services then again as that will be lost.
     
    Last edited: Jun 11, 2020
  3. Markswift2003

    Markswift2003 Active Member

    Indeed - I've been using it on my test box and have seen no stability or playback issues at all.
     
  4. Abominog666

    Abominog666 New Member

    Good Day,

    Not so good indeed, as it looks like I've just bricked my beloved Z9S. I have updated from the fairly stable fw 2.2.96 to this particular beta 2.3.32.
    After upgrade finished and the device booted up I end up stuck with the main menu with a continuously popping up message that the Google services framework has stopped working again (and again and again and again on an endless loop). I cannot close this damn message as it pops up repeatedly and prevents me from entering any menus or settings to clean up cache, to uninstall or reinstall Google apps or even do a factory reset. Reboot doesn't make any better as I constantly return to the main menu with the annoying message google services framework has crashed again. I tried to make a factory reset with the needle and restore button trick but it doesn't work. When I hold the needle for several seconds (5 to 15 ) until the first large Zid0o logo appears and release, the logo freezes and the boot up process hangs up. I undertook to flash with the ROM downloaded from https://www.zidoo.tv/Support/support_guide/guide_target/ua1h3YuLrJzeq7k9e[ld]3ulg==.html but to no avail as well. It simply doesn't want neither to flash nor to get factory reset. I don't know if there's any other workaround to this. Or perhaps is there any possibility for safe boot similar to that offered by MS Windows.

    I would appreciate expert opinion and help.

    Thanks in advance
     
    Last edited: Jun 11, 2020
  5. Markswift2003

    Markswift2003 Active Member

    Did you follow emergency flash instructions to the letter?

    1 . Copy v1.7.8 full image file to an empty FAT32 USB stick

    2. Rename file to "install.img"

    3. Turn off player at switch on back

    4. Put USB Stick in a USB 2.0 port on the left hand side of the player

    5. Press and hold reset button on left hand side while switching power back on

    6. Wait for on screen confirmation before releasing reset button.

    Just noticed that Zidoo web page says use the USB 3.0 port - all instructions I have say use the USB 2.0 ports on the left and indeed I did this procedure twice yesterday with my test Z9S using the USB 2.0 ports and it worked perfectly both times...
     
    Last edited: Jun 10, 2020
    Abominog666 likes this.
  6. papirus

    papirus Member

    Hi ,

    Could you please inform us, is the firmware v2.3.32 which is prepared for Zidoo Z9S going to prepared also for Zidoo Z10 ?

    Should we wait ?

    Best regards
     
  7. Abominog666

    Abominog666 New Member


    Many thanks for your kind response and help.

    In fact I forgot to rename the ROM file, but I tried with both sides of the machine (i.e. USB3.0 and 2.0), as I know the USB3.0 port is a kind of glitchy.

    But while I expected the help to come, I was desperately trying to get past this irritating message on 'G services framework' by clicking repeatedly my remote control in order to reach apps installer in between the message continuously going on and off, which I somehow eventually have managed and even made it to hit the install button concealed beneath the message. It may sound crazy but I gave a sigh of relief once I finally noticed the google apps installation progress bar started to rotate despite it was still partially hidden under the 'google services framework" message "firing" 100 rounds per second.

    After installation was over I reboot (switched the power button on and off as the regular reboot from the remote control was impossible) and to my excitement this f@#$ng message went off. Hope this beta is worth all those torments and nervous breakdown.

    Anyway I really much appreciate you help and advice. Guess I'm going to check this out once I may experience major issues with the Z9S the other day (hopefully not).

    Warmest regards.
     
    Osmar and Markswift2003 like this.
  8. xsander

    xsander New Member

    Hello, does this update solve the problem of the usb3 which disconnects after 40 minutes?
     
  9. Markswift2003

    Markswift2003 Active Member

    I don't think any changes were made to USB handling on this release.
     
  10. Nice Monkey

    Nice Monkey Well-Known Member Beta test group

    You did not brick your player: Well Known Google Services problem instead. You need to re-install gapps or re-run it from APP's. This to be done after every FW update! It will not be fully stable without doing so, unless uninstalled completely.
    Yes, that is a big nuisance.

    There are many instances where this is explained (amongst others by me) in detail. You may also uninstall Gapps to make the player work normal.

    Once the GappsInstaller-rtk-7.1_v1.2.4.apk has been installed correctly there is no need to re-install it again with next FW updates.
    Gappsinstaller will be still there and working correctly as an APP and just needs to be run once again to activate Google Services. Quite simple actually once known (one click on it, reboot it and all set to go).
     
    Last edited: Jun 10, 2020
    Abominog666 likes this.
  11. apache

    apache New Member

    Are you having this error : "android.process.acore has stopped working" ?
     
  12. Abominog666

    Abominog666 New Member

    Thank you. Now it seems that the unit works fine. I have stumbled upon google services issue before, after earlier update to 2.2.96, when I was compelled to reinstal gapps to fix periodic system crashes, but this time it was a way more difficult as I couldn't remove the google services framework notification popping up persistently and hampering access to menus and settings. It was a kind of a miracle that I finally managed to launch gapps installer entering mouse mode and repeatedly hitting the RC to thrust through notification that was reluctant to disappear. Honestly a weird experience.
     
  13. Abominog666

    Abominog666 New Member

    I have a Russian GUI yet the error message covering half of the entire main menu was displayed in Russian as well, but it was something like "Google services framework has stopped working again" (or crashed again) without indicating specific process.
     
  14. apache

    apache New Member

    Oh, mine was popping out message "android.process.acore has stopped working" almost every second after pressed the OK button. Luckily my remote comes with mouse cursor so that I quickly navigate to factory reset page. Took lot of clicks to reach it.

    And I think my issue same as your case, it won't solved the issue with factory reset.

    What I did after few tries, I tried to update again the same version e.g. 2.3.30 firmware (USB Update) button and after reboot, the annoying pop up message will only appear from time to time and not as frequent as before.
     
  15. Abominog666

    Abominog666 New Member

    I've never resorted to factory reset before, as everything worked almost flawlessly without this step many users believe is essential after each firmware upgrade. But this time I got mad as the unstoppable notification deprived me of access to the unit's main functions.
     
  16. apache

    apache New Member

    Plug in a mouse and try navigate?
     
  17. Abominog666

    Abominog666 New Member

    As I indicated earlier in this thread the google services framework error message, which was impossible to close as it popped up again the same split second, blocked access to the main menu. You know, you cannot navigate the menu before you close the error message, whereas this stubborn message didn't want to go, hence all my desperate efforts to use any of the available accessories at hand seemed to be futile unless the message is dismissed (at the 1000th attempt).
     
  18. Nice Monkey

    Nice Monkey Well-Known Member Beta test group

    @xsander
    There was a fix in one of the FW updates. It was FW v2.3.10 I believe but could be even later?
    So it depends what you are running now. I have no problems with USB3 with it, my music HDD is connected to it (2.5 inch powering from USB3).

    @Abominog666
    Those problems with Google Services are becoming even more serious. Zidoo needs to do something here before releasing this FW in general.
    Are you sure the latest version of GAPP's was installed?
    My update went smooth but I was coming from FW v2.3.30 with Gapps v1.2.4.apk. Obviously with the need to re-run GAPP's myself too.
    The good news for you is that you in fact helped others avoiding the problem by reporting your nasty experience here. Welcome to the world of Beta testers. ;)

    The best recipe seems to be:
    - Uninstall Google Store and Gapps totally
    - Do the update via the USB procedure
    - Re-install gapps GappsInstaller-rtk-7.1_v1.2.4.apk
    You need to registered at Google Services then again as that will be lost.

    There was a special trial version FW v2.3.15G which in fact worked with Google Services running.
    It did not get follow-up though. :(
     
    Last edited: Jun 11, 2020
    Abominog666 likes this.
  19. catorcio

    catorcio Member

    the warning also appears by disabling the Wi-Fi connection?
     
  20. Abominog666

    Abominog666 New Member

    In my case the warning itself prevented wifi connection - the entire menu and all icons including wifi were greyed out. I tried to communicate with the device via cell phone's Zidoo controller but it said the zidoo was offline.

    But on the bright side, apart of this mishap, so far I haven't noticed any glitches with the new beta as I watched a couple of mkv movies, at least my viewing experience hasn't deteriorated.
     

Share This Page