New firmware v2.1.40 beta version for ZIDOO Z9S release

Discussion in 'ZIDOO Z9S' started by mirror, Jan 24, 2019.

  1. Dan

    Dan New Member

    Just ordered the Z9s to replace my X9s, after reading this forum I wish hadn't bothered.

    If it's as bad as you guys are making out I'll be sending it straight back.
     
  2. afss

    afss New Member

    I don't think it is that bad. After changing the menu resolution to 1080p/60, yesterday I watched a full 4K/HDR movie on the Z9S without a single glitch.

    I am confident Zidoo will listen to our feedback and get to the root of all those bugs.
     
  3. Zq77

    Zq77 New Member

    I want a root adb shell method
     
  4. Dan

    Dan New Member

    My Z9S is coming today, which firmware should I install for stability? Main function will be to watch 4K films via attached USB drive

    Currently have X9s and watch films without any issues, so hoping I wont regret the upgrade.
     
  5. Zigourney

    Zigourney New Member

    Hi - I thought I will post some feedback for Zidoo tech on my experience so far. I bought three Zidoo players, X9S, Z9S and Z10.

    The X9S on the latest firmware 2.1.22, all good except only one issue for me that is - hdmi CEC function not working properly.
    The best thing about X9S is that it has no random blank screen issues and no micro stutters on latest firmware - this is good.

    The Z9S has been the most unstable player for me, I updated to 2.1.30 it has random blank screens every one minute and sometimes double blank screens within 30-40 seconds and it is unusable. I updated to 2.1.40beta and the problem is still there. It is too annoying. I returned the Z9S for a refund.

    The Z10, I updated to 2.1.30 and I have the random blank screen issue...then I updated to this 2.1.40beta and also I have random blank screen issue.
    I have tried everything on it, new hdmi cables but it still made no difference. It was not a cable issue, it is a firmware issue as everything works fine on the X9S.
    It looks like the Z10 cannot lock in the hdmi settings properly i.e. bit depth, colour space, and the range as well as the hdmi handshake and sync.
    Can you please prioritise fixing the random blank screen/hdmi handshake and resync issue on the Z10. I know you can fix it, because the X9S on 2.1.22 does not have any random blank screen issues.

    So the most stable player for me for 4K HDR rips is the X9S at the moment.
     
  6. Dan

    Dan New Member

    Sounds like I should stick with the X9s and return the Z9s.

    I presume if they can get it right on the X9s it will only be a matter of time before they resolve the issues on the newer models......
     
  7. tertm141

    tertm141 New Member

    I have random USB HDD disconnected while watching movies as well, looks like its a firmware bug at the moment until the tech support guys returned from CNY and fixed it.
     
  8. Zigourney

    Zigourney New Member

    Yes there is definitely something wrong with the firmware for the Z9S/Z10, as I have had both units connected to the same equipment LG OLED 65C8, Denon x3500, using Amazon basics hdmi 2.0 cables also bought new Ugreen premium certified cables just to rule out a cable issue and both box exhibit the random blank screens, the Z9S being worse than the Z10.

    However if I switch to the X9S using the same set up and same cables (amazon or the Ugreen hdmi cables) and using the same settings 10bit, 444, 16-235, I have no blank screen problems at all on 4k hdr mvk files.
    In fact I have tried many different combination of settings starting with auto and then changing the hdmi resolution, as well as the colour and bit depth and range and they all work rock solid on the X9S on the latest firmware.

    Its a shame really, Zidoo should focus on getting the core stability of the new players right before anything else.
     
  9. mirror

    mirror Well-Known Member SUPER Administrator Zidoo TECH Supporter

    We are checking this issue,But so far we can't reproduce it.
    Just for confirm, do you have the random black screens issue connecting directly to the TV(LG OLED 65C8)?
     
  10. Zigourney

    Zigourney New Member

    I have not tried connecting directly to the TV. I do not understand what that will achieve, as I said before, the X9S works fine using the same equipment and cable chain, but the Z9S/Z10 do not.

    I can try later on and report back.
     
  11. afss

    afss New Member

    For me, looking at how my JVC projector behaves, the black screen issue could be HDMI synch related - When I see the issue, my projector behaves in a way as the Z9S was asking for an HDMI change of some sort, triggering a slow re-synch (which is typically slow on my projector). I have found a workaround which is to keep the main resolution as 1080p/60, while setting auto-resolution and auto-frame-rate features one (BTW, I have 10bit 4:4:4 selected). After doing this, I was able to watch both a 1080p/24 and a 4K/24 movie end-to-end without a glitch.
     
  12. vadergr

    vadergr Member

    Can someone confirm the maximum sampling rate supported via optical out when in music playback mode?
     
  13. Zigourney

    Zigourney New Member

    Tried that on both boxes already before and unfortunately it did not work for me.
     
  14. Summer Wind

    Summer Wind New Member

    Same problem on this firmware. Western Digital My Book 8TB via USB 3.0
     
  15. mattmarsden

    mattmarsden Member

    I think it might be related to Denon amps as I have the black screen resyncs and I'm going through a Denon amp. No problem with any other media player in the same setup. Strangely when it happens the audio carries on playing which I would have though would also have cut out if it was a full HDMI resync.
     
  16. thrang

    thrang Member

    I have both the z9s and the x9s I’ve found both to be reliable in my playback chain (Lumagen Radiance Pro/Trinnov Altitude/Sony VPL-VW5000 projector

    Remaining dealbreaker are the brief audio dropouts on branching UHD’s - hopefully this will be fixed in the next firmware. But I’ve not have any green/black screen or sync issues - I can freely hotplug either devices and it will sync on the fly
     
  17. Zigourney

    Zigourney New Member

    Its not a Denon amp related issue, its a firmware related issue...because the X9S works perfectly on the latest firmware but the Z9S/Z10 doesn't.
     
  18. Theeraphon

    Theeraphon Member

    Can you try this on Z9S?

    'Quick Settings' -> 'Playback' -> 'Automatic frame rate' -> changed from 'switch frame rate and resolution' to 'off'

    This function might work on X9S but not on Z9s.
     
  19. talkron

    talkron New Member

    Hi, are you able to send 10bit signal from Z9S to your Sony projector? I have VW270 (295 in US) and what ever i set in the player or Z9S shows in information sending YUV444 8bit. When i set YUV444 24hz 10bit or 420 10bit it even says this Tv does not suport this format, but the Sony should definitely support 10bit (only 10bit with 60Hz should be imposible)

     
  20. mattmarsden

    mattmarsden Member

    Yes its definitely an issue with the Z9S but Im wondering if the common factor is a Denon amp
     

Share This Page