New firmware v2.1.25 version for ZIDOO X9S release

Discussion in 'X9S Official Firmware Releases' started by mirror, May 5, 2019.

  1. 3DBuff

    3DBuff Active Member

    Native Kodi player is the best for this but then you will be limited to hardware like Raspberry Pi, PC, etc.

    Zidoo / Realtek is not compatible with Kodi player. Something to do with open source and Realtek not following this standard. Maybe that’s how we get HDR, Atmos and BD Menus with Zidoo player ;)
     
  2. Miguel Freitas

    Miguel Freitas New Member

    Anyone else can confirm this? I want to upgrade from 2.1.21 but i don´t want to loose auto switch function of frequency and resolution.
     
  3. 3DBuff

    3DBuff Active Member

    I’m on v.2.1.25 and I don’t see this as issue at all. It appears to effect some specific 720p formats up inverting to 1080p despite auto switch on.
    http://forum.zidoo.tv/index.php?thr...for-zidoo-x9s-release.48559/page-5#post-90133

    On occasion Zidoo player has issues with some odd formats like 25fps but nothing too drastic.
     
  4. godalmighty

    godalmighty Active Member

    when i played 1080p @23.976 content to my uhd tv using HDMI display set to 2160p
    then on my screen info said it 2160p and that mean the box do the upscalling not my tv :( even auto switch for resolution was on

    and for @Miguel Freitas it really dont bother me whom do the upscalling job
    so for now i only auto switch for frame rate only
     
    Miguel Freitas likes this.
  5. giangi76

    giangi76 Member

    I don't know if the auto-switch works or not, because I let the Zidoo do the upscaling to 2160p. And you know why? Because it does a better upscaling (quite noticeable) than my TV (LG OLED C7) or my VPR (JVC X7900).... I also have an Oppo 203 and believe me when I say that our Zidoos do a better UHD upscaling (incredible!!). Actually I also prefer how the Zidoo manages the HDR tone-mapping...specially in the high lights :eek::eek:
    So don't be sad if the Zidoo does the upscaling instead of your TV because most likely it does it better than your TV processing ;)
     
  6. 3DBuff

    3DBuff Active Member

    I have HDMI display set to 2160p at 60Hz and player auto for resolution and refresh rate.
    Zidoo home screen and poster wall shows at 2160p 60fps and HD movies are 1080p at 23.976fps without touching anything.
     
  7. godalmighty

    godalmighty Active Member

    like i said before, i dont care who doing the upscaling job coz in mine, they all both have the same result through my eyes :D
    i do care about frame rate so i just set auto switch for frame rate only
    ok maybe its my mistake
    i will try it again coz recently i use only my fullHD projector

    edit:
    already test it carefully :(
    yes only 720p @23.976 that cannot switch to the original resolution, others frame rate can switch the resolution to its original
    dont know about 2160p @23.976 coz i have to take my X9S downstair to connect it with my uhd tv
     
    Last edited: Jun 10, 2019 at 3:24 PM
  8. xxxxx

    xxxxx Member

    Auto swtch don't work well and this firmware don't keep your chosen resolution. I have flashed zidoo and downgrade to 2.1.22. The 23Fps option is good to avoid micro-shots in 23.976 videos, but for me even 25Fps works well, so..... all good and waiting for the next firmware!
     
  9. Aaron McFarland

    Aaron McFarland New Member

    Ok, I am trying to download this update and this 500 mb download, presently says it is going to take 7 days on my gigabit internet connection. Is there any other place I can download this update since this is download slower than dial up speeds?
     
  10. godalmighty

    godalmighty Active Member

    @Ekul said in this firmware, micro stutter is back
    my files almost all are 23.976 so i stay with this firmware
    my internet speed is low, only 3mbps it mean i only can download with +/-300kBps
    if you have a gigabit internet connection speed, dont know why it take 7day :(
    for me only take not more than 30minutes
    try vpn if maybe your country got bottleneck to the zidoo server
     
    Last edited: Jun 11, 2019 at 3:37 AM
  11. Ekul

    Ekul Member

    What i found out is stuttering only occurs with smb setting.
    Not with nfs. I need to investigate more.
    Too bad smb 2 and above not working with Zidoo.
    Smb 1 and nfs very risky protocols when using nas.
     
  12. giangi76

    giangi76 Member

    I use smb and I have no stuttering problem: 23,976 fps / 24 fps movies and TV series, 1080p and 4K, H.264 and HEVC: all good!!
     
    3DBuff likes this.
  13. giangi76

    giangi76 Member

    As promised, I tried (not with The Flash, but with another TV serie): 1080p, 23,976 fps webdl with DD+ 5.1 audio track. I watched 3 episodes one after another and never had a stuttering or any other kind of problem.
     
    3DBuff likes this.
  14. godalmighty

    godalmighty Active Member

    oh just for SMB
    lucky me, again, i dont use any NAS so i dont need smb protocol :D
    he said "in slowmotion"
    but i dont really know what it mean :(
     
  15. Ekul

    Ekul Member

    Thanks for testing, now i can investigate more.

    Its hard to explain, every 12 minutes the picture starts to shiffer, not the sound.
    Could it be a buffer or memory problem?
    The same file (in the same netwerk) plays ok with rpi3 in other room.
     
  16. 3DBuff

    3DBuff Active Member

    When the movie starts playing what do you see in the upper left corner? 23.976 or 23.97?
    I’ve seen it once with bad bad copy.
     
  17. Ekul

    Ekul Member

    I see 23.976 in the corner.
    Files must be ok because it runs ok when using nfs.
     
  18. 3DBuff

    3DBuff Active Member

    You could plug in laptop using Ethernet cable from Zidoo and download this file from SMB drive. This would validate your network setup. Anything over 10Mb/s should be OK for HD files. If your network and drives are in top shape you should see over 100Mb/s as consistent speed.
     
  19. Ekul

    Ekul Member

    Thank you all for advise, tips and testing.
    As i thought my stuttering only affected smb so i went back to nfs, and guess what, i was wrong and also saw stuttering.
    So to exclusie my network with qnap and r7000 had a problem i copied a episode to x9s internally.
    Good choice as i still saw slowmotion after 12 minutes, that narrowed my problem.
    Next i hooked x9s directly to my tv without receiver who i blamed then, so directly from internal mmc to tv. Same stuttering, so it could only be a x9s setting or hardware failure.
    Then i started to change settings and alot of testing.
    From original setting 10 bit, yvbr444 and auto i ended up with 10 and 12 bit off, ycbr rgb to auto and color range to 16-255.
    Now finally all episodes plays fine!
     

Share This Page