New firmware v2.0.5 version(beta) for ZIDOO X9S release

Discussion in 'X9S Official Firmware Releases' started by mirror, Jan 24, 2018.

  1. ursiel

    ursiel Active Member

    Yes, I'll give a blu-ray ISO a try this afternoon and report back.
     
  2. litlgi74

    litlgi74 Member

    Not for me...

    I can manually select the correct series and episode... but nothing happens, the episode remains in the unmatched section.
    20180320_121500.jpg

    The exact same thing happens for Duck Dynast, Game of Thrones, House, Firefly, The Tudors, Lost, The Sopranos, etc.
     
  3. godalmighty

    godalmighty Active Member

    i have no problem too with my all tv show collection, even with kodi, my "Heroes" collection somehow cannot detected
    with HT, scanned and scrapped it perfectly
     
  4. thrang

    thrang Member

    Did you have a chance to check? Thanks...
     
  5. ursiel

    ursiel Active Member

    Okay, so here's a new banding test while playing the UHD of "The Peanuts Movie". This is a great UHD movie to test on this player because it is very prone to heavy banding. It's also a very entertaining movie. This is tested on my x10 with v2.0.15.

    Banding
    --------------
    Matching my previous banding tests, here are the results when playing The Peanuts Movie in UHD/HDR (I only tried a few configurations):

    422 12bit/10bit - Heavy banding - absolutely unwatchable mess
    444 10bit - drastic improvement, still some annoying banding
    444 12bit - best - very minor banding, likely due to my panel - this looks the exact same as when I play the file directly from my TV's player via USB thumb drive, so it's as good as my panel can display.

    Bottom line - I would only want to watch UHD/HDR in 444/12bit. 422 is out of the question, and 444/10bit has less but still annoying banding.

    <<But -- 444/12bit has the frame stutter. Which means there is currently no usable configuration for UHD/HDR content on the Zidoo imo.>>

    So I ask Zidoo again -

    Why does 10 bit have noticeably heavier banding than 12bit for 444?

    I'm playing 10-bit content on my 10bit TV, so it shouldn't matter if I select 10bit or 12bit on the Zidoo - either way they should look the same. Yet I have repeatedly demonstrated that 12bit looks noticeably better than 10bit.
     
    Last edited: Mar 23, 2018
  6. ursiel

    ursiel Active Member

    I did test bookmarking on a blu-ray folder (x10/v2.0.15)

    Bookmarking works for full blu-ray folders when selecting "Play" from the pop-up menu asking if you want to open, play or play with menu. If you select "Play with menu", bookmarking doesn't work.

    Is this intended?
     
    Last edited: Mar 23, 2018
  7. ursiel

    ursiel Active Member

    Some other issues I came across tonight using the x10. I know the x9s doesn't by default include the illuminated remote, but it does work with it, so I'll post this here anyways:

    Skipping chapters
    -------------------------------

    There are 2 ways to skip chapters on the x10 using the deluxe illuminated remote:

    - using the left "page <>" toggle button on the remote, opposite "volume"
    - using the up/down parts of the 4-way pad on the remote

    Hitting the up/down sides of the 4-way pad skips chapters fine without issue.

    However, using the left "page <>" toggle button seems to have two conflicting functions. A fast press skips to the next or previous chapter, displaying the chapter number at the top left of the screen. However, if you hit it again before the chapter display disappears, or use a long press, it skips to the next or previous file in the folder. I have no issue with that particularly, but this causes a couple problems. You have to remember that if you want to skip chapters rapidly, you need to use the up/down parts of the 4-way pad, as that won't skip to the next file. If you try skipping chapters quickly with the left "page <>" toggle button, you will end up skipping to the next or previous file by mistake.

    But, a more annoying/sloppy issue with this:

    Each time you hit the left "page <>" toggle button to skip chapters, it displays this message in the upper-right corner, directly on top of the chapter number, making an unreadable mess (message depends on whether you hit previous or next):

    "hit next key again to play next file"
    "hit previous key again to play previous file"


    Worse, that message pops up and displays for only an instant - I mean a fraction of a second - not long enough to actually even read it. So it's very sloppy.

    Also, very annoyingly:

    You cannot skip chapters when viewing a full blu-ray using "play" from the pop-up option asking you if you want to "play" or "play with menu". The chapter buttons simply do not work. You get this message:

    "Video could not support this operation"

    Chapter skipping does work fine if you select "play with menu". So for some reason, if you select to play just the movie, you can't skip chapters.

    So, selecting "play" with the blu-ray pop-up box allows bookmarks to work, but you can't skip chapters. Selecting "play with menu" allows you to skip chapters, but bookmarking doesn't function.

    **Also, when playing a blu-ray disc or image, the number buttons on the remote do not skip to that percentage of the film (10%, 40%, etc.). They do work when selecting "play" without menu from the pop-up, or when playing single files. So full disc playback breaks that functionality too.
     
    Last edited: Mar 27, 2018
  8. HDMax

    HDMax New Member

    Looks like we're back to v2.0.5
    Are we playing Snakes & Ladders?
    Does anyone knows what's going on here ...Zidoo doesn't say anything !!!
     
  9. ursiel

    ursiel Active Member

    z10 v2.0.15.

    Problems with blu-ray extras - varying frame rates.
    -------------------------------------------------------------------------------------

    I was watching a full blu-ray folder this weekend, and the extras would not play properly. The main film played, but the extras had serious issues with frame rate blurring/choppiness. It was literally like watching a stop-motion film. I went back to the main menu, and started it up again, and then it played normal for a few minutes, then started playing all choppy/blurry again. The frame rate was all messed up and had weird motion blurring. This happened on both extras.

    I then coped just the .m2ts files for the extras and played them separately on the Zidoo, and they played at the correct frame rate with no blurring. The frame rate of the extras was 29.970.

    Also, the aspect ratio was correct when playing from the blu-ray menu - 16:9. However, when playing the separate .m2ts files, it played squished horizontally, with black bars on the sides. This is not how it should appear. This is the same issue I have posted about many times with DVD playback - playing in the wrong aspect ratio.

    It seems 720x480 files have aspect ratio issues with this player.

    --It also seems this player has issues with blu-rays that have different frame rates for different features (say 23.976 for the main film, and 29.970/25.000/50.000 for some extras, which is common on blu-rays).

    One of the big reasons I wanted this player was for the convenience of having full disc support, to be able to play the extras from the menu, instead of having to use makemkv to export each extra over separately, which is a pain, and results in a folder full of files which aren't labeled so I have no idea which extra is which. But it looks like the Zidoo can't even handle a blu-ray with mixed frame rates, which means it doesn't properly support full discs, as it will only play the main feature correctly, not the extras.

    Did Zidoo check anything before they released this player/firmware? It seems there's more things that are broken with this player than works correctly.
     
  10. ursiel

    ursiel Active Member

    Tried playing another blu-ray folder, and the first thing that appeared was the studio logo (Vestron), which was all messed up. Played all choppy and kept freezing for the first half of the 23 second logo, then smoothed out and played fine. I restarted the disc folder several times and each time the logo was messed up. It plays fine if I play the .mt2s file separately. The logo file is 1080p/23.976, so I have no idea why that is causing an issue.

    Looks to me like disc playback is a problem with the Zidoo.

    I also found that when playing a blu-ray disc or image, the number buttons on the remote do not skip to that percentage of the film (10%, 40%, etc.). They do work when selecting "play" without menu from the pop-up, or when playing single files. So full disc playback breaks that functionality too. I added this to my post above about "skipping chapters".

    And another sloppy typo I found - when you hit the audio button but there is only one audio track, a pop-up says "No more audios". Seriously? That's not proper English.
     
    Last edited: Mar 27, 2018
  11. ursiel

    ursiel Active Member

    Looks like every time I try to play something on this player, there's another issue I find.

    3D blu-ray ISO issues
    ------------------------------------

    x10 v2.0.15

    Tonight I tried playing a full 3D blu-ray ISO for the first time. The menu on this disc is in 3D, and the menu did indeed display in 3D properly. When I selected play from the disc's menu, it started by playing the standard copyright warnings and logos (in 2D), then the film began. Now, on the blu-ray player, the disc starts with the 3D menu, then cuts back to 2D for the warnings and logos, and then once the film begins, the player switches back to 3D automatically, and the TV detects it.

    Not with the Zidoo. Once it switched to 2D for the warnings and logos, it stayed in 2D, even after the movie started. I paused the film, then hit the menu button the on the remote to bring up the 3D option, but I discovered that bringing up the menu forces the movie to continue playing - it won't stay paused. What? So now the film is playing while I mess around with 3D settings. You can't pause it and then bring up the menu. Ugh.

    So then I see 3D_MVC is checked off, so the player says it's in 3D, but it wasn't. Manually putting the TV into 3D mode didn't work - the TV wanted me to either select under/over, side-by-side, or 2D>3D conversion mode, which means the TV wasn't receiving a 3D MVC signal from the Zidoo, or it would have switched right into true 3D when I hit the 3D button.

    I then discovered that I had to manually switch from 3D_MVC to 2D from Zidoo's menu, while the movie was still playing, then switch it back to 3D_MVC, then manually engage 3D mode on my TV, before the movie played in 3D. Once I switched from 3D>2D>3D, it didn't properly trigger the TV, so the image remained 2D until I hit the 3D button on the TV. At that point all was fine.

    So yeah, what a mess. I tried it again and the same exact procedure was necessary: Play the ISO>menu plays in 3D and TV automatically detects it>select play from disc menu>player switches to 2D for logos and warnings>3D movie starts but the Zidoo doesn't switch back to 3D>bring up Zidoo's menu while playing>switch from 3D_MVC to 2D>switch from 2D back to 3D_MVC>hit 3D button on the TV remote>hit the back button on the Zidoo remote to go back to the beginning of the film since I missed the first minute.

    From my blu-ray player, it's start disc>menu plays in 3D and TV automatically detects it>select play from disc menu>player switches to 2D for logos and warnings>3D movie starts and player switches back to 3D and the TV automatically detects it and goes back into 3D mode. I don't have to do anything but hit play to start.

    Has Zidoo actually tried testing anything on this player? So it looks like any time I play a full 3D disc that has a 3D menu and 2D logos, I have to play this back-and-forth game to get the Zidoo to play the 3D properly.

    And on top of that, of course I noticed a bunch of frame stutters throughout as always.
     
  12. ursiel

    ursiel Active Member

    MediaCenter/player crashing
    --------------------------------------------------

    I booted up the Zidoo last night and the first thing that happened during boot was a pop-up saying apps are starting. I'm sure that should not happen.

    Then I highlighted MediaCenter and immediately I got another popup saying MediaCenter has stopped working. After a few seconds I tried again and it worked. Then I started playing a full blu-ray disc, and as soon as I tried to navigate forward during playback using the remote's arrow buttons, another popup over the video saying navigation has stopped working, and the video player crashed and went back to the main screen. I tried again and then it played and navigated ok.

    I truly regret keeping this player. I knew I should have just returned it while I could.
     
  13. HaoSs

    HaoSs Well-Known Member Beta test group Contributor

    not sure if anyone still reads 2.0.5 topic when 2.0.15 is out for a week now.
     
    nikos_a and leonkoum like this.
  14. ursiel

    ursiel Active Member

    Is there a new thread for 2.0.15?

    I just checked last night on Zidoo's firmware download page for the x10 and the latest they list is still 1.4.12, and the latest for the x9s is still 2.0.5.
     
  15. tosh123

    tosh123 Member

    I assume its something like 24p...

    As stated often before, 422 - 10 Bit isn't allowed on 24/30p:
    https://www.hdmi.org/manufacturer/hdmi_2_0/hdmi_2_0_faq.aspx#146
     
  16. HaoSs

    HaoSs Well-Known Member Beta test group Contributor

    Check again. You are not locking in the right place if you missed the 2.0.15 firmware
     
  17. ursiel

    ursiel Active Member

    You're missing the point. I know this.

    It shouldn't matter if I'm sending 10-bit or 12-bit. The point is, I'm playing 10-bit content. So 10-bit content should look the same over 10-bit or 12-bit.

    But it doesn't on this player. 10bit looks worse than 12bit when playing 10-bit content.

    Why?

    When playing 10-bit content over 12bit, it should look identical to 10bit.
     
  18. ursiel

    ursiel Active Member

    Downloads>Media Player>x10> 1.4.12 is the latest posted.
    Downloads>Media Player>x9s> 2.0.5 is the latest posted.

    This is off their main page - you know, where new owners are likely to go looking for updates.

    If there are more recent official versions, then this is just another example of Zidoo's customer service if they can't even bother to update their main product pages' download section.
     
  19. Sascha0574

    Sascha0574 New Member

    Hi guys. New here, just got my x9s, so I got a question. It comes with a 1.4.16 firmware. But the downloads page gives 2.0.5 as latest firmware. Question is can I upgrade it straight to 2.0.5 or do I have to go step by step with previous versions first? Tried to find the answer to that here already with a search but came up with nothing. Auntie Google ain't that helpful either... Thanks
     
  20. DELUCAS

    DELUCAS Active Member

    Just upgrade straight to 2.0.5 all previous updates are in there so to speak .
     
    Sascha0574 likes this.

Share This Page