Jellyfin AndroidTV Client Thread

Discussion in 'Jellyfin for Zidoo' started by andy22, Jun 18, 2022.

Tags:
  1. Nathan W

    Nathan W Member

    anyone having issues with the next up/wait 10 seconds screen not appearing between episodes in 0.16.X vanilla edition on Z9X Pro (happens on .65 and .75fw)? Following an episode it just starts playing next one and makes exit behavior unreliable

    I've confirmed the settings within jellyfin are enabled and zidoo settings are set to only play 1 file.

    Downgrading back to 0.15.12 resolves issue. Curious if anyone has same issue or if I just need to do a purge of cache/settings/etc on my end
     
  2. Święty

    Święty New Member

    Similar issues here.
     
  3. Ordinator

    Ordinator New Member

    Does anyone know how to solve subs issue with official jf app?
    I'm currently using Andy's version, because you can't have both for some reason would be nice to have both.
     
  4. 3DBuff

    3DBuff Well-Known Member

    Quick note to finish off this topic.

    I couldn't find a way to play local files stored on USB drive from Andy's Jellyfin client and direct path. It plays all other locations except for local files. The same files are accessed without any issues from second Zidoo Z9X using direct path smb://smb_user:smb_password@Zidoo_Z9X/share/folder

    When direct path is enabled on local Zidoo the movie gets stuck forever with scrolling dots on opening screen with Zidoo front display showing 00:00:00. It works when direct path is disabled using Raspberry Pi 4 as Jellyfin server reading files off Zidoo SMB server and streaming it back to the same Zidoo. 40GB MKV files play without a single stutter, I can move back and forth on the timeline without any issues.

    All those local movies are included in HT 4.0 and preferred way to start this collection.

    This is to share my experience and save time for someone else trying it out with local drives.
     
  5. ya_boy_danny_rand

    ya_boy_danny_rand New Member


    I've been having the same issues with this since upgrading to v16+ and i'm on regular Z9X (non pro). something definitely broke on "next up" in that version and has persisted through all the recent versions. i'm thinking seriously about going back to 0.15.12 as the problem is quite annoying IMO.

    ***EDIT*** 16.6 was released a couple days ago and i tested it out and the issue is still there, so i rolled back to 0.15.12 and it's working correctly again. something else that was broken since v16 was if you have your zidoo set to show time remaining, once the next episode started to play it would bug out and just go back to the regular clock.
     
    Last edited: Feb 27, 2024
  6. Z49845

    Z49845 Member

    Is there a problem with certain characters in the filename when using Direct Path Play on the Zidoo?
    I use local paths and network share substitution in my libraries.

    This file does not play:
    "smb://user: password@192.168.178.37/share/Video_1-4/Filme_1-4/100% Wolf (2020)/100% Wolf (2020).mp4"

    But i i change it to "smb://user: password@192.168.178.37/share/Video_1-4/Filme_1-4/100 Prozent Wolf (2020)/100 Prozent Wolf (2020).mp4" then it plays without problems.
    I have a UHD3000 with firmware 6.4.65.
    Jellyfin server: jellyfin_10.8.13_windows-x64.exe
    Jellyfin Client: jellyfin-androidtv-v0.14.10-zidoo_edition-Android6-9.beta-release.apk
     
  7. robsainz

    robsainz New Member

    I've had problems with chinese and/or japanese characters in the filename/path. I would advise to take out any other special characters just to be safe.
     
  8. Sledgehamma

    Sledgehamma Well-Known Member

    Hey @andy22 were you be able to have a look at your changes and incorporating them upstream?
    I'm afraid that the upcoming 10.9 Jellyfin version might break compatibility with your current version.
     
  9. andy22

    andy22 Active Member

    Hiho, @Sledgehamma, no upstream changes yet.
    Still working on a "clean" base-version pull-requests, yet dev-time is still a issue. Main problem is that upstream and my org. changes did drift quite a bit, so getting them together is kinda rough and more work than i anticipated. Yet i daily drive the setup and in the worst case if 10.9 is incompatible, i'm forced to update either the old version or get my shit together for the "mini" version at least.
     
    Six66Mike, theory, 3DBuff and 4 others like this.
  10. Sledgehamma

    Sledgehamma Well-Known Member

    Thanks for the update! No worries mate, just glad you are still working on it :)
     
    Zaudio and Six66Mike like this.
  11. Yes, thanks for the update Andy. I'm still rocking your version and use it nightly. Don't know what I'd do without it lol.
     
  12. Forrest

    Forrest New Member

    Ok so I have tried searching for this issue, but haven't been able to find anything concrete.

    When attempting to play 96KHz FLAC files on my Jellyfin server I noticed every single output regardless of media defaulting to 48KHz. The only thing I could find online was some speculation that AndroidTV resamples everything to 48KHz, but that some external players are able to bypass this. I tested that theory by using MP7 to play a couple files I loaded up onto a USB drive. It worked! But I still want to use the Jellyfin client to interact with my media...

    This is where it gets weird. If I play a file using MP7 that is a higher sample rate FIRST then go into Jellyfin and play something of the same higher sample rate, it passes the 96KHz via HDMI just fine. Then as soon as you play something lower, it'll go back to resampling to 48KHz...

    Does anyone know of a way for the Jellyfin client to play native sample rates without the fuss OR somehow use MP7 for playback similar to an external player?
     
  13. dav

    dav New Member

    First of all, thank you very much, it works like a charm.
    The scraper is awesome and it uses the zidoo player perfectly.
    My set up consists in a local unraid server, a zidoo z9x pro.

    One question though, the home menu is not displayed properly, I can’t see the edges of the menu meaning I can’t see the first letter of the menu texts and also the last letter when some texts is at the far right of the screen.
    I’ve been everywhere in the app and can’t find where I can fix this :D

    If you could point me in the right direction.
    Thank you for your work. It is a relief I don’t have to do manual scraping with ht4.0…

    edit : my bad, resolution was not set to auto in the zidoo menu, now everything is ok
     
    Last edited: May 7, 2024
  14. Sledgehamma

    Sledgehamma Well-Known Member

    Seems that 10.9 didn't break anything :)
     
    Zaudio likes this.
  15. robsainz

    robsainz New Member

    So, i'm rocking andy's version of the jellyfin client for zidoo players (Z9X PRO), but it want to see how is the official version faring right now with the latest two or so updates but i don't want to lose my configuration on andy's client. Is there a way to backup my settings so i can go and try the official version and come back if i find it lacking?
    Or is there a way to have both versions installed as this was not possible back in december 2023?

    I've been testing server v 10.9 for a couple of days now and found out that it plays mostly fine with andy's version of the client, only failing to find files once in a while. Backing out and trying to play the file again usually fixes the error.
     
    Last edited: May 19, 2024
  16. Zaudio

    Zaudio Member

    I just updated my docker to 10.9.3
    Not tested with Andy's client yet, but one thing I noticed right away is that there is no way now to add or edit the direct network path for a library folder. For my existing library folders it shows the path under manage library - but I could not edit it without likely removing it I reckon (not even going to try!)... so hoping it still works for now with the existing paths.
    Wondering if it might be better to revert to the last 10.8... but I also have to then downgrade my other clients as they are warning the server needs to be 10.9 as of the next update.
    So what is going to happen going forward here... we need that direct path for best playback in the Zidoo using the native player; Andy's app will be broken for me without it as far as I'm concerned.
    @andy22 do you have any initial input on this?
     
  17. Zaudio

    Zaudio Member

    I did a little digging into my appdata, and found that the library options are an xml file, and in there I can see my network path still. So as long as the server keeps reading that and serving it to Andy's app now and going forward, then direct path should continue to work. I'd feel happier if Jellyfin were not deprecating the option though... as they might totally remove support for it one day???

    for example this is in my appdata\jellyfin\data\root\default\3D Legacy Movies\options.xml file

    <?xml version="1.0" encoding="utf-8"?>
    <LibraryOptions xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema">
    <EnablePhotos>true</EnablePhotos>
    <EnableRealtimeMonitor>false</EnableRealtimeMonitor>
    <EnableChapterImageExtraction>false</EnableChapterImageExtraction>
    <ExtractChapterImagesDuringLibraryScan>false</ExtractChapterImagesDuringLibraryScan>
    <PathInfos>
    <MediaPathInfo>
    <Path>/data/3dmovies</Path>
    <NetworkPath>smb://USERNAME|PASSWORD@IP/Video/3D</NetworkPath>
    </MediaPathInfo>
    </PathInfos>
     
  18. Zaudio

    Zaudio Member

    I did a quick test creating a new library. I edited the options.xml for it to add a network path. This did not show initially in Jellyfin under Manage Library... and in fact would get deleted from the xml file if I clicked 'OK' on that dialog. So I added it back and then restarted my JF server. THEN it shows in the library options... and stays there if I change some other option and save it. So seems for now we can use this to set the network path, and hoping it works OK in Andy's app.
    Someone should contact the JF team and make sure they keep it in the library schema, and let us keep using it with Andy's app so we can support Direct path on the zidoo
    EDIT: Can confirm that server 10.9.3 works fine with direct path with Andy's app, with the above proviso on setting it.
     
    Last edited: May 30, 2024 at 6:19 AM
    3DBuff likes this.

Share This Page