Jellyfin AndroidTV Client Thread

Discussion in 'Jellyfin for Zidoo' started by andy22, Jun 18, 2022.

  1. Lol, no doubt eh. I'd say I got a little carried away. I let a couple family members eat, but that's it.
  2. Zaudio

    Zaudio Member

    And I thought my 52Tb mirrored was getting large lol
  3. Markswift2003

    Markswift2003 Well-Known Member SUPER Administrator Beta test group Contributor

    Hard core :D
    martinstraka8282 likes this.
  4. IamSpectre

    IamSpectre New Member

    I Installed Andy's new client 0.14.10, Updated my direct path to shared folders. It now shows the filename playing instead of "Streaming" as it did before. Of course I had to check the box in settings to play the direct path option. Thanks Andy for the great work!
  5. IamSpectre

    IamSpectre New Member

    I don't know if it's just me but i don't remember scrolling up and down the home screen being this choppy. I am onAndy's new client 0.14.10, anyone else noticing this also?
  6. Zaudio

    Zaudio Member

    Wait for Andy to do his new lite version based of the latest 15 version. I'm using his old version still for the direct path, and yes I find scrolling through my wall quite choppy. The official version was much better, but that did not do true direct play, which I need. Andy's lite version should be the best of both I hope.
    Onwrathz and IamSpectre like this.
  7. Frostb!te

    Frostb!te Member

    Hi @andy22 I've read this on your roadmap: "working support for trailer/intro plugin's". Yesterday, I did some reasearch regarding the ability to play movie trailers before the actual movie starts like in the cinema: show trailers of recent movies and those about to be released soon. This is my summary of what I've figured out, given the latest Jellyfin Server v10.8.12 and the latest Jellyfin Android TV Client v0.15.12 (running on my Zidoo Z9S instead of your fork just for testing purposes):
    • There is no built-in function in Jellyfin that works anymore (even though there might be some ancient buttons without any funcitonality behind).
    • There are many plugins and forks but a lot of them are abandoned. I found those 2 plugins which are still maintained:
    1. and the related pre-roll community. They want to play splashy screens before a video starts like the Netflix logo. Afaik, they used to download the videos form somwhere automatically. Now, the plugin just plays files located in a specific folder. So you need fetch media files on your own. Thus, this could be used to playback trailers, as well. Somewhere I read about the tool called Backdroppr that might be used to automatically fetch movie trailers.
    2. This is my personal favorite. It fetches the trailers from tmdb and plays a random and configurable amount of trailers before the video starts: It works quite well, even on my Zidoo. You also need to enable "cinema mode" in the Android TV Jellyfin Client settings. The trailers are downloaded as plain readable files in the Jellyfin folder (mostly mp4). Perhaps, that might ease the integration of that feature/plugin into your fork. The only issues I had so far, were video stream freezes in some trailers (only the sound continued. Of course the player provided by Jellyfin was used).
  8. andy22

    andy22 Active Member

    yes, i'm aware of this. This was a side-effect after changing to a fully dynamic card/row layout. I never had the time to fully investigate this, so no idea if its actually the more complex android "layout" calls or maybe the image library used.
    This "dynamic" layout, will not be part of the "lite" version, so should behave normally.

    I guess if i want to get the dynamic layouts into the official version, this is something i would need to fix than.

    @Frostb!te thanks for the summary
    Oberon, dr4go, Zaudio and 2 others like this.
  9. 3DBuff

    3DBuff Well-Known Member

    I got direct path working for most of my collection where it matters the most. The benefit for me is the subtitles. The external subtitle files work now so is the downloading of the subtitles.

    I have a question here, one of my Z9X devices has 3 local hard drives. Jellyfin server is installed on RPi 4.
    Anyway to set up direct path on this Z9X client to play files from local drives?

    I tried 3 possible combinations without any success:

    1. smb://smb_user:smb_password@server_ip/share/folder - this gets into movie backdrop starting page with dots going forever
    2. /STORAGE/8ED032A8D.../folder - ZDMC path, no go, can't play this file
    3. usb://DriveName/folder - HT Source path, syntax error

    Any other ways or ideas?
  10. Frostb!te

    Frostb!te Member

    Afaik Jellyfin clients are thin-clients. They expect all media to be provided by the Jellyfin server. There is no local playback like Kodi/ZDMC as of now. Installing jellyfin server on Zidoo might be bit tricky. But you may try to enable the smb server on your Zidoo. Then on your RPi 4 create a media library fetching the data from your usb drives of your Zidoo. Enable direct path both in the client app and on the server. but in the path try to use as ip address something like or localhost or the ip of your Zidoo in doubt. So the jellyfin server would handover a file path that'd be resolved to a local (loopback device) file.

    Never tried this on my own. But it should work in my opinion.
  11. andy22

    andy22 Active Member

    yes, but now that you mention this, i never thought about this. Ofc you could just allow local paths and hand those to the player, instead of smb paths, similar to how nfs paths are supported.
    I think the biggest issue is the new file access restrictions inside Android 11, for the new devices.
    Not sure if this is better than just using smb via loopback.

    Not even possible, there is no arm version for the JF server.

    Might work, if the server can "see" the files via the zidoo smb-server.
    Frostb!te likes this.
  12. 3DBuff

    3DBuff Well-Known Member

    Thanks everybody for quick reply.

    The server is set up on Raspberry Pi 4 with another couple of local drives attached to it. I have multiple small SMB NAS servers around the house including 2x WD, Zidoo Z9X, RPi4 and Cisco router ;). All drives are in SMB protocol and mounted on RPi4. All those locations are fed to Jellyfin server on RPi4. I'm actually surprised how well it works and how stable it is. Without direct path I can play all files from all drives on any device, iPhones, laptops etc. using Jellyfin clients. It works well on Zidoo Z9X using Andy's client app or Android version without direct path. Zidoo Z9X can play local files through RPi server without a glitch. It streams 40GB 4K HDR files from local USB hard drive to RPi and back to the same Zidoo. No stutter or dropped frames whatsoever. I can move the time slider and the movie jumps forward and back without the problem. Info screen on Zidoo player shows Stream, wow.

    Now back to direct path. As suggested I already enabled the direct path on both server and client. This was option 1 listed above:
    1. smb://smb_user:smb_password@server_ip/share/folder - this gets into movie backdrop starting page with dots going forever

    Direct path works very well for all remote storage locations that I have except for local drives on Z9X. Opening screen gets stuck. It works on second Zidoo Z9X with direct path to first Zidoo.

    It's not the end of the world. Those are my good 4K movies and typically I play them from HT Zidoo app. The movies from this Zidoo play on other Jellyfin client devices like laptops or phones. They also play when I disable direct path :rolleyes:.
  13. 3DBuff

    3DBuff Well-Known Member

    @andy22, this is probably not that important since not too many people will have Jellyfin client on Zidoo with local drives.
    For this to work the client needs to be aware of local path like option 2 used by ZDMC or option 3 used by Home Theater app:

    2. /STORAGE/8ED032A8D.../folder - ZDMC path, no go, can't play this file
    3. usb://DriveName/folder - HT Source path, syntax error
  14. 3DBuff

    3DBuff Well-Known Member

    The direct path stored on the Server would work only for one device with local drives :(
  15. Frostb!te

    Frostb!te Member

    When you're referring to "server_ip", do you mean the ip of the Raspberry Pi 4 where Jellyfin runs or the Zidoo IP?

    Do you run a SMB server on your Zidoo Z9X?

    Can you playback those file located on your Zidoo Z9X drives from a different jellyfin client on your network, e.g. from you local PC with a browser?
  16. 3DBuff

    3DBuff Well-Known Member

    smb://smb_user:smb_password@server_ip/share/folder - this gets into movie backdrop starting page with dots going forever
    Server IP is Zidoo Z9X. I tried hostname and direct IP, no difference. "smb_user:smb_password" is from Zidoo Samba setup. I can browse and move files in and out of those Zidoo attached drives.
    Yes it works for me very well.
    Yes, those files play from the same Zidoo when direct path is OFF and from any other device with Jellyfin client or directly pointing to files on Zidoo shared dries with file browser and any capable player.
  17. Frostb!te

    Frostb!te Member

    Okay that's how I'd have set it up too in your case, hmm. "/STORAGE/" and "usb://DriveName" are probably some path descriptors that you've seen somewhere on the Zidoo, correct? Like the path that is shown by Zidoos media browser?
    The only thing that I would try is to remove the credentials in the path. In my standard setup it works just with the IP address. It even worked with the host name once in the past for me.
  18. I'd moved to the Android version, but then I'd gone back to Andy's version. I can't remember what I did previously, but I can't get Direct Play to work for the life of me. Wondering if anyone can offer any suggestions. I have a Windows based PC server running Jellyfin with an 8 bay Synology NAS on my network housing all my media. I can access the NAS SMB shares through the file manager on the Zidoo and direct play files through there fine.

    I can usually find my way eventually with help from the net, but in general, my IT knowledge/skills are very limited and setting up the NAS was a bit overwhelming in general.

    The warning when I try to play anything with the Direct Play option turned on in the app is always the one about setting up paths correctly with the suggested methods, so I'm assuming the issue lies solely with my path structure.

    My NAS is set up as 8 separate drives (Volumes 1-8) with parent folders all labeled and shared as PlexDrive1 through PlexDrive8. Each library will pull from more than one folder on different drives. Using the methods suggested, I tried both of the following.

    • smb://smb_user:smb_password@server_ip/share/folder
    • smb://smb_user@server_ip/share/folder
    My drive structure would be something like this with the top one being the parent folder, followed by the 2nd inside it, with the 3rd inside that one.

    -3D - Downloads
    -3D Documentary Shows - Downloads

    smb://G@###.###.###.###/PlexDrive7/3D - Downloads/3D Documentary Shows - Downloads

    I've also tried the above with the password included, as well as trying my admin user name and password for my NAS instead of the main regular user. Is there something obvious I'm missing here?
  19. Frostb!te

    Frostb!te Member

    Did you add the folders to the home theater app, too? Not sure if it's necessary but I do this all the time also as a fallback.
  20. I have not. I haven't touched the HT app since I initially tried it. Do you mean it may help Jellyfin in some roundabout way or just that I can use the HT app in a pinch if needed?

Share This Page