Jellyfin AndroidTV Client Thread

Discussion in 'Jellyfin for Zidoo' started by andy22, Jun 18, 2022.

  1. techos

    techos Member

    Further update.

    The official client does not work for me at all.

    When I set to external player, I just get the cannot play video error. Thats for fully local and also local (but via mergerfs/rclone)
  2. techos

    techos Member

    One more test to perform as I had the "shared network folder" applied for both libraries, with the SMB path. I will take that out when I test with the official client.

    Edit: made no difference.

    So as it stands for me:

    Z9x Pro

    Local server with mergerfs/rclone and also normal shared folder with a fully local file.

    works with andys build but ONLY on public smb share, wont work if I use credentials (maybe cos the credentials have spaces or special characters?) also only if I set the shared network folder and enable that function in his settings.

    doesn't work on the official build when I set to use external player - cannot play video error for both local and mergerfs/rclone files. tried to remove the smb path from the library to test, same error.

    all mkv files.
    Last edited: Oct 16, 2023
  3. 3DBuff

    3DBuff Well-Known Member

    I have official Android client on two Z9X (not PRO) players working pretty good with Raspberry Pi 4 as Jellyfin server. My hard drives are based on years of collecting of various devices attached in different places around the house. The hardest part was to mount and share those devices using SMB down to V1, local USB drives on RPi and USB drives on Z9X. At the end it all works pretty good. I do have direct path setup on the server and I use option to stream HVEC directly on player client side. Every share is locked with username and password accessible from RPi and Z9X itself. I can use Media Center from Zidoo home screen, navigate to the remote share and play the file by clicking on it. I'm assuming that those credentials stored in Zidoo networking are used when playing if from Jellyfin client and external Zidoo native player.

    Just want to share my setup as running on low power Linux RPi server with variety of devices not perfectly structured like Mark was showing off above ;)



  4. IamSpectre

    IamSpectre New Member

    Anyone having the problem with lyrics being shown in Chinese? My default language is set to English so not sure why this is happening. Any ideas?
  5. Zaudio

    Zaudio Member

    How do you know it is actually using the direct path to play with the External Zidoo player? I was using the official Android TV client, but it will not use the direct paths, and the devs confirm they do not use that option.
    You can check if it is using direct path by bringing up the info menu while playing; if the info has 'Stream' and no movie name, then you are streaming via the JF server still. I'd be very interested if you actually figured out a way to get the official app to make use of Direct path on the Zidoo, as I need that for stable playback; my JF server running in a container on my synology NAS, with traffic routing through there results in random 'frame skips' during playback. I do not get these at all playing directly with the zidoo player.
  6. Zaudio

    Zaudio Member

    A bit of a late reply, but this has been my experience also. I narrowed the cause down to where my JF server is running and how the official android TV JF app routes all streams through it so it can convert them to an http stream. You need to be able to direct play like Andy's fork can to avoid this. I just started using Andy's fork, despite it being old now, for this reason.
    Please go and vote here to persuade the JF devs to actually implement the direct path option for playback to external player:
    Last edited: Oct 24, 2023
  7. 3DBuff

    3DBuff Well-Known Member

    You are correct. The direct path was entered in Andy's JF version and maintained in official Android version. Any movie I play shows "Stream" instead of the movie title indicating that it's not using direct path. Here is something interesting. My main collection of 4K HDR movies is on Zidoo Z9X with 2 USB hard drives 8TB and 10TB plus 16TB SATA. I can play those movies 40GB files from JF official Android client on this very Zidoo Z9X without a glitch, even jumping the timeline. Info screen is showing "Stream". In order for this to work the file has to be sent from this Zidoo attached hard drive to Raspberry Pi 4 server that will send it back as a stream to the very same Zidoo Z9X. With all the issues that people complain how bad Zidoo is on networking and SAMBA I didn't think it was possible. I think the connection between Z9X and RPi goes through couple of switches on my Gigabit Network. Works so flawlessly that I didn't think it was streaming through RPi. Jellyfin server is running directly on Raspbian 64 bit without container.
  8. If it shows "stream", is that Direct Stream where it transcodes audio but leaves original video untouched?
  9. 3DBuff

    3DBuff Well-Known Member

    I don't know if there is a way to see what is original and what transcoded. Stream means it is sent from server (Raspberry Pi in my case) rather than reading the file directly from network NAS location.
    If you have one NAS like Synology with Jellyfin server loaded on it the direct path will be to SMB server on Synology and stream will be the the same file sent by Synology processor using Jellyfin server and reading it internally. It should be less process demanding using direct path.
  10. Ya doesn't seem to be a way to tell. I run a separate server from my NAS too, just PC based. I guess I was mostly wondering if what is reporting as stream on the Jellyfin is what they refer to at the link as "Direct Stream" and define as "Direct Stream: Transcodes audio but leaves original video untouched."
  11. 3DBuff

    3DBuff Well-Known Member

    You could probably explore the original file with media info tool and record audio and video info. Compare it to the info from Zidoo player during JF streaming and see if that changes.
  12. Ya I might check that out. I tried looking on the server end and can't tell anything there. The bit rates and audio/video codecs seemed like everything was playing as it should.

    On another note, I've found a significant issue with sorting that I hadn't noticed before because I usually peruse my library for a show or movie from another device like my phone or tablet, then just turn on the Zidoo in the theatre and load it up. The issue I've found is that when I change the sorting option like say from "last played" to "date added", only the first 4 or so rows are sorting correctly, then after that it's in the same order of movies no matter what sorting option I select.

    Anyone else notice that or mind checking?

    I found that if I force close the app in clean up or reboot the Zidoo, it will sort properly once, but then the next time I select a different sorting option, it does it again. Basically it means that after the first 4 or so rows, everything is in the same order no matter what sorting option I select. Because of what I said above, I don't even know if this was a gremlin that popped up or if it was always behaving this way.
  13. Six66Mike

    Six66Mike Member

    Yeah I checked on my Z9X, changed from A-Z to Premier Date, first 5 rows works backwards, then it's not even an alphabetical or release date sort, like the first one out of order starts with Among from 2002, then the dates and titles don't appear to be in any sort of order at all. I went back to A-Z and it was still messed up til I rebooted. I didn't try other sort options after that.
  14. Zaudio

    Zaudio Member

    Please do go vote for Jellyfin to add Direct path playback to the official app... I posted the link just above. The more people that vote, the more likely they might actually implement it. It was first requested in 2021!
  15. Damn, so it's not just me. I was hoping this was something that maybe just popped up on mine that I might be able to reverse by uninstalling and re-installing or something.

    Pretty tough detail with no workaround other than picking a movie on another device first, unfortunately.

    Does Andy's version still work fine? I might have to go back to that one.
  16. Zaudio

    Zaudio Member

    I'm using Andy's version with almost the latest server, so yes.
  17. Cool, thanks. I'll probably load it back up tonight.

    It's a shame, that issue above is my only complaint, but a bit of a deal breaker.
  18. I tried the newest beta version and had the same issues with sorting, so loaded up Andy's old version instead.

    Guess that Android app wasn't as good of a match as I thought. Does not display the same behavior on my Nvidia Shield.
  19. Six66Mike

    Six66Mike Member

    Did you raise a bug on their github?
  20. No I haven't. Do you mean the Jellyfin Github? Would this be a Jellyfin issue?

    Since the app works fine on my Nvidia Shield in another room, I assumed this was a Zidoo issue, and there doesn't seem to be much point to trying to bark up that tree.

    Edit: I went ahead and raised it on their Github
    Last edited: Nov 2, 2023

Share This Page