HDfury Vertex2 - Dynamic DV content from LLDV source on any HDR10 display

Discussion in 'HDD Media player(RTD 1619DR)' started by rozel, Oct 26, 2020.

  1. Markswift2003

    Markswift2003 Well-Known Member SUPER Administrator Beta test group Contributor

    If you're seeing "Dolby Vision VS10 Engine" then you haven't got the correct EDID set for the input you're using, you should see this.
    Ignore the two options above, they're on later Firmware, so you should just see Mapping HDR, SDR Rec.709, SDR Rec2020, LLDV and Auto.

    With the LLDV EDID set you should not see any VS10 options (at the moment)

    Your Vertex EDID page should look something like this (assuming you're using input 0):

  2. rozel

    rozel Well-Known Member

    Thanks @Markswift2003 but as I've said already, I'm not seeing the HDR screen on the Zidoo that you are. First pic = in HDR Auto : Second pic = when VS10 Engine is ticked. Third pic = my EDID screen from the webserver which matches yours. So I deduce, again as I've said already, that there's another setting in the Vertex2 that's wrong; the screen doesn't appear as yours because my Samsung doesn't support DV; or I'm running a different Zidoo Firmware. In this latter case I'm on the .45_G Firmware. I'm sure you can put me right :)

    Attached Files:

  3. Markswift2003

    Markswift2003 Well-Known Member SUPER Administrator Beta test group Contributor

    You've got Automix ticked, not Custom.

  4. skelton

    skelton Member

    So i finally got my Vertex2 yesterday and have been trying it out today with my Sony VW760 projector. I still find it a bit confusing with all the different options & settings but i followed the settings @Markswift2003 posted here earlier and have some questions i hope you can help with,

    I connected my sources/soundbar to the HDMI input 0 and projector to the TX0 output on Vertex. Here are some screenshots of my current settings, i didn't touch any settings on the other tabs except the EDID and HDR/AVI like was posted here. Can you check if these are correct? @Markswift2003
    Now i can see the LLDV output option under HDR settings in Zidoo but after playing some titles both SDR & HDR10, they look incredibly washed out with terrible black levels. This is due to the VS10 raised black floor issue i assume?
    But after selecting Auto in HDR settings instead, i now have a beautiful image for both SDR & HDR10 content. Very saturated and dynamic. So here's the part i don`t fully understand yet, what exactly is different from having the Zidoo in Auto HDR mode with Vertex in the videochain sending the custom EDID10 versus having Zidoo in Auto HDR mode without the Vertex in place?

    edid.png hdravi.png
  5. Markswift2003

    Markswift2003 Well-Known Member SUPER Administrator Beta test group Contributor

    Your settings look ok (I assume you have the Zidoo connected to Input 0, but when you took the screenshot the Zidoo was turned off.)

    If you can see LLDV under HDR settings then the EDID is set correctly.

    If you select LLDV and the image is washed out and colourless that means that the projector hasn't switched into HDR. This is what the Custom HDR string does. (Although very slightly elevated, LLDV does not have the same levels issue as VS10 HDR or VS10 SDR)

    Are you sure you created the HDR IF correctly in the HDR tab and then pressed "Create IF" followed by "Send HDR"?

    You can test this is working by ticking "Use custom HDR for TX0 and TX1 [ignore RX HDR]" which will send the custom HDR string regardless of input.

    If you set "Auto" in HDR then you're reverting to default behaviour, but, with the addition of the Vertex and an LLDV EDID, it will output LLDV if a compatible Dolby Vision file is played. All other files will play in their corresponding format - SDR > SDR, HDR > HDR.

    You can see exactly what's going into the Vertex (Rx) and what's going out (Tx) by ticking and unticking "Rx Video Info" then pressing "Send OSD Values" in the OSD tab:

    Last edited: Nov 4, 2020
  6. skelton

    skelton Member

    Yes, i am sure the projector is in HDR mode and i took these screenshots playing a mkv rip from the ultrahd Blu-Ray of 1917 (HDR10 only) The top pic is with LLDV output from Zidoo, as you can see the Vertex is showing HDR for the projector and i double checked the HDR settings on pj too and it's in auto HDR mode. Image is washed out and less dynamic compared to bottom pic

    The bottom pick is with Zidoo in Auto mode for HDR and this gives better contrast and looks more dynamic. So right now, the LLDV is showing a inferior image compared to outputting standard Auto HDR from Zidoo. Have to say i am quite disappointed after reading all the positive reviews from others but maybe there will be a fix for this raised black floor issue sometime down the road. But right now, i will go back to using Auto mode again.


  7. Markswift2003

    Markswift2003 Well-Known Member SUPER Administrator Beta test group Contributor

    I don't think this is caused by the black floor - it's just not that far out in VS10 LLDV.

    With my JVC the LLDV image is as good as the standard HDR image. The big plus is the ability to view HDR, SDR and LLDV content on the same level playing field without resyncs (a big issue with JVCs since it takes 12-15s to sync!)

    When you created the Custom HDR IF did you set as below with BT2020 primaries & 1000nit max lum and MaxCLL?


    The other thing with the JVC is I create my own gamma curves and I'm not sure how the Sonys handle HDR gamma - whether they use MaxCLL/FALL or not.. but I think gamma handling is where the problem lies.
  8. rozel

    rozel Well-Known Member

    Of course! I'm a complete muppet - I have not given the Vertex2's EDID tab too much attention. I'm grateful for you pointing out the obvious for me and for explaining the Zidoo's Display/HDR screen - cheers. It was the Zidoo's screen that confused me as it differs from yours and was convinced this was the issue.

    So I'm getting 12 bit LLDV now on the DV source title - But I have questions on the OSD: -
    1. Is it normal not to have a legible second line of narrative when viewing LLDV?
    2. Is 297 MHz correct?

    And after working out that I need to switch back to "Automix" for HDR10+ titles, I have further questions: -
    3. Is 371 MHz correct?

    4. I ask 2. and 3. because HDfury insist on having 600 MHz cables and this leads me to ask if I'm getting compressed Video and possibly Audio?

    5. My biggest grief with all this now is the constant resyncing - every time I stop a video the screen goes blan for a couple of seconds, comes back on then this repeats once more before getting back to original screen before you started the video. It is the same when starting a video and sometimes when flicking through the GUI. Is this a bug or is there a way to stop all this? I tried the Frame Switch Pause fix on another thread but this didn't seem to work - I paused for 3s - is this long enough?

    But slowly but surely now I'm getting the hang of things, just wish my Harmony Elite can be programmed with an Activity to incorporate all the settings needed to say start everything up and to make all the settings needed for either LLDV or HDR Auto (in both the Vertex2 and the Zidoo) and then close things down after playing. That would be good :)

    Attached Files:

  9. Markswift2003

    Markswift2003 Well-Known Member SUPER Administrator Beta test group Contributor

    Getting there mate!

    1. Yes - the second line shows the HDR SEI message which you don't get with LLDV.
    2. Yes - LLDV at 4K 422 12-bit is 8.9Gb/s which translates to 297MHz
    3. Yes - 397Mhz corresponds to 11.1Gb/s which at 23Hz translates to 4K 444 10-bit
    4. 600MHz or more correctly 597MHz applies only to 17.8Gb/s signals (4K60 422 12-bit or 444 8-bit)

    If you have 600MHz cables (aka 18Gb/s cables) you know they'll handle any signal you throw at them - this has nothing to do with video/audio compression.

    5. No, it's not a bug - all TVs have to resync when the HDMI mode changes. To reduce this set the gui to the same HDR mode, frame rate and resolution as your most prevalent content.

    In my case, my projector takes 12-15s to resync! I'd kill for a 3s resync!!

    So I set <HDR> to "LLDV...", <HDMI Mode> to "3840x2160p23Hz" because the vast majority of my content is 4K23 which means I get no resyncs for most movies when moving to and from the gui - The gui is presented in 4K23 LLDV and the content is in 4K23 LLDV.
  10. rozel

    rozel Well-Known Member

    Thank you! Where exactly are the GUI settings?
  11. Markswift2003

    Markswift2003 Well-Known Member SUPER Administrator Beta test group Contributor

    Set as below but change the HDR setting to LLDV and resolution (HDMI Mode) to whatever matches most of your content:

    Recommended Settings for RTD1619 Players
  12. rozel

    rozel Well-Known Member

    I am making these settings and am aware that each time I change the HDR Mode it changes the HDMI Mode from your 3840 x 2160p 23Hz setting - you advised me about this, so I always change it back. Doesn't matter if I forget to change it or I do, I'm getting extremely irritable resyncs.
  13. Markswift2003

    Markswift2003 Well-Known Member SUPER Administrator Beta test group Contributor

    What's your predominant type of content, 1920x1080 SDR or 3840x2160 HDR?
  14. rozel

    rozel Well-Known Member

    Good morning - 3840x2160 HDR
  15. Markswift2003

    Markswift2003 Well-Known Member SUPER Administrator Beta test group Contributor

    Ok, so if you set exactly like this there's no reason for your TV to resync when you play that content:

    Display/HDR: Dolby Vision Low Latency (LLDV,YUV422 12BIT)
    Display/Color Settings/4K 50~60Hz: Priority YUV420 10BIT
    Display/Color Settings/4K 23~30Hz: Priority YUV444 10BIT
    Display/Color Settings/Non-4K: Priority YUV444 8BIT
    Display/Color Settings/HDMI Color Region: 16-235
    Display/HDMI Mode: 3840x2160p 23Hz

    Those are the setting I use and I get zero resyncs on any 4K material (HDR or otherwise)

    If you go a step further and allow the Zidoo to upscale by setting:

    Playback/Automatic frame rate/Frame rate mode: Only Frame Rate

    You will then not get any resyncs for all 23.976fps content regardless of resolution which will be pretty much everything (with the odd 24fps exception and maybe a couple of 60fps videos)
  16. rozel

    rozel Well-Known Member

    @Markswift2003 - other than the frame rate setting, those are the settings I'm using and I use them in both LLDV mode or in HDR AUTO mode. I get resyncs regardless. But I will change the Frame Rate mode and report back.
  17. Markswift2003

    Markswift2003 Well-Known Member SUPER Administrator Beta test group Contributor

    As far as the Zidoo is concerned, the only changes that can cause a resync are frame rate changes, resolution changes or HDR changes. If those are static then something else is going on.

    I assume you have the Scaler turned off on the Vertex?
  18. rozel

    rozel Well-Known Member

    1. I of course assume that I should set in the Zidoo HDR to LLDV when playing DV material and HDR AUTO when I want to view other HDR10/HDR10+ material for best results. I get resyncs either way.
    2. Is my Scaling setup incorrect (see attachment)? This is the default as I've never changed it

    Attached Files:

  19. Markswift2003

    Markswift2003 Well-Known Member SUPER Administrator Beta test group Contributor

    1. If you chop and change HDR mode then of course it will resync! And if you leave in Auto, then again, of course it will resync. Just leave in LLDV.

    2. Technically that should work for TX0 but just turn off scaling and have done with it - so choose "No Scaling"

    I this scenario we are only using the Vertex to provide an LLDV EDID and spoof the outgoing HDR mode, nothing else.
  20. rozel

    rozel Well-Known Member

    @Markswift2003 Thank you. Yes I fully understand we are discussing LLDV and I'm learning all the time thanks to your superb support. However I have quite a number of HDR10+ titles and so to play these back in best possible quality, I assume I need to switch back to HDR AUTO and change the Vertex2 back to the "Automix" settings. I will of course choose "No Scaling" and experiment from there.

    If I have this right (and that will be a first lol!) let's wait now until we see what the new firmware brings to the table :)

Share This Page