Good news for you,The new firmware v1.0.3.1 for X9 release,Support 4k_24HZ

Discussion in 'ZIDOO X9' started by mirror, Apr 30, 2015.

  1. mirror

    mirror Well-Known Member SUPER Administrator Zidoo TECH Supporter

    Update list:

    1.Optimized Googleplay.

    2.Increase the support of Google TV remote control.

    3.Fixed the problem that Zidoo RC stops running.

    4.Add the output of 4k2k_24hz.


    1.Solved the problem that will stop recording automatically when the recorded file is more than 1.9G with the MP4 format, optimized to save the current recorded file automatically and automatically create a new file to go on recording.

    2.It will pop-up prompts when the storage is less than 100M, it will save the recorded files and stop recording automatically when the space is less than 50M.

    3.During recording, it can continue to record when the HDMI Input signal interrupts within 1min.


    1.Optimized the function of breakpoint play.

    2.Add support of Simplified Chinese coding in the subtitles.

    3.Optimized the display problem that controls menu when playing.

    Last edited: Apr 30, 2015
    dflamb likes this.
  2. bovoro

    bovoro Member

    that Greats im going to flash it right now!!!
  3. lc_lol

    lc_lol New Member

    bravo ! :)
  4. user59

    user59 Member

    All good Excellent

    HDMEDIA Member

    good job

    online update not work?
    Last edited: May 1, 2015
  6. TheMasterAsd

    TheMasterAsd New Member

    hi after local update i have black screen

    i see zidoo boot screen for a second
    hello on display
    but on tv blackscreen..
  7. TheMasterAsd

    TheMasterAsd New Member

    all work..remote connection..conect and i see all aplication

    but on tv i have blackscreen no signal
  8. TheMasterAsd

    TheMasterAsd New Member

    i have reset the zidoo...but nothing
  9. Dexos

    Dexos New Member

    i am going to suggest this is probable related to your tv not supporting the resolution or refresh rate during the update. this happens to me on my sony barvia yv but is not the case with a dynex tv i have. in my case i just wait for the update to finish. even though i cant see the progress. it has never failed. whatever you do dont power off zidoo. be patient.

  10. user59

    user59 Member

    Try another TV or monitor if you have and the HDMI cable.
  11. TheMasterAsd

    TheMasterAsd New Member

    nothing...i downgrade to 2.9..

    mirror in the firm 3.0 u solve the 1.9gb problem in hdmi rec..

    the problem is in the recording app??
    i replace my 2.9 rec app with the new a solution?
  12. warren_wh

    warren_wh Active Member Staff Member Zidoo TECH Supporter

    Has been updated successfully, try to switch the output by the "Display" of the remote control buttons.
  13. TheMasterAsd

    TheMasterAsd New Member

    I try "dispaly" change...blackscreen...

    The upgrade i thest to use new recorder application..export to new fw and instal on old..

    Itry to fix 1.9gb recording problem....
  14. papirus

    papirus Member


    After installing and trying v1.0.3.1 Release software on Zidoo X9, are we able to return back previous softwares ?
  15. TheMasterAsd

    TheMasterAsd New Member

    Plug usb with previus firm
    Boot in restore
  16. papirus

    papirus Member

  17. Scott

    Scott Member

    Why would you want to revert back to previous firmware version or is it because you may not like it or something ?
  18. Scott

    Scott Member

    When is this firmware release going to go OTA ? or is there a better version going OTA for May or June ?
  19. papirus

    papirus Member

    Hi ,

    The problems which still continuing on V. Release version :

    There are still some problems about subtitle selection issue.

    1-) 'Turkey' option should be changed to 'Turkish'.

    2-) That option sholud be stored in memory. This is a language prefer and it won't be changed by user often. It's so troublesome to select 'Turkey' option every watching.

    3-) This one is the most important: Although the video file name and the subtitle file name are the same, player does not select the correct subtitle automatically. While watching TV series which contains so many subtitle files in folder, its so challenging. The movie should be start automatically with the subtitle which has the same name with the movie file.

    4-) On the menu, selected file names sliding so slowly. Their slide speed should be increased. Its gonna be possible to read full file name more quickly with this change.

    5-) Devices own media player does not support the '.sub' format subtitles.

    These problems were reported to you before while using v1.2.0.9. But on the v1.0.3.1 Release version, they are still continuing.

    Also there are these problems additionally ;

    In Zidoo RC application, i cannot turn off the vibration in the program although it was turned off on my phone ( LG G2 ) settings. There must be an option about it, its important for battery life.

    Thanks for your concern.
    Last edited: Jun 9, 2015
  20. papirus

    papirus Member

    For example,
    When i tried to plug my USB 3.0 Hard Disk in the device , the display was gone (blackscreen) and after that the device rebooted itself.

    Besides, its always good to have an option to backup to previous versions on any device or technology. You know the challanges that the ios users are having. ;)

Share This Page