doesn't recognice hard drive 4tb

Discussion in 'ZIDOO X9S' started by hoplitas, Oct 16, 2017.

  1. hoplitas

    hoplitas New Member

    Ok, now I get the HDD working so...
    I'm not an expert but I think its a problem of power, I just get the HDD to be recognized by Zidoo with a hard drive docking station, HDD was recognized, so I tried again with SATA connection with the same HDD and again no way.
    I'm almost sure (I repeat, not an expert) via SATA the HDD has not enough power to be recognized by Zidoo (4tb and 2tb should need the same amount of "energy" but who knows...) , the HDD start to spin and you can hear it buzzing but not with enough "volume", its like a little buzzing, instead if you connect it via Docking station the buzzing is louder and appears in Zidoo explorer, ZDMZ, etc....
    So I'm happy because at least I can use both HDD 4tb, but sad because I have to use an external docking station, I prefer SATA connection because I suppose its faster but sometimes its the way it is.
    Thanks and maybe some expert can check the SATA connection with an ammeter o whatever, or maybe in future firmwares send more electric power via SATA, anyway thanks.
  2. HaoSs

    HaoSs Well-Known Member

    it may be that the sata port or cable is not performing as intended, i also have a X10 that uses the same x9s board and has the sata connector inside, work's fine with my hdd , i will test when i have time my x9s with the 4 TB and external sata cable, but i'm 99,9% sure it will work the same
  3. hoplitas

    hoplitas New Member

    Yeah, I use the SATA cable Zidoo provided, maybe I´ll buy one and try again, are cheap cables so...
    Thanks again.
  4. Nice Monkey

    Nice Monkey Well-Known Member Beta test group

    The supplied cable should work just fine. You may need to reformat the drive. SATA deployment is far more critical than USB for some minor variables.
    Remove all partitions including hidden and format with GPT + NTFS having it also SATA attached to a Windows PC. Guaranteed to work.
  5. hoplitas

    hoplitas New Member

    Thanks for the advice but I did that several times, tried whit Exfat, NTFS, GPT, MTB... all the alphabet soup and all the combination between them, I don't know why it didn't work, only works with an external docking station, and frankly I just copy a lot of movies again in the HDD and now it's full, so thanks again for the advice but for the moment I just use the docking station, I'm going to try again with the other HDD (same brand and model) but my hopes are no high, anyway I'll try again.
    I only will post if it's a success so if ther's no more post it's because it's not working.
    Thanks again, much appreciated, :):):), but sadly I know what's going to happen. :(
  6. Ayokoya

    Ayokoya Member

    If your X9S SATA works with 2TB drives, and openwrt sees the 4TB drive, then the power and cable are not at issue. Reformatting the 4TB will not work if openwrt partition editing altered some critical sector information that win7 does not touch, thats why you need to perform the command prompt clean operation to clean out everything.

    If you ever get another 4TB drive, you should just let win7 init it to GPT and format with NTFS first, and see if it works with your X9S SATA.
  7. hoplitas

    hoplitas New Member

    Thanks but...
    I did the last part, I put other 4TB drive (same brand and model) and format in windows 7 to GPS when win7 "saw" the HDD, after that, without any other partition, format in NTFS, didn't work, the only way my Zidoo sees the drive is with an external docking station, if I use this external docking the HDD start to spin and Zidoo sees the drive, if it's connected via SATA Zidoo HDD start to spin just a little and Zidoo never sees the drive...
    Believe me, I tried with 2 diferent 4TB HDD and it doesn't matter wich combination I used...
    GPT and NTFS.
    MTB and NTFS.
    GPT and Exfat.
    MBT and Exfat.
    All of this combination with the HDD format via opernwrt, via win10 or via win7.
    My Zidoo never sees 4TB HDD via SATA, start to spin very little but never spin "well", only via USB using external dock, if the HDD is 2TB there's no problem via SATA or USB.

    But thanks anyway
  8. Nice Monkey

    Nice Monkey Well-Known Member Beta test group

    Please read this one and report accordingly:
    You will see that many of the combinations tried don't make sense or don't even exist. Valid for a 4 TByte HDD are only GPT+NTFS and EXT4.
    MBR and GPT are Microsoft Windows partitions which work with NTFS/FAT32 formatting. MBR has a structural 2 TByte upperlimit. The exFAT format is meant for SD-Cards and USB-sticks solid state memory not for HDD's.

    If it does not work use the display command documented as this is the only way to see what is wrong:
    You can display all mentioned HDD format details using fsutil fsinfo ntfsinfo x: under Windows. This is a CMD to be executed with Admin rights! (Note x: replaces the actual drive being used).
    Use Minitool Partition Wizard Free for removal of partitions and formatting for optimal results. If a HDD was ever initiated as a system partition Windows will not remove the hidden backup partition anymore.

    Never seen a HDD which did not work via SATA and have seen many unless they are 4Kn types. Seagate Barracuda HDD's are 512e types as far as I know, but Seagate for sure makes 4Kn also.
    Last edited: Oct 25, 2017
  9. hoplitas

    hoplitas New Member

    But it didn't work.
    I downloaded Minitool Partition Wizard Free, removed al partitions (you were right there was a hidden partition not detected by windows), initiated and formated as GPT, wiped all data, formated the only partition as NTFS.
    After that I copied a movie in HDD and...
    as usual HDD wasn't recognized via SATA.
    When I connected via external dock it was ok.
    So I give up, I will use external dock because I don't want expending all my life trying to do it work via SATA, time is a valuable thing, it's not infinite...:(
    Thanks anyway.
  10. Sarco

    Sarco Active Member Beta test group

    This is the most powerfull cleaning disk:


  11. Teresa Parro

    Teresa Parro New Member

    hi i use a wd 4 tb and , not working :( the hd its new and working on windows, any idea?
  12. Nice Monkey

    Nice Monkey Well-Known Member Beta test group

    Please execute the windows display command. only then we know what we are talking about.:p
    Always specify the exact type of HDD you got, we can then look up the specifications. WD makes many types of 4 TByte hard disks.
    Last edited: Oct 28, 2017

Share This Page