DMP-A6 | Folder scanning bug?

Discussion in 'Eversolo DMP-A6' started by Bonobo, Jun 3, 2023.

  1. Bonobo

    Bonobo New Member

    I have another issue with my new DMP-A6:
    After adding a folder from my NAS via NFS, the scanning process starts automatically - or it can be initiated in the "three dots" menu.
    However, after the scanning process is completed, Music Player only shows subfolders with names from A to J, all other folders (K to Z) are missing.
    I've already tested the following:
    - Removed the folder connection, reboot the device, reconnect the NFS folder, rescan ---> same problem
    - Deleted characters like _ or ' in the path and file names of the first missing subfolder ---> same problem
    Sometimes the scan seems to abort at subfolder name "Jan..." , sometimes at "Jas...", not reproducibly at the same name.
    I have used this music collection on my NAS with Volumio devices for many years and never had this problem (just to say that I think I can exclude a major bug in my NFS server).
    Dear developers, could you please give me some hints what else I could try - or have an eye on the firmware?
    Current Firmware on my DMP-A6 is v1.1.46
    Thank your so far!
    Last edited: Jun 3, 2023
  2. mirror

    mirror Well-Known Member SUPER Administrator Zidoo TECH Supporter

    Upgrade to v1.1.60. if still has problem. please post here again. Our engineer will contact you.
  3. Bonobo

    Bonobo New Member

    thank you for your reply.
    After further testing I found out the following (just a few minutes ago):
    At the device, the folder list ist complete!
    Only in the Controller App the list is cut and incomplete.
    And more: In the app, the number of tracks shown after scanning the source is correct (the number right of the folder icon.
    So the bug seems to sit in the app, not in the device's firmware, right?
    Kopczas likes this.
  4. mirror

    mirror Well-Known Member SUPER Administrator Zidoo TECH Supporter

    The new version control APP should solved this issue please update it
  5. Bonobo

    Bonobo New Member

    Okay, thank you.
    I currently have the latest version of the app. So I'll see after the next update.
    Thanks for your support.
  6. mirror

    mirror Well-Known Member SUPER Administrator Zidoo TECH Supporter

  7. StefanKue

    StefanKue New Member

    I have problems with my NAS since first day. Scan works ok and it’s show all tracks, but after restart the folders appear „invalid“.
  8. Laz Arus

    Laz Arus New Member

    Hi, have only had my DMP-A6 for a few days now but I'm thoroughly enjoying its capabilities.

    I've noticed a "bug" which may have been alluded to earlier in this thread.

    After I have created a unique library entry (with the data residing on either the SSD or via my NAS), if I display the contents via the 'library' icon from the Music Player (ver. 1.10.59) itself on my Android phone, the listing only shows the first 100 entries. I have checked this on other created libraries and they all stop at 100 entries shown.

    I had a look to see if there was a specific setting to limit the entries shown to 100 but could not see any. I'm thinking it may have been a debugging setting done by the programmers but not removed before the official release.

    Hoping this can be resolved soon.

  9. theowad

    theowad New Member

    Same issue here,
    I have big network library and when I try to browse on my android phone using most recent APP \Music Player\Library\Library name\ click on library name and in the right top corner leave folder icon nothing displays on the screen, when click folder icon (it changes to files icon) only so many folders is being shown. When I do the same directly on the device it shows everything.
  10. wcseow

    wcseow Member

    I have the same behaviour. Every reboot I have to rescan the NAS folder, else I will get the attached message when I play any track.

    I am using SMB.

    I am not sure whether the same will happen if I used a internal SSD, thus am holding off getting a SSD

    Attached Files:

  11. wcseow

    wcseow Member

    I set my A6 to a fixed IP address instead of DHCP. By doing this it appears the issue is resolved. Tried a few resets/power on-off, it works all the time.

    Revert back to DHCP, issue reappear

    Desmodromic likes this.
  12. Desmodromic

    Desmodromic Member

    Very useful information, do you also have your NAS as a fixed IP?
  13. wcseow

    wcseow Member

    Yes, the network drive is on fixed IP. It is setup as that from day 1.
  14. Kopczas

    Kopczas Member

    So I`ve tried to turn off DHCP and still I can see folders from A to G in control app.
    On screen operations all folders are visible.
    Yes, app is the latest version.
    All files are on M2 drive.
  15. wcseow

    wcseow Member

    Sorry if I am not clear. The issue I face, similar to a StefanKue, is that library needs to be rescan after every reboot. In my case, static IP seems to resolve that

  16. Kopczas

    Kopczas Member

    I've created other thread with issue with my app but other member sent me here as in his opinion is the same problem ( which is not I guess).
  17. wcseow

    wcseow Member

    Ya. 2 issues being presented in this thread. I think the thread starter, Bonobo, issue should be similar to yours.
  18. Nutul

    Nutul Well-Known Member

    see post #3 in this thread by @Bonobo
  19. Ray77

    Ray77 Member

    Here is my experience so far..I have been listening to ripped music from my laptop via SMB, then via an external USB drive with a subset of same music, then transferring albums by artist name from this drive to the internal SSD. I think this is confusing the Music Player to no end! Its Library has scanned the USB/New volume (ext USB drive) and Eversolo folder in its internal 32 GB storage (no files). When I try to add a new Library, i.e. New Volume (SSD) it doesn't do anything. I have to click on New Volume on the device display to bring up the individual album files and select each one to add to the library. In this manner it is able to see all the files that I transferred from ext HD to SSD. I have only transferred artists up to "H" so far. I hope I can transfer all my music (A to Z) and have the Music Player recognize them under all categories (Artist, Album, etc.) I also notice that trying to search using (A to Z) and (Z to A) doesn't seem to work properly, at least for me.
  20. Jim Helman

    Jim Helman New Member

    HELP! I have a 2TB internal drive installed and formatted...I can "see" this. How the heck do I get the files from an external HD to transfer? I tried plugging the drive into the top USB-A input (USB OTG), but I can't "see" that on the A6...I tried thebrowser method, but cant get the browser pointed to the SSD drive...CLEARLY I am doing something wrong...Can you help??

Share This Page