Bricked the Z9S in the process of firmware upgrading...

Discussion in 'ZIDOO Z9S' started by Raymond Lim, Mar 8, 2020.

  1. Raymond Lim

    Raymond Lim New Member

    Guys, I've encountered what I believed to be a bootloader corruption. I tried the base firmware version 1.78 in an attempt to revive the device but to no avail. When switched on, there is no display and the bootloader just kept looping itself. For what its worth, I came across this so-called rescue X9S from brick firmware update and I wondered is there any for Z9S? here's the link: https://www.zidoo.tv/Support/support_guide/guide_target/LpUhOsHcwiveq7k9e[ld]3ulg==.html

    Is there a way to "revive" from this firmware issue? Or is this going to be another "paper-weight" for me?

    Any help appreciated.
     
  2. Markswift2003

    Markswift2003 Well-Known Member

    Daft questions, but need to be asked - did you follow these instructions to the letter?

    https://www.zidoo.tv/Support/support_guide/guide_target/ua1h3YuLrJzeq7k9e[ld]3ulg==.html

    And have you tried the process again? This procedure bypasses the OS with it's own bootloader and so should replace everything.

    Assuming yes to both then try the procedure you linked to but obviously using the full Z9S image. (if you don't have an extractor, I'd recommend UniExtract)
     
  3. Raymond Lim

    Raymond Lim New Member

    Thanks for the reply. I have tried everything and to no avail. I'm hoping Zidoo staff here can provide some in-house tips to get it working, if any.
     
  4. Nice Monkey

    Nice Monkey Well-Known Member Beta test group

    Got a box like that sitting here as well (send to me). No luck reviving it.
     
  5. Raymond Lim

    Raymond Lim New Member

    Sighz...:(
     
  6. Markswift2003

    Markswift2003 Well-Known Member

    I guess this is why we need simple firmware reversion...
     
  7. Nice Monkey

    Nice Monkey Well-Known Member Beta test group

    Agreed just tried the other day regresion worked on my Egreat A11 just fine. If necessary one can always do a factory reset next.
     
  8. woody

    woody Member

  9. Raymond Lim

    Raymond Lim New Member

  10. woody

    woody Member

    Ok no worries.

    Edit - I think I passed the wrong link too. Will check what actually worked and report later.

    I got into bootloop last year with my z9s. Tried this which worked for me and then never faced the issue over several updates. (Bootloop that is).

    I have gone back to base ROM couple of times and then step update to a stable version later on.

    Only encountered bootloop once as I said above.
     
    Last edited: Mar 10, 2020
    Siju Thomas likes this.
  11. Nice Monkey

    Nice Monkey Well-Known Member Beta test group

    You did not have the problem as the emergency ROM load process just worked for you. Restoring is very easy then.
    The player I have here shows UP _ _ or Boot (with and without pressing Reset at power-on) and next just shows the light on the flashdrive flickering.

    What happens: Nothing displayed on the TV screen and no update made in UP_ _ which it should do. :mad:
    What should happen: When releasing Reset the front display should change from UP _ _ to Hello and the update progress screen should be appearing on the TV attached concurrently.

    Trying to revive this unit for a fellow owner of a Z9S. No luck thus far.
    Followed the procedure using my own Z9S as a cross check. Just worked fine.
    The last OTA is apparently FW 2.2.82 and GAPP's is then not installed with it.
     
    Last edited: Mar 11, 2020
  12. woody

    woody Member

    Yes I am mistaken on what I actually did last year when I had the problem. Have updated my post above.
     
  13. Raymond Lim

    Raymond Lim New Member

    Thanks for trying to help. Truly appreciated.
     
  14. Raymond Lim

    Raymond Lim New Member

    Yes, Nice Monkey is right...this is precisely the problem which I faced...hope there is no need to reiterate the problem faced all over again.

    Still searching for a solution (still out there)...
     
  15. bob79

    bob79 New Member

    Hi,
    today I also rescued my Z9S with these instructions: https://www.zidoo.tv/Support/support_guide/guide_target/ua1h3YuLrJzeq7k9e[ld]3ulg==.html

    I needed it because I updated to firmware v2.3.10, but half of the apps crashed and showed white screen after open them.
    Then after few reboots the whole ZIDOO crashed after boot up and had a black screen blinking over and over.
    So fortunately I updated it with the image from above link successfully.
     
  16. ThomasP

    ThomasP Member

    You can wait until hell freezes over!
     
    bob79 likes this.
  17. Nice Monkey

    Nice Monkey Well-Known Member Beta test group

    The only thing that may work is using the JTAG connector on the mother board. With an active adapter cable from serial to TTL one can write directly to the Flash Memory.
    One needs such adapter, the program to do so and have the skills needed. I have none of those, but I know this method is actually used within the factory to get the initial programming loaded.
     

Share This Page