v1.2.8 Beta 5 OpenWRT NAS

Discussion in 'ZIDOO X9S' started by Ahmad Haghshenas, Dec 29, 2016.

Thread Status:
Not open for further replies.
  1. If i try to access the Zidoo NAS i can see my usb hard disk but if I try go into any folders i do not have permission. Anyone else try this on firmware 1.2.8 beta 5? On 1.2.7 it was all working fine.

  2. Here Is my Samba template.

    netbios name = |NAME|
    display charset = |CHARSET|
    # interfaces = |INTERFACES|
    server string = |DESCRIPTION|
    unix charset = |CHARSET|
    workgroup = |WORKGROUP|
    browseable = yes
    # deadtime = 30
    domain master = yes
    encrypt passwords = true
    enable core files = no
    guest account = nobody
    guest ok = yes
    invalid users = root
    local master = yes
    load printers = no
    map to guest = Bad User
    # max protocol = SMB2
    # min receivefile size = 16384
    null passwords = yes
    obey pam restrictions = yes
    os level = 20
    passdb backend = smbpasswd
    preferred master = yes
    printable = no
    security = user
    smb encrypt = disabled
    smb passwd file = /etc/samba/smbpasswd
    # socket options = TCP_NODELAY IPTOS_LOWDELAY
    syslog = 2
    # use sendfile = yes
    writeable = yes
    min receivefile size = 512
    use sendfile = true
    aio read size = 4096
    aio write size = 4096
    write cache size = 1024000
    read raw = yes
    write raw = yes
    getwd cache = yes
    oplocks = yes
    #max xmit = 65535
    max xmit = 131072
    dead time = 15
    large readwrite = yes

    path = /mnt
    read only = no
    guest ok = yes
  3. thaiminhan

    thaiminhan Member Beta test group

    how can i get beta firmware ?

  4. Update list of v1.2.8_Beta_5 for X9S

    1,Added the 3D playback function of MVC MKV.
    2,Increased the buffer of DTS HD audio from 100ms to 300ms.
    3,Forced the wifi reconnection once it lost connection.
    4,Fixed the stutter problem when the video loaded a sort of very special subtitle.
    5,Fixed some Ethernet problems.
    6,Fixed the issue that VFD settings can't be saved after hibernate.
    7,Added and updated more languages.
    8,Added a QuickSettings.
    9,Added the root function.
    10,Fixed a rare event that the resolution changes to 720P when the box boot up.

    1,Removed the popup window when user quit the external playback.

    1,Fixed the issue that the video which fps greater than 24.5HZ is identified as 25HZ video.
    2,Fixed the issue that sometimes the HDR doesn't work.
    3,Optimized the way to autoswitch.

    1,Fixed the estimation error of free space when saving the recorded file.
    2,Enhanced the effect of display from HDMI IN.
    3,The video with Interlaced frames from HDMI IN could been displayed correctly.
    4,Optimized the detection of writable property of path.

    1,Delete the path of NFS and SMB after quit the Filemanager.
    2,Resolved the crash when run a APP at the same time insert a U-disk.
    3,Resolved the abnormal display of files when the NFS or SMB disconnected.
    4,Resolved the crash when user view the bluray folder in NFS.
    5,Resolved the crash when delete the files all-selected and at the same time the files list more than one screen.
    6,When copy files,if the file size is 0,then the progress bar on account of the number of files.
    7,Changed the progress bar of deletation.
    8,Fixed the issue that can't open the share folder.
    9,Fixed the issue that can't enter the SMB share folder if the folder's name include a blank space.
    10,Restored the funtion of hidden files.

    Zidoo theater:
    1,Added some prompts.
    2,Optimized the series classfication.

    Beta version only for invited users.
    There are risks of bricking and you have to have skills in flashing a ROM.

    Mediafire mirror:http://www.mediafire.com/file/h5xd9lyr13s48fl/ZIDOO_X9S_OTA-v1.2.8.5_Beta_5.zip
    Amazon mirror:http://ota-cloudfront.zidoo.tv/X9S/OTA/ZIDOO_X9S_OTA-v1.2.8.5_Beta_5.zip
    Google drive:https://drive.google.com/file/d/0By6Gyfuj2nqabW9URmVFalI3ZGM/view?usp=sharing
    China mirror:下载链接:http://pan.baidu.com/s/1bpBrf1H 密码:acv1

    How to upgrade: http://www.zidoo.tv/Support/guide/guide_target/7kv1voas1D1KKmVViAFMcQ==/guide_faq/CN6lY0XMyIg=/faq_page/9nCdOWqz+dw=.html

    Onekeyroot for v1.2.8 :http://ota-cloudfront.zidoo.tv/X9S/ZDMC/OnkeyRoot_1.1.4.apk

    if you want to use zdmc to manage the files, such as delete/copy file in zdmc, you must re-install this version. we add a system signature for this version.
    The new version ZDMC:http://ota-cloudfront.zidoo.tv/X9S/ZDMC/zdmc161221-16.4.10_system_sign.apk
    pirmas and thaiminhan like this.
  5. thaiminhan

    thaiminhan Member Beta test group

    thankyou ahmad-haghshenas
  6. agmarco

    agmarco Member

    I wonder if there is a beta version also for X8. And I don't see the fix for USB sound issue with remotes like Mele F10. Hope this onekeyroot is also working for the X8?
    Last edited: Dec 29, 2016
  7. thaiminhan

    thaiminhan Member Beta test group

    Config above using for Domain. if you didnt use Domain. trying change three lines:

    domain master = no
    local master = no
    preferred master = auto

    optional :
    dead time = 15 # disconnect idle user in 15 minutes. if no need for terminate. comment or change value to zero.

    hope this help :)
  8. Thanks gave it a try but still no access
  9. thaiminhan

    thaiminhan Member Beta test group

    have you restart the box? its working on mybox with ntfs fs 3TB connexted via Sata port.

    another option. change all three line to auto.

    this works with me also
  10. I did restart yes. Will try all auto next. Dont want to do a full recovery to find out it still not gonna work after that. 2 days left for me till 2017 lets see the official 1.2.8 is out with audio remote support
  11. thaiminhan

    thaiminhan Member Beta test group

    no need to factory or full recovery. just clean "overlay" partition in SSH access and reboot then it'll reset your "OPENWRT" to default settings without affect to Android.

    rm -rf /overlay/*
  12. Thanks for the help. It is working now. Im happy
  13. Kurt

    Kurt Member

    Hi, 2 questions on the 1.2.8 update

    1. I see no mention of a schedule save for recording. Is this correct that we still can not save a schedule?
    2. You need to add a new version of zdmc if you want to use it to copy/paste etc..
    Will copy/paste etc.. functions work with kodi 17 ??

  14. Scofield1986

    Scofield1986 New Member

    i want install ZDMc from above but App cant install
  15. Kurt

    Kurt Member

    Same here, the new ZDMC app will not install
  16. Kurt

    Kurt Member

    Can not use copy/paste etc.. with Kodi 17 RC after installing 1.2.8 beta 5 & root app
    (also tried installing kodi 17 again after the root)
    New ZDMC will not install after installing 1.2.8

    UPDATE: You need to uninstall old ZDMC first, then install the new version.
    However still cant get kodi 17 RC to be rooted where delete, paste, etc.. work
    Last edited: Dec 31, 2016

    HDMEDIA Member

    Arabic cp1256 SRT subtitle encoding not work
  18. thaiminhan

    thaiminhan Member Beta test group

    so. you can rename zdmc data file in Android folder before remove old version of zdmc and install new then rename back the zdmc data folder to keep old settings and add-ons
  19. Kurt

    Kurt Member

    I tried the renaming trick to install a fresh version of 17 beta.
    Works great to install multiple versions, but new fresh version still has no root access to delete files
  20. saeeddos

    saeeddos New Member

    Arabic cp1256 SRT subtitle encoding not work,please arrange to fix the Arabic encoding
    HDMEDIA likes this.
Thread Status:
Not open for further replies.

Share This Page