ZDMC release 20.1 (x8/x9s/x10)

Discussion in 'HDD Media player(RTD 1295)' started by bob, Jul 31, 2017.

  1. Claudiu

    Claudiu Member

    With this last version (17.6), I have a problem with changing refresh rates and resolution. If I set the resolution in Kodi 1080p and refresh rate at 24, normally, when I launch a 1080p24 movie there shoudn't be any changes in resolution, no? Well, my tv (LG oled C7) changes resolution eacht time, from 1080p24 to 1080p24, which I find really annoying. When the movie ends, its's doing the same thing, it reverts from 1080p24 to 1080p24. The switch to adjust refresh in Kodi is Off, I am using external player, X10 resolution is also 1080p24 and I have auto change resolution and framerate enabled in external default player. It didn't do this with previous versions, although I only tested that just a few times, as the tv is new.

    Any ideea? I guess if resolution and refresh rate is the same, it shouldn't change it, no?
  2. HaoSs

    HaoSs Well-Known Member

    Try the kodi option from off to always. Strange your TV does that
  3. Claudiu

    Claudiu Member

    Apparently it depends on the file used. For some it changes the resolution, for some, it doesn't. Really strange. As at the end they are all 1080p24 and that's the resolution and refresh indicated by the box in the upper right corner.
    What I am trying to do is let the tv set do the upscaling, as I guess it would be better, and make the X10 send the video as is. I am using external player with the option of changing the resolution and refresh checked.
    But I hate changing the resolution and refresh when launching a movie, when they are already set at the same values. I could set the external player not to change them and always send at 2160p24, but as I already said, I would like to let the tv do the upscaling.
  4. Celuloso

    Celuloso New Member

    I have a X8 and I want to update my ZDMC. I have uninstalled the previous version and I have installed the new one. But when I run the ZDMC, the screen goes black. Any tips about it?
  5. HaoSs

    HaoSs Well-Known Member

    make sure you are on latest firmware
  6. naddude

    naddude New Member


    New to this forum. I have an X6 Pro and wnat to update Kodi. From what I have read on these boards:
    1. I must update the firm ware
    2. update XMBC rahter than simply update kodi through playstore.
    Is this correct and if so can someone point ot links for latest firmware and XMBC and just briefly outline steps to take to do all?
    Also I understand that the Android OS (now 5) cannot be updated? Is that true?
  7. HaoSs

    HaoSs Well-Known Member

    1) there is no more firmware for x6 pro, last one was half a year ago
    2) doe to rockchip SOC, you can't just update kodi ( XBMC is the old name used years ago )
    2.1) you remain on ZDMC that was made for x6 pro ( NOT THIS ONE FROM THIS TOPIC)
    2.2) you install latest kodi and see if it works for you ( some function will most likely be broken )
  8. naddude

    naddude New Member


    Thank you for this information.
    Too bad Zidoo is not supporting the X6 by updating the firmware & ZDMC.
    Can you install Kodi 17 along side of the ZDMC or will it overwrite it?

    Thanks again!
  9. HaoSs

    HaoSs Well-Known Member

  10. naddude

    naddude New Member

    OK. That's great that way I can test Kodi 17 without losing the functionality of ZDMC. I am guess that I select new and not update and download Kodi from the Kodi site and not Android play?

  11. HaoSs

    HaoSs Well-Known Member

    sorry. yes as it will overwrite it
  12. naddude

    naddude New Member


    SO I am stuck with Kodi 16 until or if Zidoo ever updates ZDMC.

    Thanks for clarifying.
  13. paulschmidt

    paulschmidt New Member

    i have the Firmware 1.4.12.
    Work the zdmc 17.6 with this?
    With the newer Firmwares i have big Problems with external srt
  14. Compuman

    Compuman New Member

    I have firmware 1.4.12 and i use ZDMC 17.6 without problem on Zidoo X8

    My question is on ZDMC 17.6 vs KODI 17.6

    With ZDMC all works ok, external player look great ... but is an external player...
    -ZDMC not update the watch/unwatch check
    -when play video, the ZDMC subtitle service are inusable... the subtitles are managed bu the external player...

    So i tested KODI 17.6
    The player for video is "internal" in KODI, watch/unwatch works, subtitles service works...

    So I search for main difference and I found that in OLD KODI DTS not works...
    So I tryed a movie with DTS AUDIO and it works well like in ZDMC

    The only difference that I see is that ZDMC switch to 1080p 24 fps when I see a movie (I'm italian) meanwhile KODI not do this... but I not search the settings,
    maybe I have to set on some settings ?

    There are other difference between ZDMC and KODI ?

    ok, the 24fps seems to be a big problem... some video loss sync from audio/video in KODI
    So i return to ZDMC with external player
    Now the video is perfect, audio/video not loss sync and it all allright...

    But the question now is:
    can we configure subtitles service?
    or the configuration is only the default in firmware 1.4.12?

    ok, after some days of testing I can say that ZDMC works well for movie and tvshow
    (subtitles are downloaded from the zidoo default server, but at the end... it works)

    Now after I have decided to use ZDMC, I installed all the addon that I used with KODI and i found another problem...
    With ZDMC the IPTV channel that use f4mtester as proxy, not work at all!!!
    The Zidoo player start with an error and the video stream not start

    I have to use KODI with the same addons that works fine like always.

    Any idea how to use this addons (f4mtester+iptv video addons) with ZDMC 17.6 ?

    UPDATE 3:
    now I am on firmware 1.5.0 but I think that this make no difference for this problem...

    I tried to set the zidoo player as the default KODI external player (to have the last KODI installed) but I found some problem that I didn't understand...
    On a terminal console the command works... but when it is lanched from KODI like externalk player it seems not to work... maybe ZDMC is lanched from a different user ?
    I use this settings:

    <player name="Gallery" type="ExternalPlayer" audio="true" video="true">
    <args>start -n com.android.gallery3d/.app.MovieActivity -d {1} --user 0</args>

    I add --user 0 because I tried the command on a console and without that options the player not works...
    But in KODI also with that option set .... it seems not to work (the LOG not help much... it say that there is a exception in lanching "am")

    I found the solution for my problem editing the default filetypes associated to ZidooPlayer on ZDMC...
    So now ZDMC start internal player for streaming channel... and I can use ZDMC for all.

    BUT obviously I wish to use KODI with ZidooPlayer as default player... can someone help in this quest ?
    Last edited: Jan 6, 2018
    videobruce likes this.
  15. Max69

    Max69 New Member

    how did you do?
  16. Compuman

    Compuman New Member

    Like the original KODI have a setting in
    ZDMC have the same settings in

    (I think you need root)

    this the file with the default settings

    I change the extensions associated to ZidooPlayer.

    For my quest:
    the same settings in KODI configuration file, not launch the zidoo player as external player...
  17. PacoRabanne

    PacoRabanne Well-Known Member Beta test group

    Compuman, please, how have you changed extensions associated to ZidooPlayer?
    P.S. I'm also italian, if you prefer you can answer me in PM using italian.

  18. cesarleeds

    cesarleeds New Member

    What happened to 3D on this latest ZDMC 17.6 release?

    It has stopped working for me.
  19. SaskMedia

    SaskMedia Member

    Mine works. Make sure the “change frame rate” setting is set to either “on start/stop” or “always” within zdmc playback settings. If it’s already set you might have to change it and then change it back.
    cesarleeds likes this.
  20. For some movies it works automatically. and for others not, In the other version it was perfect

Share This Page