ZDMC 19.1 Will Not Read .nfo, -fanart.jpg or -poster.jpg Files

Discussion in 'HDD Media player(RTD 1619DR)' started by BigPines, Dec 28, 2022.

  1. BigPines

    BigPines New Member

    I have been using a HiMedia Q10 Pro for years. I am trying to make the switch to the Z9X. I thought this should be pretty straight forward but I have been working on this for two days straight and I am having nothing but trouble.

    My current issue is that when I set up an smb share source in ZDMC and scan it to import my library, ZDMC ignores the existing local .nfo, -fanart.jpg and -poster.jpg files which are saved along side each .mkv video file in their own folders. It will only attempt to scrape new info from The Movie Database or the Movie Database Python scrapers. If I select "Local information only" it will not import anything into the library. What is even more annoying is that neither The Movie Database or the Movie Database Python scrapers will bring in poster or fanart during the scrape. When I try to manually add poster, fanart or thumbnail art to a video after the scrape, ZDMC immediately crashes! So I am left with a really ugly library which I cannot fix. I also had my very large library meticulously maintained so it is a huge disappointment that it will not simply import like it did on the HiMedia.

    My HiMedia was running Kodi 16.1 when I exported the library as separate files. I would think ZDMC 19.1 would be happy with the .nfo, -fanart.jpg and -poster.jpg files exported from Kodi 16.1.

    Has anyone else experienced this or know how to work around it?
  2. Phil181

    Phil181 Active Member

    Not sure what your problem is with scraping but I moved successfully from a Q10 Pro to a Z1000 Pro using ZDMC 19.4 (even swapped over the internal HDD).
    I'd suggest updating to ZDMC 19.4 and see how that works for you. I was running Kodi 19.3 on the HiMedia so I don't know why you stayed at 16.1 for so long (I do recall Kodi 19.0 and 19.1 having issues when released, fixed by19.2)?

    I did a test on one NAS folder, using TinyMediaManager, which creates .nfo and thumbnails etc and had no issues with ZDMC recognising those new files.
    A rescan to update Library should usually find all the files (as long as Sources are correctly set up).
    BigPines likes this.
  3. LarryZ

    LarryZ Member

    The format of the nfo files and the place and name where poster and fanart files are stored has changed between version 16 and 19, so it seems it is incompatible.
    BigPines likes this.
  4. BigPines

    BigPines New Member

    Thank you for your response.

    I stayed on 16.1 for so long because I have a highly customized skin and got tired of keeping it in sync with every version which came out. The new versions also had too many breaking changes and I was tired of constantly fixing stuff. I want a media player to play media, I don't want a tinker hobby. :) 16.1 did everything I wanted so there was no need to mess things up with new versions every few weeks which offered no benefit.

    Unfortunately, I tried ZDMC 19.4. Same exact behavior! I am wondering if it has anything to do with security settings or the SMB share or something. Video files play off it fine but it seems to ignore everything else. The crashing when I try to change the artwork is super annoying.

    I just tried vanilla KODI 19.3 (installed from Google Play). Same exact behavior. Won't load any library info. Crashes when I try to change the artwork.

    I don't know if I can install 16.1 on the z9X but I am going to try that next. :(
    Last edited: Dec 30, 2022
  5. BigPines

    BigPines New Member

    Thank you. That would explain part of what I am seeing.

    I am looking for documentation on what Kodi 19 wants as far as local .nfo, -fanart.jpg and -poster.jpg files. Could you by chance point me to a resource for this info?
  6. Phil181

    Phil181 Active Member

    You will find this in lots of detail on the Kodi forum. ZDMC is simply a fork of Kodi and works the same but uses the Zidoo hardware player for seamless high quality media playing (using Zidoo Settings).

    An excellent Zidoo resource is @McBluna's website. https://www.mcbluna.net/wp/
    You will find links and information for TinyMediaManager (which does what you want and is also compatible with HT4), latest ZDMC and even Zidoo firmware updates, as well as lots of other stuff that may be of interest to you (Handbrake, MediaInfo etc).
    BigPines likes this.
  7. BigPines

    BigPines New Member

    I just installed vanilla Kody 16.1 on the Z9X running firmware 6.4.42. I get an error when Kodi initially boots saying "Kodi Detected problems with app native libraries (please consult log for detail): libkodi.so:text relocations". I haven't looked into that further yet.

    However, this version DOES scan my library, brings in all the .nfo data including my collections and the poster and fanart! Progress! Videos play using the Kodi player so I am not getting 3D or lossless audio. I am assuming I would need the external player / wrapper configured to get that stuff.

    So there is something different about Kodi 19.1-19.4 which is causing me a problem. I am wondering if I can incrementally upgrade Kodi to bring my library up to date.

    I did another experiment. I deleted all .nfo, -fanart.jpg and -poster.jpg files out of one of my movie folders and did a scan on it using ZDMC 19.4. It scanned in with art (first time I got v19 to do that). However, when I tried changing the art, it crashed like it always does. This rules out my library files as being the cause of this bug. I then exported the library files back into that movie directory. The files exported were named exactly as my old files were named .nfo, -fanart.jpg and -poster.jpg. So v19 works the same in that regard. I then deleted the movie from the library and attempted to import the movie back in using the new .nfo, -fanart.jpg and -poster.jpg files exported from v19. It failed to import the art just like it did on my library exported from Kodi 16.1. Looks like a bug to me. It can't even import files exported from the same version!

    I will install newer and newer versions until the library stuff breaks so at least I know where that is happening.

    Crazy that nobody else seems to be experiencing this. Maybe not very many people are using Kodi on this device? Seems odd to me.
    Last edited: Dec 30, 2022
  8. BigPines

    BigPines New Member

    What version of firmware are you on? Maybe I'll try to recreate your setup.
  9. Phil181

    Phil181 Active Member

    There was one recent firmware update that had a big (poor) impact on ZDMC. It got fixed very quickly and the current firmware v6.4.42 works well with ZDMC 19.4
    Go to Settings/Update and tick "allow beta" and v6.4.42 should install for you OTA.

    Kodi did changes to the database in the major update from 18 to 19 and they had to be recompiled (and I recall 19.0 was a disaster on the HiMedia and many Android devices).
    You can keep trying old versions of Kodi on your Zidoo, but they won't use the hardware video player and won't provide audio passthrough correctly.

    I would suggest re-setting your Zidoo, updating firmware and a fresh install of ZDMC 19.4
    You may need to ensure SMB is set correctly in Kodi settings for it to find your network.
    Then select all your sources (use Zeroconf browser for locating network sources) and let it scrape your system......
    Good luck!
  10. BigPines

    BigPines New Member

    My Z9X has firmware 6.4.42 G. I have tried ZDMC 19.4, 19.1, 18.9. All of them have the same issue I outlined in the first post. ZDMC 18.4 & 18.3 crash immediately upon launch.

    ZDMC 17.6 is the newest version which seems to work correctly but I get the error "Kodi Detected problems with app native libraries (please consult log for detail): libkodi.so:text relocations". It doesn't seem to cause any playback issues that I have been able to tell. It scrapes everything fine. I also get 3D and lossless audio with this setup as it is using the external player.

    One thing I noticed is all the ZDMC versions that have the problem described in my original post, also ask for permission to access the system directories on the first launch (which I grant). I'm thinking it has something to do with permissions not getting set correctly somehow. Maybe it can't write to the app directory or something. Maybe the issue is specific to the G version of the firmware? I tried to install the regular firmware to test that theory but I got an error: "Verifying failed, the upgrade package is lower than the current version"

    This box seems very buggy. :(

    Used a 6.3.92 recovery image from mcbluna's site to wipe the Z9X. Installed ZDMC 19.4 on that. Same problems. :(

    Installed 6.4.42 (non G version) over that. Same problems. :(
    Last edited: Dec 30, 2022
  11. BigPines

    BigPines New Member

    I finally found a solution. Installed ZDMC 19.4 on Firmware 6.4.42. In Kodi, go to System -> Settings -> Services -> SMB Client -> Minimum protocol version = SMBv1 & Maximum protocol version SMBv1.

    My media shares are hosted on a Mac and apparently it needed these changes to work correctly in the newer versions of Kodi / ZDMC.

    I hope this helps someone else!

Share This Page