Z9X Pro issues

Discussion in 'HDD Media player(RTD 1619BPD)' started by Sneakygloworm, Sep 17, 2023.

  1. Sneakygloworm

    Sneakygloworm New Member

    Hi All,

    I have a few issues with the Z9X Pro that have (at this time) stopped me from using it. I am now back on a mini pc using Kodi and Plex.

    1. The first thing I found frustrating was scraping TV shows. The initial scrape only found 7 correct shows out of 322 which was alarming (to put it politely). Using TMM and many spare hours, I finally finished it but some had to be applied manually which was unnecessarily painful. Will there be an update to the scraper?

    2. The movie poster wall will not hold posters even if I scroll and populate the whole lot (1102). If I leave the poster wall, they need repopulating again which is horrendously slow. I'm using a Nas and a USB Das. I've set posters to custom and set the location to internal memory, assuming it would be the fastest. The 4 usb Das drives are between 2 and 12 terabytes each. Is there a way to stop the wall repopulating everytime I open it?

    3. The worst of the bunch is that a lot of MKV files freeze on start. I decided to run each movie to make sure it would start as I had one lock on start before 3 seconds and would not play even if I fast forwarded. After testing 42 movies, 12 locked on start.

    Fearing I had a damaged drive, I plugged it into a pc. No issues. I then ran these initial failed movies through KODI. No issues. I then tried the drive in the other 2 usb 2.0 ports on the Z9X PRO. The files still failed to start. At this point, I gave up as I didn't fancy checking the other 1000. Will Zidoo update codecs to allow for these issues or is there a fix as some AVI files also refuse to play.

    Many thanks
  2. Markswift2003

    Markswift2003 Well-Known Member SUPER Administrator Beta test group Contributor

    1. What is your naming convention? If series are named correctly, eg. SeriesName - SxxExx.ext then in my experience scraping is extremely accurate.

    Adding an episode name like SeriesName - SxxExx - EpisodeTitle.ext can lead to issues since EpisodeTitle is also parsed. I've suggested that TV series are only parsed up to SxxExx in the past but as far as I'm aware this hasn't been implemented.

    2. I'm assured that this will be given priority once firmware releases resume - in the meantime, refresh performance is dependent on poster size.

    This is from my own testing:

    3. Never had this issue - my libraries are exclusively h.264/AVC, h.265/HEVC MKVs. Some straight remuxes, some that I've encode myself with Staxrip, all 4K and they play flawlessly.

    As for your AVI files, compatibility will depend on the codec.
  3. Sneakygloworm

    Sneakygloworm New Member

    Thanks for replying. The initial naming was - folder with series name/seasonxx/sxxexx. These were scraped successfully in Kodi/Plex to about 90% using TVDB. So when the failure to scrape occurred with zidoo, I couldn't understand why as the scraping tool was the same. I've since reorganised them with tiny media manager and they now work but I can't figure out why Plex and Kodi hit the target but Zidoo needs micromanaging.

    I use medium posters so maybe that's where the problem lies. I never actually understood what the overspread thing did so thanks for clearing that up.

    The majority of rips that had issues were 1080p using dvdfab. Strangely, 2 out of 4 of those that failed were done back to back with no changed settings. A few years ago but basic lossless rips.

    I can't understand why the Zidoo can't play them but Kodi and Plex have zero issues with them. I can only assume it's a codec issue or Kodi and Plex are a little more forgiving to possible damaged headers, etc but they play back with no issues.

    I'm really holding onto hope for the Z9X Pro because it allows the full mixture of both my Nas and Das together, nice and clean with full HDR options in a tidy low power box so this little setback is disappointing.

    If you want to PM me a sample problem file I can have a look at it.
    Last edited by a moderator: Sep 18, 2023
  4. Markswift2003

    Markswift2003 Well-Known Member SUPER Administrator Beta test group Contributor

    The Zidoo scrapes the file name, unless BDMV structures are used, in which case the containing folder name is used. It can have issues with commas and numbers, but generally I find scraping maybe 90-95% accurate as long as filenames are sensible.

    As far as the files go, I've used Zidoo devices from the X9S through Z9S, Z9X and now Z9X Pro (and various premium derivatives along the way, but the playback engine is exactly the same within a given range of devices) and never had any such issues.

    I have a variety of DVDs, BluRays and UHD BluRays. All my BluRays and UHD BluRays are ripped to MKV in h.264/5 although I also use a wide variety of other containers for testing. DVDs are mostly MKV in native MPEG2.

    I'm not saying these devices are perfect, far from it - no device is - but used with the file types and codecs they're designed for and a robust delivery system, they're pretty much bombproof. If they weren't, I wouldn't be here, and I certainly wouldn't allow one in my cinema! (quick anecdote - Years ago I used to use a Shield in the cinema for local playback using Kodi but one day it crashed while I gave a demo to someone quite important in the BBC - It only did that once, but it got removed that day and hasn't been used for local playback since).

    Ok, the current Zidoo generation needs a lot of work (which I'm assured is being done), but the basics are there and certainly while I've been testing, playback has been reliable.
    xskip likes this.
  5. Sneakygloworm

    Sneakygloworm New Member

    Okay, I set the Zidoo up and checked a few things. In the settings, there is a setting - "Auto Frame rate". This was set to match frame rate. I set this to auto.

    Then, digging deeper, I noticed hdmi signal format was set to standard. I set this to enhanced. VOILA!!! Everything plays again.

    I've also (with your recommendation) set the poster size to small and set the "slip the detail at overspread" button to ON. The movie posters appear to remain cached on exit.

    Many thanks! I'm back in the game!
  6. nutzer

    nutzer New Member

    Hi all, hi @Markswift2003 ,

    i have exactly the same problem with freezing of movies after 3 sec. (your problem nr. 3, @Sneakygloworm )
    already tried a lot of options (changing audio output to lpcm, mixdown...) but nothing helps.

    where did you find the "auto frame rate" - auto-option you were speaking about? i can only select "off", "match-framerate only" or "match frame rate and resolution" for autoframe rate. but with every option the movie freezes..

    setting the hdmi-signal to "enhanced" elevates grey levels and distorts colors for me...

    It's not with every .mkv file - that's what's puzzling me...but with many (which is quite annoying)
    i scan skip in a file and then, again, after 3 sec. playback --> freeze.

    would a debug log help?

    I can't find a pattern in the files, i would say mostly DTS, but also some ac3...run in into freeze.
    Last edited: Sep 19, 2023
  7. Sneakygloworm

    Sneakygloworm New Member

    Unfortunately, enhanced HDMI is the thing that made it all work again for me. I haven't noticed any change in picture behaviour like you did though. I assumed I had bad MKV files, etc but thankfully, it was just switching from standard to enhanced HDMI.
  8. Markswift2003

    Markswift2003 Well-Known Member SUPER Administrator Beta test group Contributor

    Assuming you mean Settings/Display/Color Settings/HDMI Signal format > Enhanced format then there's no problem using that as long as the display is HDMI 2 and the cabling is sound. It won't change the image as such.
  9. nutzer

    nutzer New Member

    changed it to "Enhanced" but still freeze after 3 sec.

    update: borrowed a denon hdmi-receiver from a buddy, it works with it, no freezes.
    but, doesn't work with my SPDIF-only rotel receiver, directly connecting my projector via HDMI to z9x pro. (also freezes if projector only connected, outputing sound via projector speakers)

    maybe this helps further troubleshooting? maybe some edid problem?

    i can offer a debug log. where to post?
  10. cucnz

    cucnz Active Member

    If its working fine ,when you change to the HDMI Denon amp in between, then that would really suggest issue isnt with Zidoo, but with what your running it in to

    ie a 4k hdmi dv da hdr source going to a non hdmi etc older ? rotel amp and to projector

    Maybe list all the devices in the chain ,would help with setup suggestions ,and also the file types being played ie mkv 1080p/2160p ac3 eac dts DA etc etc

    If i remeber correctly a lot of higher end audio types wont go via SPIDF
  11. Fricke

    Fricke New Member

    Can z9x / pro get photos and so on for a film/TV-series if it's format is mkv on my network. And then via the internet put it for the movie automatic in the right place and will show up in the software meny for chosing film to see in the player it self?
  12. Markswift2003

    Markswift2003 Well-Known Member SUPER Administrator Beta test group Contributor

    In a word, yes :)
  13. nutzer

    nutzer New Member

    not to be rude, i know you're trying to help here, but it's far to easy to make other components responsible..

    it's not a problem of high-def. audio/video: problems (freezes) especially come up with 1080p and plain simple ac3. (i would say it's even less with highdef-material..)

    also tried another setup: directy connected the box to 2 different 1080p samsung tv via hdmi: same issues! freezes after 3sec.

    problems arise with or without spdif connected.
  14. DennisTheMenace

    DennisTheMenace Active Member

    I also faced the same problem that my MKV files got stuck after a few seconds. When I connected my Z9X Pro player directly to my TV. My TV doesn't support DTS passthrough, so I set the sound settings to Auto instead of Raw. I couldn't connect the z9x pro directly to my Sony receiver because it was having problems working with my Samsung s95c TV. These have now been fixed with a firmware update of my receiver.
    But when I played around with the settings a bit, I found that the MKV files that got stuck after a few seconds played perfectly if I selected "Raw" in the sound settings.
    In short, in my setup, all MKV files with Dts audio tracks would hang after a few seconds when the "Auto" setting was selected in the sound settings. When “raw” was set, everything played smoothly. Only without sound, of course, because my television doesn't support DTS passthrough.

    Now that my Sony receiver is now working perfectly after a firmware update, I of course connected the z9x pro to the receiver.
    I haven't had any video files stuck since then.

    You can test whether the videos you are stuck on can be played by first setting “RAW” in the audio settings.
    I'd be interested to see if they play without getting stuck
  15. nutzer

    nutzer New Member

    indeed, it doesn't get stuck with "RAW"...but audio does not work then...(and with "lpcm" it freezes as with "auto" )

    conclusion @Markswift2003 : can be identified as an audio problem then...
  16. Markswift2003

    Markswift2003 Well-Known Member SUPER Administrator Beta test group Contributor

    Could be on to something here - it's not the whole story because I use Audio set to "Auto" but when you say "audio does not work" when set to RAW, why is that - is the box directly connected to a TV without an amp?

    Wondering if it's to do with LPCM output...
  17. DennisTheMenace

    DennisTheMenace Active Member

    Yes, I think this error occurs when the zidoo outputs the sound from dts or dts-hd to lpcm stereo.
  18. nutzer

    nutzer New Member

    yes, box is directly connected to TV (no amp), that's why sound does not work with RAW (obviously). file plays but no sound.

    but I can narrow it down a little bit:

    checked all my files on harddrive with audio set to "auto" and also "lpcm"

    .iso --> works 100% (dolby and dts)
    .m2ts --> works 100% (dolby and dts)
    3D .iso --> works 100% (dolby and dts)

    .mkv --> freezes ONLY with dolby-audio (ac3, eac3, dolby-atmos, dolby digital plus, etc.). If a file also has a DTS-track--> switching to dts solves the problem and file plays.

    (i only thought it was with with dts-tracks, because hometheater showed dts logo, but default track was dolby, so it freezed..)

    summing up: .mkv files with activated dolby track cause the freeze after 3sec., when audio is set to auto/lpcm and box is connected (solely) to TV/projector.
    Last edited: Sep 24, 2023
    DennisTheMenace likes this.
  19. Markswift2003

    Markswift2003 Well-Known Member SUPER Administrator Beta test group Contributor


    But this raises way more questions -

    Firstly it contradicts what @DennisTheMenace said above where his issue was with DTS > LPCM (because his TV doesn't support DTS).

    Not all TVs support DTS but most support AC3 and EAC3, so setting Audio to Auto will allow AC3/EAC3 to pass-through in most cases and DTS will be converted to LPCM stereo.

    Can you post your EDID then I can mimic your box and see if I can replicate.

    To Download EDID

    Settings/Display/Custom EDID/Save EDID

    Save to a USB stick or network location.

    Change the file extension from .bin to .txt to upload to the forum

    (The forum won't accept .bin files)
  20. nutzer

    nutzer New Member

    sure, here you go...

    but in my case it even freezes with lpcm.. (with dolby track).

    with lpcm playing dts it works (as it does on "auto" for dts)...problem really seems to be dolby...

    Attached Files:

    • edid.txt
      File size:
      256 bytes
    Last edited: Sep 24, 2023

Share This Page