Z9X PRO 3D Problem

Discussion in 'HDD Media player(RTD 1619BPD)' started by Olimpike, Mar 2, 2024.

  1. Olimpike

    Olimpike New Member

    Hello! I just bought a Z9X PRO and I'm encountering an unexpected issue with 3D:

    I have an old LG 3D TV with which I can watch all kinds of 3D content, whether it's .mkv files or BD3D from discs, and so far it has played everything.

    I bought the Zidoo to be able to directly play ISO3D files or .mkv files as well, but with most of them, when I try to play them, the LG TV displays a moving screen indicating "Unsupported Format" while the Zidoo seems to continue playing. The strange thing is that this is happening with .mkv files that play without any problems when connected directly to the TV's USB.

    Do you know what could be causing this?
    I would appreciate it if someone has encountered the same issue and has been able to solve it.
     
  2. Sanctrum

    Sanctrum Member

    How those files are named? Z9x Pro behaves differently based on two factors: EDID supporting 3D and the file name. If 3D support is Yes (as detected in EDID) and if the file name contains 3D separated by spaces, e.g. Test 3d SBS.mkv or "Test 3D TAB.mkv then if both conditions are met Zidoo plays files in the frame packed format => expands each eye frame to the full screen size and alternates them. So your TV should detect this mode and switch to 3D automatically.

    If at least one condition is not met then 3D file is displayed as 2D... and you can manually enable 3D from the TV level.

    Also make sure to set your settings as here:
    http://forum.zidoo.tv/index.php?thr...r-useful-stuff-for-rtd-1619bpd-players.95967/

    Especially the setting:
    Playback/Automatic frame rate/Frame rate mode: Match frame rate and resolution *
    * Personal preference. You can use "Match frame rate only" to allow the Zidoo to scale and reduce HDMI resyncs

    So you should have at least Match frame rate.

    There are other 3D/2D settings that can impact, but if you have "unsupported format" then maybe your TV just does not support 3D frame packing.
     
    Last edited: Mar 2, 2024
  3. Olimpike

    Olimpike New Member

    Thank you, Sanctrum, for your quick response!! My LG TV was indeed detecting the 3D signal, but it wasn't displaying the image. I managed to watch all 3D movies by setting the following parameter:

    Display/Color Settings/Non-4K: Priority YUV444 8 BIT

    Do you think I might be sacrificing image quality by selecting 8 BIT instead of 10? When I choose 10 BIT, I can watch 2D movies without any issues.
     
  4. Sanctrum

    Sanctrum Member

    My knowledge ends here. You have to wait for @Markswift2003 to help you.

    For sure you should dump EDID and analyze it. And do it for each HDMI port of your TV since they might differ. E.g. in case of my old TV, the 10bit is available only at HDMI3 port. Also something can be spoilt if you send the signal via amplituner existing in the hdmi chain. This will impact EDID and some options that your TV supports might be truncated.
    So you should explain your setup chain and experiment with connections and ports.

    E.g. In my setup I can't have both: 3D in frame packing mode and the audio via my AVR255. I instantly loose audio in my AVR255 when having 3D in frame packing... as AVR255 has the very old HDMI 1.3a. ports. So I have to deliberately disable 3D support at Zidoo side so I could have RAW audio pass to AVR255 and then at TV I just manually enable proper 3D mode.
     
    Last edited: Mar 3, 2024
  5. Olimpike

    Olimpike New Member

    I didn't know that either, so that's helpful too. I'll try my 3 HDMI's inputs!
     

Share This Page