X10 UART route

Discussion in 'HDD Media player(RTD 1295)' started by wolfy196, Jul 1, 2021.

  1. wolfy196

    wolfy196 New Member

    Hello everybody and thankyou to this forum and it's technical members for providing me with lots of information over the years. I am now no stranger to firmware flashing for most of the zidoo range.
    Now to the problem. I have just received a Zidoo X10 that's stuck in a boot cycle and will not accept a firmware flash, and I have tried many combinations of eveything may times over. The only option left that I haven't tried is to recover it using the UART method, but i am unsure of what equipment I require and the process needed as the method stated is not very clear. Can anyone who has done this method or has the knowledge please ellaborate.
    Failing this it will probably meet a lump hammer.
    All the best and many thanks.
  2. Markswift2003

    Markswift2003 Well-Known Member SUPER Administrator Beta test group Contributor

    Before going down the UART route it's worth trying to create a rescue image. This is different to the normal USB rescue process in that you copy specific files to the USB disc in addition to the firmware image to initiate a reflash.

    These instructions are for X9S but if you use the USB firmware for X10 and follow the instructions from "Create the rescue firmware by yourself" about halfway down the page you should be able to create the rescue files yourself:


    Failing that, this is the page you need:


    I've done this several times with a 1619 device with a lot of help from the guy on that page.
  3. wolfy196

    wolfy196 New Member

    Hi Mark,
    Thank you for your quick response.
    I have tried both flashing the image via the reset button on the back of the X10 and via the image route with the four other files without the reset button.
    Have tried both Fat and Fat32 with the above on various usb drives that work perfectly with my other Zidoo boxes.The furthest I get is for UP--- to appear on the Zidoo and Zidoo to appear on my TV screen which disappears after 5 minutes to be replaced with a solid green screen which stays like this for hours.
    I am left with the only option still remaining, which is to go down the UART/TTL route, but this option is new to me and I need to know what lead i require and a more explained step by step instruction as the route explained via the link in your post is a little vague.Once i get my head round what is needed i will most probably fathom it out.
  4. Markswift2003

    Markswift2003 Well-Known Member SUPER Administrator Beta test group Contributor

  5. wolfy196

    wolfy196 New Member

    Your a gent Mark. That picture has made all my head scratching confusion disappear.The penny dropped.
    Once again I can't thank you enough.
  6. McBluna

    McBluna Well-Known Member

    Just to be prepared for the emergency case I've ordered 2 adapters from Amazon including 2 USB A-Male to A-Female Extension Cable for €9,81 including shipping.


    I'll try this new toy at the weekend.
  7. wolfy196

    wolfy196 New Member

    You guys are the best and a bargain on that "new toy" McBluna.
    Incidently, the TTL port on the X10 is next to the USB 3.0 on the Board.
    Markswift2003 and McBluna like this.
  8. wolfy196

    wolfy196 New Member

    Well I had a go. Seems the previous owner has somehow completely wiped the RTD1295 chip as it's missing uBoot and all relevent commands required to instruct the box to boot or flash firmware. It would either have to be re-flashed again as if back at the factory or the complete command line structure typed in and executed, which I'm not sure even exists to download.
  9. Markswift2003

    Markswift2003 Well-Known Member SUPER Administrator Beta test group Contributor

    Kudos for getting connected - so if you connect by PuTTY what do you see on the terminal?

    Can you not get to a Realtek> prompt (pressing esc key)?
    Last edited: Jul 5, 2021
  10. wolfy196

    wolfy196 New Member

    Hi Mark,
    Yes I was able to get to the Realtek prompt but upon executing the "help" command I received a small list of menu commands of which the important ones needed are missing from the list. Rtkemmc and mw are present but dw and boot ( required for
    Unbrick with UART + U Disk) are not.
  11. wolfy196

    wolfy196 New Member

    Screenshot of what is listed

    Attached Files:

  12. Markswift2003

    Markswift2003 Well-Known Member SUPER Administrator Beta test group Contributor


    DW is only needed for restoring FWTable but I have no idea why "boot" wouldn't be there! I think it's worth a PM to jjm2473 - he really helped me out when I bricked my Z9X the first time..

    I see bootr and bootm as discrete commands but r and m are usually arguments applied to "boot" not individual commands. Is there a bootall command?
  13. wolfy196

    wolfy196 New Member

    As "Boot" is missing from the command list, the substitute "Go" seems to work. So although "go all" will execute the four files from usb, it will still not flash the install.img file.

Share This Page