Still got CEC problems with Z9X

Discussion in 'HDD Media player(RTD 1619DR)' started by John7, Oct 28, 2022.

  1. John7

    John7 New Member

    I still have problems with this machine and CEC

    I Have
    Updated to the latest FW
    Disabled CEC in Z9X settings
    Fitted an HDMI blocker to the Z9X output
    Turned HDMI CEC "OFF" on both my receiver (Pioneer SC-LX701) and my TV (LG65B7)

    My recever still switches automatically to the Z9X input when powering on, even with the Z9X shut down! It's driving me crazy!!!

    Anyone have any other suggestions for me? Thanks.....
  2. Markswift2003

    Markswift2003 Well-Known Member SUPER Administrator Beta test group Contributor

    CEC is controlled by pin 13 and all a CEC blocker does is disconnect that pin.

    There are two possibilities here - either it's not CEC doing it (auto sense - I know HDFury devices use this for example, but I'm not aware of any AVR manufacturers using it), or the CEC blocker is faulty.

    I believe that there was a batch of Lindy CEC blockers that were recalled because pin 13 carried through, so it was effectively an HDMI back to back and that would be my first guess here.
  3. 3DBuff

    3DBuff Well-Known Member

    I think it's autosense on HDMI port of the receiver doing it. I get the same thing on my Sony receiver. It switches to Zidoo port when Zidoo is in power off standby (red LED on) by turning TV on and selecting Netfix app on smart TV. My CEC is on for volume nad mouse control but not for power up and down. Receiver will turn on with the TV and switch to Zidoo port black screen. Sometime it will do it couple of times when selecting Netflix. Third time is the charm. Netflix stays on :D. I don't get frustrated anymore. Just admitting that this is how it works with CEC on. I take the good of volume and cursor movement on any remote with the bad of receiver forcing Zidoo port all the time :confused:
  4. John7

    John7 New Member

    Quite, but the frustrating and annoying thing is my Z9S had ZERO issues with CEC, everything worked perfectly!

    In answer to Markswift2003, yes I did have one of those dodgy Lindy blockers but I recently replaced it with a different make which works perfectly apart from this one problem. Surely this must be some other issue unrelated to pin 13, which is now effectively blocked?
  5. John7

    John7 New Member

    Just an update on this issue.

    So, I bought a remote power socket to isolate the Zidoo completely. Receiver STILL switching to designated Zidoo HDMI port. Unplugged the HDMI cable - problem still persists!!

    Scratching head......Removed power and soft-reset receiver - problem still persists....

    Enter receiver HDMI settings and disable HDMI port assigned to Zidoo. Re-set Receiver, and re-enabled HDMI port PROBLEM SOLVED.

    It seems then that the Zidoo had "locked" the HDMI port and only disabling and re-enabling it cleared the issue. Everything working fine now and remote power socket not required.

    I have re-enabled CEC on TV and Receiver but I am keeping the CEC blocker on the Zidoo output, just in case!

Share This Page