Slow internet with Z9X (both WiFi and LAN).

Discussion in 'HDD Media player(RTD 1619DR)' started by Ant14, Apr 24, 2022.

  1. Ant14

    Ant14 New Member


    My internet is very slow (WiFi and LAN) with my brand new Z9X, approximately 120 Mbps (DL) max on both, instead of usually +/- 900 Mbps.
    I've tried several things (update, factory reset, various adjustments on my AX3600 router...).
    I even tried with another router (ISP orignal one), and the result is the same.
    I have zero bandwidth limitation, zero internet consuming device when testing, nor "intelligent" allocation service ON, and I've double checked various other things like that.

    It's only happening with that single device.
    It's not related to some bad ethernet cable, nor 100M limit, nor distance between devices.
    I don't know what to do next, anyone has some fresh ideas ?
    Maybe finding and flashing an older image (I'm already on latest emergency firmware) ?

    Thanks a lot, for any provided help.
    Last edited: Apr 24, 2022
  2. Ant14

    Ant14 New Member

    Is there something wrong in downgrading to Z9X_P_v6.0.19_202008072201_usb-install.img ?
    Thanks for any help.
  3. Ant14

    Ant14 New Member

    Sadly, same result after downgrading to a 2020's firmware.
    Am I the only one facing such an issue ?
  4. Sledgehamma

    Sledgehamma Well-Known Member

    How did you measure it on the Zidoo?
  5. Ant14

    Ant14 New Member

    First, I've noticed something wrong, downloading the same file from my Real Debrid cloud, to my Shield and Z9X.
    Then, speedtests through Chrome confirmed the problem.
    May I ask you, what results do you get (if you have a Gigabit connection) ?
    Last edited: Apr 25, 2022
  6. Sledgehamma

    Sledgehamma Well-Known Member

    I’ll test later today. Can you also test with the speed test app please?
  7. Ant14

    Ant14 New Member

    Thanks, I appreciate.
    I intended to, and I will (but we both suspect the results will be the same, maybe slightly higher with the app, as often).
    I'll do that in the next hour.

    The issue is also noticeable when streaming; ZDMC is unable to play smoothly, always buffering (which is logical, considering 20 MB/s file does not match, with a connection allowing 15 MB/s, at most).
    Last edited: Apr 25, 2022
  8. Sledgehamma

    Sledgehamma Well-Known Member

    With the App I get around 250 to 270mbit with a 1000mbit internet connection.
    Via Chrome and speedtest of my ISP get 310mbit.
    Ant14 likes this.
  9. Armin Moesslacher

    Armin Moesslacher Active Member

    iperf i get 300mbit rock steady with the zidoo tcp
    Ant14 likes this.
  10. Ant14

    Ant14 New Member

    Sorry for the late answer, I've done more tests, to provide more insightful informations.

    I have quite similar results with the app (which is a good surprise, no faulty hardware apparently), and around 600 Mbps with Ethernet (so it seems it's fine, on the router side).
    Downloading from Z9X's Chrome is OK (around 30 MB/s, which is perfectly correct for WiFi).

    At the opposite, downloading from various add-ons inside ZDMC : always 6.1 MB/s max, no matter if I'm wired with WiFi off, or not (as if it was capped, somewhat limited to that exact speed).
    I've tried other Kodi and ZDMC releases (because I have zero issue with Matrix on Shield) : same result (so it's "XBMC" related).
    Another failed try : using a VPN makes no change.

    I don't know what to do next.
    Last edited: Apr 26, 2022
    Mentor27 likes this.
  11. Ant14

    Ant14 New Member

  12. Ant14

    Ant14 New Member

    New test : same (bad) result, with something from my Alldebrid's Cloud; no matter if I'm DL to internal storage, or USB 3.0 external HDD.
  13. Carlos Niño

    Carlos Niño New Member


    I'm experiencing exactly the same problem. I have a 1Gb connection and only get 70-90Mb through the ethernet. Did you find a solution?

  14. BdoUK

    BdoUK New Member

    Also having very slow speeds via ethernet connection with my Z9X.

    I started to look into the Zidoo's ethernet speed because I was getting occasional "stops" while playing 4K MKV files. These files are all created from my UHDs using MakeMKV. All my troubleshooting led me to test the speed of the connection through the Zidoo and it's far below expectation for a 1000 Mbps connection. Using via Chrome on the Zidoo I only get around 130 Mbps. Using the same cable and switch port I get 900 Mbps using my AppleTV.

    I've seen numerous reports of slow speeds via ethernet with the various Zidoo models but haven't been able to locate any actual solutions to the problem. Is this something that Zidoo is examining as a possible software issue?
  15. Deano86

    Deano86 Active Member

    If it truly was a firmware/software issue, there would be a lot more complaints being noted. Factory reset your Zidoo and see how it does then. Also, make sure you don't have a duplicate IP address conflict going on in your local network as well.
  16. BdoUK

    BdoUK New Member

    I've done both of those things and still no improvement. Playing the same files via Infuse on AppleTV has no issues. I should note I've tried both NFS and SMB and no difference there.

    Are there clear instructions for rolling back firmware to an earlier versions?
  17. khollister

    khollister Member

    I have not had any playback issues but this thread got me curious. I tried in Chrome (finally figured out there is a mouse mode button on teh remote) and I get 170 Mbps to the internet (my connection is about 450 mbps per my hardwired 16" MacBook Pro M1. I'll try my 5GHz wifi network for grins later.
    vddan and BdoUK like this.
  18. LarryZ

    LarryZ Member

    This seems to be a problem with a too small tcp window size.
    The maximum bandwith of each tcp connection depends on the latency and the tcp window size.
    Normally the operating system adjusts the window size, but it seems the configured maximum on the Zidoo player is too small.
  19. rozel

    rozel Well-Known Member

    My Internet speed is usually max 58 mbps and that is via Ethernet - usually I get around 40mbps as it hits my Zidoo and other streaming equipment, such as Sky Q using my TV. Never had a single issue with any of my equipment playing back, particularly with my Zidoo.

    I don't understand, to be honest, why people are struggling with much greater speeds than myself. FWIW, I get appx 20 mbps using say a Roku stick and BBC iPlayer via my TV, the former via WiFi but get a higher speed using TV, again via WiFi

    But all seriously lower speeds than all those above.
  20. Deano86

    Deano86 Active Member

    That's because you are talking about something totally different than what our current discussion is....we are not concerned with incoming internet provider speeds or for lower bit rate compressed streaming services.. we are concerned with high bit rate 4K UHD files played via local network...

Share This Page