Resuming HDR10+ Content on DV/HDR10+ display plays incorrectly for 5-10 seconds - Z9X

Discussion in 'HDD Media player(RTD 1619DR)' started by Nathan W, Aug 28, 2022.

  1. Nathan W

    Nathan W Member

    I've found an issue on newest beta version 6.4.20 where if you resume "SMPTE ST 2094 App 4, Version 1, HDR10+ Profile B compatible" content on auto with a DV/HDR10+ display. Playback is all screwed up for first 5-10 seconds of playback. But error only happens once per "boot". Confirmed with friend that they can reproduce.

    Steps to Reproduce
    1. Play HDR10+ content and seek forward somewhere so you can resume later.
    2. Exit video
    3. Standby and turn back on
    4. Resume said video

    This only happens if display supports DV and HDR10+. Issue does not trigger on HDR10+ only display.
    Attached zip file contains 3gp video file of it happening (no idea why cutting video on my phone results in this format but plays fine in VLC)

    Attached Files:

    Last edited: Aug 28, 2022
  2. Markswift2003

    Markswift2003 Well-Known Member SUPER Administrator Beta test group Contributor

    Can't replicate this one.

    These are the steps I took:

    1. Load DV/HDR10+ EDID
    2. Set HDR to Auto
    3. Play HDR10+ Profile B file, confirm playing in HDR10+ and skip to 5 minutes
    4. Stop play
    5. Turn off Zidoo with remote
    6. Turn on Zidoo with remote
    7. Start Video (starts from 5 min resume point)

    And no problem - plays back in HDR10+ as expected - no artifacts as your video shows.

    Also tried HDR10+ Profile A which works fine too. Also tried standby vs power off and cold reboot.
  3. Nathan W

    Nathan W Member

    I will investigate further and report back on findings.
    Markswift2003 likes this.
  4. Nathan W

    Nathan W Member

    It seems I can only have this issue to popup if my HDFury Arcana is part of chain. As soon as I take it out I am unable to reproduce. Consider this resolved I guess. If I am ever able to reproduce without it or a different way will reply to one of your posts. Thanks for taking your time for looking into this.
  5. Markswift2003

    Markswift2003 Well-Known Member SUPER Administrator Beta test group Contributor

    Ah right - must be something to do with how the metadata is buffered - I must admit I had the Vertex 2 out of chain while I was testing - I'll try it in the chain tomorrow.
  6. Nathan W

    Nathan W Member

    I talked to the friend I mentioned in original post and their setup is just Z9X -> Yamaha RX-V4A -> TV so this isn't HDFury specific, but something to do with HDR passthrough "switch" type devices. My soundbar with earc doesn't cause this issue (guessing earc "resyncs" metadata or something like that.)
    Last edited: Aug 31, 2022
  7. Nathan W

    Nathan W Member

    Did you get a chance to try this? I have done more testing and am inclined to believe it is something to do with how the HDR10+ metdata is buffered. With my HDFury Arcana I also get a black screen for a second or 2 every 15-20 mins when watching plain HDR10+ content. Does not happen when playing HDR or DV content.
  8. Markswift2003

    Markswift2003 Well-Known Member SUPER Administrator Beta test group Contributor

    Apologies, but this completely slipped my mind, but I've just had a pretty extensive play with this.

    If I add the HDFury into the chain and follow the procedure I did before, I still can't replicate what you see - whether I have an AVR in the chain or not, or whether I restart the box, power down or put it into standby.

    I think this must be a particular issue with your TV syncing the HDR10+ metadata and the HDFury is scrambling that somehow on the way through. Possibly something to bring up with HDFury?
  9. Nathan W

    Nathan W Member

    Ok, thanks for trying to reproduce.

Share This Page