Procedure root/unroot for X6?

Discussion in 'ZIDOO X6 Pro' started by hook7, Sep 26, 2015.

  1. hook7

    hook7 New Member

    Hi all, there is a procedure to root/unroot for this model X6?
    I need to install "Paragon HFS +", no root, can not recognize a hard drive formatted HFS +.
  2. warren_wh

    warren_wh Active Member Staff Member Zidoo TECH Supporter

    Dear Hook7,X6 has the root,Thank you very much for your attention.
    Siam Wahid likes this.
  3. hook7

    hook7 New Member

    Good news, I have ordered X6 yesterday and am looking forward to prove it. Now I have a Minix Neo-X8 H Plus and to update it every time I do unroot. A real hassle.
    Thanks for your answer.
  4. asshenoy

    asshenoy New Member

    [QUOTE="]Dear Hook7,X6 has the root,Thank you very much for your attention.[/QUOTE]
    thanks for the confirming that Zidoo X6 pro has full root access.. so that users can play around with different custom firmware.
  5. Arctic Ace

    Arctic Ace Member

    I just UNROOTed Zidoo X6 Pro by using SuperSU Free's "Unroot" -command. Some good and bad news:
    Some apps which didn't work earlier, started to work now but not all... There are still some apps which states that Zidoo X6 Pro is rooted and won't work correctly (won't stream media content due the Root-status). What else should I do to get box fully unrooted?

    Last edited: Dec 7, 2015
  6. Bogdan

    Bogdan Member

    Hi all!
    I bought this nice piece of equipment and for now I have to say it is more on paper and statements than in real life. Still the player worth its money, and given the apparent willingness to support us of the Zidoo team, things may improve and become closer of the paper and statements specs.
    On topic: Can I "install" the unrouted firmware (1.0.26) directly via the Update procedure (Download, Update, local file go) on a routed player (having already routed 1.0.26) or it takes computer tools flashing to achieve this?
    Thanks for answering.
  7. rafarataneneces

    rafarataneneces Member Beta test group
    has no root version

    Zidoo X6 came out of the box with ROOT.

    Why are we going in reverse?

    The latest firmware updates don't include root anymore, so frustrating!!

    What is the easiest way to install root on Zidoo X6 Pro?

    Reverting to ZIDOO_X6_Pro_v1.0.25_ota for now
  8. mirror

    mirror Well-Known Member SUPER Administrator Zidoo TECH Supporter

    Released the rooted version.pls check
    rafarataneneces likes this.
  9. Arctic Ace

    Arctic Ace Member

    Default version should always be UNROOTED so that official apps would work in Zidoo. If someone need a ROOTED version, that could be possible by downloading an optional firmware?
  10. rafarataneneces

    rafarataneneces Member Beta test group


    I haven't slept for the last couple of hours ;'(

  11. fredli888

    fredli888 New Member

    So current download page for firmware is this ROOTED version?
  12. rafarataneneces

    rafarataneneces Member Beta test group

  13. PacoRabanne

    PacoRabanne Well-Known Member Beta test group

    Not exactly, there are two version, one rooted, the other not. The one that ends with _root is the root one.
    Just installed, fine until now (for me, I'm not an advanced user).
  14. maxfratin

    maxfratin New Member

    @warren_wh @PacoRabanne @Harlan @rafarataneneces @mirror @Bogdan
    HI guys! Is there any onekwy root nowaday that can help us to unroot the x6? Currently I rooted the box for a misunderstanding and now my media app (italian app mainly: mediaset play, skygo and so on...) are checking the rooting device status and are not running since the X6 is still viewed as rooted even if I run the supersupro command "Permanent unroot". Any idea or suggestion? Is there any stock firmware (even OTA) that I can download to bring my box to the "original" status (1.0.32 was my first fw)? Thank you in advance.
  15. PacoRabanne

    PacoRabanne Well-Known Member Beta test group

    I know the pesky problem related to some italian apps and rooted (or considered rooted) android devices.
    Do you remember which was the latest FW version on which these apps ran fine (useful also for other italian X& owner) ?

    Unluckily, AFAIK, is currently not possible to downgrade FW (Zidoo developers, is a real pity!!!), so you need to do the "flash" procedure using an IMG format FW, and again AFAIK, there are only two downloadable, 1.0.19 (as stated in FAQ post) and 1.0.33 (from cyber7 post "Zidoo X6 Guidelines" that explain again how to flash X6)
    Then you should download the right OTA FW file "no root" (look inside the forum or in Zidoo support page) and do a manual update (avoid real OTA from X6, else you go to the last FW ).

    Maybe some other user can give you a better advice.
  16. maxfratin

    maxfratin New Member

    Ciao @PacoRabanne
    unfortunately I misunderstood the need of root for italian streaming app.
    Let me explain.
    1) at the unboxing moment i had the 1.0.33 fw revision and suddenly, when the box was connected, the upgrade started. So I've got the 1.0.34. in that moment I suppose no root was present right?
    2)later on, since I thought the root was needed for italian streming app, i installed onekeyroot apk from this forum and the root was supposed to be there in that moment.
    3)Then I discover that the root was not needed for italian streaming app and I was very sad :), but i decided to roll-back.
    4)I tried with supersu installed with OneKeyRoot, but no way, you guys suggested to try to come back with SuperSUPro
    5)I bought supersupro and I reinstalled the root succesfully (with su bunary upgrade succesfully included), because the full unroot was not working at that moment so I decided to correctly reinstall the root and then come back to unroot.
    6)I tried to cleanup the box from root with the supersupro function "full unroot" to restore the initial (point 1) status and finally run the italian streaming apps, but no way. The full unroot process terminated succesfully, but currently the italian streaming apps are still "sensing" a rooted device under them.
    7)As suggested by PacoRabanne I downloaded the root checker app and I discovered that the root was not correctly installed on my device, the messages from rootcheck was "Rooting is not correctly installed in the device" or something similar. This is a suspicious status to me. In fact I think there is something dirty that left the device in somehow hybrid you agree?
    8) I retried to root the device with supersupro but...surprise! The supersu pro is telling me now that "There is no SU binary installed and SuperSU cannot install it! This is a problem! If you just upgrade to ANdroid 5.0, you need to manually re-root - consult the relevant forums for your device!". NOw, obviously I am not in the upgarde to android 5.0 case, but this message confirm to me one thing: FROM THE SUPERSU APP PERSPECTIVE, MY DEVICE IN THIS MOMENT IS UNROOTED, so I expected that italian streaming apps works fine....instead is not like my opinion due to the "dirty status" revealed by root checker in point 7.
    Guys, what do you think?
    Flashing is the only salvation to come back to unrooted unboxing status? If yes...which fw should I flash and from where to come back in that status?

    Thank you in advance! Thank You @PacoRabanne!

  17. maxfratin

    maxfratin New Member

    Just for your information....just flashed Zidoo X6 pro with 1.0.33 img file and still rooting has been read from premium play app. Is it possible that the 1.0.33 will already come with rooting included? Now I will go back to 1.0.19 in order to find a fw release without rooting.

    Let you know.

    Thank you.
  18. PacoRabanne

    PacoRabanne Well-Known Member Beta test group

    AFAIK, 1.0.19 is rooted.
    Maybe someone has the list of which release are rooted, unrooted or in both versions.
  19. maxfratin

    maxfratin New Member let's wait for unrooted fw..or should it exist an unrooted firmware?
  20. Harlan

    Harlan Active Member

    They are all rooted or improperly rooted.

    Browsing through the OTA zips from v.1.0.19 > .35 I found that all of the versions had an orphaned su binary in /system/xbin, except But even that one had Busybox binaries and symlinks in /system/bin that appeared to be from an uninstalled root version. So the point releases are either rooted or improperly rooted, the files are there, but can't be deleted while /system is mounted read-only. You cannot remount it until you properly root your X6. The Free and Pro versions of SuperSu and Busybox have different IDs, so you may need to install/uninstall both to clean-up all the orphaned files.

    On anything <.35 you'd have to (1) use OneKeyRoot.apk, reboot, (2) Install the SuperSUs from Play Store and employ the Clean section settings for Reinstall (cleanup in preparation for reinstall from Google Play), reboot, (3) Reinstall SuperSU.apk from Play Store, (4) Install Busybox Free/Pro (so you can use the Pro version's automated "Uninstall", then run SuperSU's full unroot, reboot, and run your favorite root checker.
    Last edited: Apr 14, 2016

Share This Page