New firmware v1.2.9 for ZIDOO X9S released

Discussion in 'ZIDOO X9S' started by mirror, Jan 10, 2017.

Thread Status:
Not open for further replies.
  1. sadrettin

    sadrettin New Member

    How to send audio via usb audio?

    war or pcm?
  2. HaoSs

    HaoSs Well-Known Member

  3. dellenuvole

    dellenuvole New Member

    Hi all,
    Someone could explain what is an on-off USB audio function?
    thanks a lot
  4. HaoSs

    HaoSs Well-Known Member

    Some air mouse's have build in speaker. A crappy one.but that's another story. When you plug it in, the box moves the sound to USB. That option should force the USB sound off
    cyber7 likes this.
  5. Roger Kao

    Roger Kao New Member

    Hi, i have a question.
    If I wanna record a HD TV such as Kbro TV in Taiwan, which sample rate should I use? 96K or 48K ?
    I just tested the HDMI In function, but I feel the sound is a little delay with 48K.
    Can you check this issue?
  6. JCJMC

    JCJMC Member

    With the Media Center, in the NFS option if the NAS folder has an 'accent', it changes it by a Chinese character and you can not enter the folder. With firmwares 1.27 and 1.28 beta 5 worked perfectly.
    If I remove on the NAS the accent works correctly, but this is supposed to change my entire folder structure.
    Last edited: Jan 11, 2017
  7. stevier

    stevier New Member

    I just did this update because it kept appearing on my screen, did the update and now my hdmi multi box will not detect or display anything on the screen when the X9s is plugged in, just a black screen, unplug the Hdmi from X9s box and everything works ok again, something is definately not right with this new update as my box was working perfect with everything until i did the update it kept asking me to do??? How can i downgrade it back to the previous version, this update is crap for me??
  8. dennys84

    dennys84 Member

    for different reasons its crap for everyone, more or less...just deal with it
  9. clarkss12

    clarkss12 New Member

    The PVR is not working inside the ZDMC app. Been awhile since I have used this box, so do not remember if it worked in prior versions. I went from v,1.2.6 to this version 1.2.9. I really need the PVR to work, that is how I watch live and recorded TV.

  10. YellowCows

    YellowCows New Member

    This update broke FileManager for me - it says in the update log (see above) that they fixed an issue where you couldn't open certain share folders under smb. FileManager has always been very buggy, but now I can't access my main video folder on my NAS using smb. I did not have this problem under 1.2.6 or 1.2.7. I can still access the folders in ZDMC or third party file explorers but I usually use the standard filemanager as it is the quickest way to get to the files and play.

    Also, the update broke the SD (TF) card that I had formatted as internal storage. This made many apps inaccessible. Performing multiple factory resets did not fix any of these issues.

    In the end I have had to downgrade the unit to 1.2.7, which restored the lost functionality, and now I have to reformat the sd card, redownload and reconfigure all my apps and unfortunately all the stored data on the sd card is gone. If this upgrade works for other people, that is great, but for me this has been a disaster.

    One final note - under the new update, there are STILL audio glitches with video apps such as YouTube (this is a huge problem as YouTube on an android player is essential) and video streaming on apps such as Amazon video STILL does not work. Please can we have these issues addressed in the next update? Thank you.
  11. stevier

    stevier New Member

    Is there instructions on how to downgrade back to 1.2.7 because this update made my box crap now... what rubbish
  12. JCJMC

    JCJMC Member

    Problems with sound on Youtube.
    blicht10069 and Pelayo like this.
  13. agmarco

    agmarco Member

    Can't say I am still eager to see the update being available for the X8 anymore. Root app for 1.2.7 might be a much better option. I am really puzzled how all these issues could slip to the tests and beta versions before releasing it. Sorry for being grumpy. I know Zidoo will fix most of this in the end.
  14. ramatulay

    ramatulay New Member

    My pvr client also stopped working and will not stay enabled in anyway. All worked great on previous version .Please fix or post how to downgrade. Very disappointed.:(:(:(:(
  15. stevier

    stevier New Member

    Yes, Can someone please, in fact, anyone give us instructions on how to downgrade back to 1.2.7 .... my X9s is now a load of shit.... :(
  16. dimipapa

    dimipapa New Member

    it`s 1.2.7 and put in usb flash.
    put in the usbflash in zidoo,and go Update>from local.
  17. dennys84

    dennys84 Member

    Come on, Guys! 2500 views but only 50 replies. We need to post here more actively, if we want zidoo make something. If just a few people here keeps complaining it does not mean anything for developers, this is 1-2% . At least we has to show that nothing is all right with this damn box!
    agmarco and Cosmi like this.
  18. YellowCows

    YellowCows New Member

    Sure. There are instructions on the 1.2.7 thread, but to help you out, download the 1.2.7 firmware from this link:

    Save the zip file to a usb flash stick, on the root of the drive (in other words, not in any folder), put it in the x9s then refer to this page for instructions on how to flash the player:

    Hope that helps
    Last edited: Jan 11, 2017
  19. YellowCows

    YellowCows New Member

    But to be sure, this update causes more problems than it solves, in fact I cannot think of any problems that it does solve. It should be pulled and reworked.
  20. Lony

    Lony Active Member

    FW 1.2.9

    Bug in DVD ISO and Directory , no chance to move in Menu.

    Playing with Nativ Player !! ZDMC and KODI 16.1

    Thanks Beta Group :p:D
Thread Status:
Not open for further replies.

Share This Page