KODI - ZDMC - MATRIX 19.5 - NEXUS 20 - 21

Discussion in 'HDD Media player(RTD 1619DR)' started by DELUCAS, Feb 1, 2021.

  1. Black-Angel28

    Black-Angel28 Member

    @andy22 Is there any news yet regarding the implementation of full support for ZDMC's native player?
  2. andy22

    andy22 Active Member

    Nope, still waiting on any news if and what from my API proposal they may decide to implement, until they actually do there is not much i can do.
    My PR for other players api (MX Player, Vimu, VLC) just got merged into JellyfinTV app. I may prepare a JellyfinTV "Zidoo" Edition, that uses whats works atm similar to ZDMC, but will have the same issues as ZDMC.

    PS: Thats the "beauty" of closed source.
    Black-Angel28 and dr4go like this.
  3. 3DBuff

    3DBuff Well-Known Member

    Does anybody know how to get back to ZDMC movie page after going to Quick Settings?

    On occasion I need to make adjustment in Quick Settings like Custom EDID when using headphones or something similar after I start a movie from ZDMC. I can stop the movie, click on home screen button Zidoo RC and make adjustment as needed in Quick Settings. The problem is going back to ZDMC. My old X9S would go back to open movie page using Task Manager button. The same function in new Z9X restarts ZDMC. I have to wait for this to start up, go to movies and search for movie I had started. Anybody knows a way to go back to ZDMC where I left off without restarting it?

    On the other hand Standby mode in latest Z9X saves everything with ZDMC opened movie page. On wake up Zidoo goes back to the same ZDMC movie page. Very handy for continue watching the same movie the next day. With Standby function CEC wake up is out of wack. Comparing the old X9S was the exact opposite here and using standby function would close all open apps down to Zidoo Home Page. CEC functions worked on the old unit ;)
  4. Black-Angel28

    Black-Angel28 Member


    ZDMC has problems starting some skins (for whatever reason). You can work around this problem by installing the desired skin normally and then starting it manually by changing the guisettings.xml file. The guisettings.xml file is located in the kodi/userdata folder.

    With Kodi closed, you edit the file in a text edit. Look for a line like this:
    <setting id="lookandfeel.skin">skin.your.current.skin.name</setting>.

    And change to this
    <setting id="lookandfeel.skin">skin.new.skin.name</setting>

    Then open Kodi and the new skin will be set as the skin.
    azon1951, Cyclion and 3DBuff like this.
  5. danbez

    danbez New Member

    Looking for guidance here. I am a long time Jellyfin user, with 1000's of movies and TV shows. The idea of re-scan and fix all matching mistakes on HT 4.0 gives me nightmares, plus it's not really efficient to maintain to disconnected sources.

    So yesterday I sideloaded the AndroidTV version of Jellyfin and configured it to use the external app so I can take adavantage of the VS10 engine. So far so good. However, I must say that the Jellyfin AndroidTV UI sucks. The wall poster with only two lines, moving horizontally is bad.

    So now I am looking for yet another option: Use Kodi (or should I use ZDMC?) with the Jellyfin plug-in so the library data is consumed from my Jellyfin server, using the nicer Kodi client interface.

    a. Is ZDMC/Kodi too heavy for the Zidoo ?
    b. Would ZDMC work with the Jellyfin Kodi plugin (or any other Kodi plugin)?
    c. I assume I can still configure ZDMC to use the native Zidoo player so VS10 can be applied. - correct?

  6. andy22

    andy22 Active Member

    Try the "experimental" vertical layout, but seems this mode is optimized for 1080p not 4k.


    You need to use ZDMC, so the "internal" Zidoo player gets used, instead of default kodi player.
    Most plugin will work, unless they depend on the normal Kodi player somehow.

    ZDMC does this by default, there is a new "use external player" option that is just that, if disabled normal kodi is used.
    danbez likes this.
  7. 3DBuff

    3DBuff Well-Known Member

    @danbez, yes HT does not maintain disconnected sources. It's a real bummer and probably an easy fix. Introduce a check mark in the source selection to maintain database when drive is disconnected.
    Unfortunately Zidoo @mirror and @Markswift2003 don't see it as benefit :(
    nc88keyz likes this.
  8. Zapo

    Zapo New Member

    Hi all, first post. I purchased a Z9X to get around the limitations of running Kodi on a Sony A80j, which were lack of ability to play DV and the TV not being able to pass uncompressed audio (DDHD, DTS:X) from internal apps like Kodi.
    I was hoping to run ZDMC on the Z9X as I am used to the Kodi interface but have run into a stumbling block not long after installing it. For some reason ZDMC will not play any video that is 720p or higher. I try to play a file, ZDMC tries to load the file from a NAS and comes right back to the ZDMC interface.
    If I deselect the external player then I have managed to play a file. It looks like the the external player is not working inside ZDMC. Is there a setting that I have stuffed up that would cause video not to play with the external player?

    I am able to play 4K files from Media Center, so I know I can play files from the SMB share on the NAS.

    Any ideas?

  9. 3DBuff

    3DBuff Well-Known Member

    That's kind of strange. Is Home Theater working OK? Make sure ZDMC is starting correct Zidoo hardware player. Check with remote "Info" button when the movie is on. Adjustment for this player is on home page Quick Settings. Select auto resolution and refresh rate for playback. Don't select any custom EDID files.
  10. Phil181

    Phil181 Active Member

    ZDMC is primarily used as a "shell" front end for the Zidoo player. Since the files play in Media Center, they should also be fine playing from ZDMC.
    I am a daily user of ZDMC with mutiple sources.

    There must be something in your Kodi setup/settings that is not yet right.
    Check your Kodi "sources" for where it is pointing to your NAS. If it shows as being "ftp/...." it is not right, and should be showing "smb/...."
    You may need to delete/change the Kodi current source and try linking it again.

    You don't want to be using the Kodi player for anything other than SD files.....
  11. Zapo

    Zapo New Member

    Hi all, thanks for the replies. I ran Home Theatre and it was able to access the files over SMB and play all files, so it looks like the player is ok.
    I have set up Kodi inside the Sony TV and ZDMC to access the same NAS share over SMB. ZDMC bombs out back the media selection screen when trying to play any content that is 720p and above. It can play 480p but that would be using the native ZDMC player.

    Tonight I even reset the Z9X, re downloaded XDMC, re installed it, re added the SMB share and with out doing much other configuration it would still not play media above 720p.
  12. Zapo

    Zapo New Member

    Ok looks like I worked it out. I used a domain account to authenticate to the NAS in the ZDMS SMB settings. This did allow ZDMC to access the share and scrape the files.
    I kicked off diagnostic logging and found in the log that the in built player was only sending the user name and password but not the domain. So the player was failing authentication. Changed the account used to a local NAS account and ZDMC was able to successfully launch the in built player and play the file from the NAS.
  13. 3DBuff

    3DBuff Well-Known Member

    Sounds complicated. What's wrong with username and password on LAN Samba Share? Works like a charm with ZDMC, HT media browser, PC and my iPhone. No authentication required.
  14. Phil181

    Phil181 Active Member

    There is no need for even a user name and password as long as the NAS is set for local anonymous access.
    I did find that it was better with ZDMC (Kodi) to browse for shares using Zeroconf Browser then add them from the list, rather than via SMB source.
  15. Zapo

    Zapo New Member

    I have a Windows domain that the NAS is configured to use so I prefer to use domain accounts to access things on the network. On the Sony TV the kodi install works fine with the domain credentials to access the shares on the NAS. The problem I had is that ZDMC on the Z9X is able to use domain credentials to access the NAS shares but when it passes playing of files over to the Z9X player, that player only sends a user name and password and not the full domain credentials of "domain name\user name" and password. So the authentication from the Z9X player would fail and drop back to ZDMC.
    Anywho all sorted by just using a local NAS user name and password.
  16. Franconian

    Franconian Active Member

    Is it me or does ZDMC 19.4 run a slower than ZDMC 19.1? When navigation through the UI everything seems to take a few milliseconds longer to appear and is not as fluid as before.

    I installed it directly over the existing 19.1 so I'm not sure if that causes the issue. In the past with ZDMC 17/18 I created backup with the Backup addon, removed ZDMC, did a clean install and restored the backup. Unfortuately not this time.

    Can anybody confirm?
  17. DMD

    DMD Member

    I entered post in the wrong section.
    Last edited: Sep 28, 2022
  18. 3DBuff

    3DBuff Well-Known Member

    You should report it in .29 thread here. It's not ZDMC issue. Both firmware version . 28 and .29 don't work with ZDMC and external Zidoo player.
  19. DMD

    DMD Member

    OK! Excuse me.
    Last edited: Sep 29, 2022
  20. azon1951

    azon1951 Active Member

    Thank you so much for this. I found an old thread with the same issue and I'm disappointed that they didn't fix it until now.

Share This Page