Jellyfin AndroidTV Client Thread

Discussion in 'Jellyfin for Zidoo' started by andy22, Jun 18, 2022.

  1. Six66Mike

    Six66Mike Member

    Support should essentially be re-directed to now, right? Any issues can't be resolved here as it has nothing to do with Zidoo dev.

    By comparing to HT, isn't that just a gap in features? Shouldn't the comparison be to Andy's forked version?
  2. Six66Mike

    Six66Mike Member

    Has anyone tried to have both clients installed on their Z9X at the same time, so you can keep using the Zidoo client Andy made while testing out the official Jellyfin client? Can you install both apk and switch between them easily without issue?

    Would be a good way to identify gaps and verify issues.
  3. Markswift2003

    Markswift2003 Well-Known Member SUPER Administrator Beta test group Contributor

    Worth a go, but the problems are related to how Jellyfin interacts with the Zidoo player and I doubt the Jellyfin devs will be interested or be able to do anything since it relates to an "external player" over which they have no control.
  4. Markswift2003

    Markswift2003 Well-Known Member SUPER Administrator Beta test group Contributor

    You can't install both at the same time and in order to switch you need to first uninstall the existing version.
    Six66Mike likes this.
  5. Six66Mike

    Six66Mike Member

    Pretty much the trouble I had. I shared playback issues here that weren't a problem on the Zidoo player, tried the Jellyfin forum, and basically ended up with no support on either side because they wouldn't touch Andy's fork either.

    Still can't run The Simpsons episodes via Jellyfin. Will keep an eye on any issues flagged in the original client and see if its worth the switch. Other than that everything seems to be working fine still for me.
  6. Markswift2003

    Markswift2003 Well-Known Member SUPER Administrator Beta test group Contributor

    Because it's a client/server thing, there's no harm in uninstalling Andy's app and trying the official version and switching back if you don't like it.
    Six66Mike likes this.
  7. Zaudio

    Zaudio Member

    I'm trying out the recommended Android TV apk on my Z9x. It's playing everything... but
    • I do not get anything ever in the Continue Watching on the Home page - some of you say you have this working? If so, how did you get it working? I get the Zidoo player resume if I play the same movie again note.
    • I get an annoying 'Mark Watched' prompt every time I stop playing any video - how do I get rid of that?
    • I'll add to the missing meta tags: no 3D tags show up for any 3D files in this app. I do see them on my windows PC browser client.
  8. Zaudio

    Zaudio Member

    Doh... all this time of setting this up I thought I was on the Z9x 6.4.42 firmware... I was not... I was on 6.4.06; which according to Andy's notes would not support the new Zidoo API. I updated my firmware to 6.4.42, and now the first two bullets above are resolved! The continue watching and the Jellyfin Resume button now both show up correctly, regardless if I use Stop or back to stop playing. Fantastic!
    So just this left now:
    • I'll add to the missing meta tags: no 3D tags show up for any 3D files in this app. I do see them on my windows PC browser client
    Six66Mike likes this.
  9. Zaudio

    Zaudio Member

    Can anyone please shed any light on how to get subtitles to select properly on the Z9x (6.4.42), with the official Android TV Jellyfin client, server 10.8.10. External player set of course in the app ?

    It seems that the client will select the same index subtitle that you latest played from any other video.
    For example, I test played my 'Coda' mkv, that has a single default forced english sub track. I had to manually select that track to get the subs.
    I stopped that video and started my 'Bladerunner 2049' mkv. This has 4 non default subtitle tracks... I would expect it to start with 'none'; it started with the first subtitle track. I selected none to get rid of it.
    I stopped that and restarted Coda... that now has no subtitle track selected again (it would have if I had started it without changing the subtitle track on Bladerunner to none)
    Even weirder is if I start a .ts 'Bladerunner 2049' I also have that has a single subtitle track that my Zidoo seems not to offer me. In this case, after playing Coda with the first subtitle track, I then get that same Coda subtitle track set for watching Bladerunner... I can again set it to none.
    I've messed around with the Z95 playback setting to try to resolve this... nothing helps... and can only make it worse if I enable the forced subtitles option (I'll end up with Code subtitles forced over Bladerunner and then cannot turn them off!)
    The subtitle setting in Jellyfin seem to make zero difference to what get selected for the Jellyfin client running on the Z9x
    This behaviour is somewhat annoying... currently I'll have to just manually enable subtitles for movies that I need them for, and have to remember to turn them off to avoid getting unwanted subtitles in my next movie.
    I don't think it matters if the subtitles are external or not for this behaviour. My Coda subtitles are external, and named correctly in the same folder as the movie; Bladerunner they are embedded.
    Needless to say, subtitles for Jellyfin running on my PC follow the flags and Jellyfin settings I have correctly; and playing movies on the Z9x via HT4 also works as expected.
  10. Enet

    Enet Active Member

    Andy's Jellyfin client works well for me and direct path play enables it to play blu-rays but I'm moving to Plex. Plex also has direct-play, but I'm not sure that it can play blu-rays. But it is easier to set-up maintain. I have created multiple servers with various movie/TV libraries automatically synced between servers. I also set up multiple clients on different devices. With the exception of some special PC requirements, this took about 20 minutes to complete.

    Of course this would not have been possible without the work of the Zidoo devs in creating a Plex client and the developer of the PlextoZidoo app which enables direct play on the default Zidoo player.
    Last edited: Aug 20, 2023
  11. Zaudio

    Zaudio Member

    Ok, watched another movie that needed an External subtitle file adding... I neglected to mention in my past post that I added an External subtitle file for Coda... THAT is the problem. The Jellyfin client is not using the shared path I set up for my library, and the Zidoo 'external player' thinks the movie is 'Stream'; and does not have the folder location for the actual file... so it cannot use the external subtitle file.
    I had browsed to it through the file tree to pick it. Did this again to add the external subtitles today for another movie... Now I always see TWO external subtitles listed for every movie I play from the Jellyfin client.
    This is of course unworkable... ie external subtitle files are just broken with this Jellyfin client playing to the external player.
    Please can the devs add back the Direct play using the shared path for the external player... I think that would fix this problem.
  12. Six66Mike

    Six66Mike Member

    Ok I noticed something strange yesterday when I was checking my Trakt account and not sure if it's a Jellyfin issue or the plugin used for Trakt integration. I'm still on Andy's build with FW version x.42 and Jellyfin running on my Synology NAS using v10.8.10 from the SynoCommunity build.

    On my movies, the play count seems reasonable, ~1200 movies watched and play count pretty close to that (kids like to rewatch stuff, right?).

    TV shows though...11,600 episodes watched, close to 64,500 plays. After watching The Haunting of Bly Manor once, it said I had over 84 hours time watching it, I think either 2,000+ or 20,000+ plays. I removed all plays then marked it watched once to fix it. So when I check now, the highest play count is an episode of the Africa BBC documentary, 260 plays. I've watched it once! Almost all the Mythbusters episodes I have are well over 200 plays each.

    When I look at a Mythbusters episode, Trakt says S15E04 added December 2022 and played 246 times since. Checking the details every single play occurred at 5pm on the same day. Is it possible that every night when Trakt syncs, it's incrementally adding to the play count instead of ignoring it because it has already been synced? I'm going through and it looks like it started to do erratic counting on Nov 23 2022 around 10:40pm then stops for that day at 10:50pm. Same on the 24th, on the 25th the play counts start at 4:03pm and update dozens of times per minute, and stopped several hours later.

    Dec 8 through to around the 23rd has hundreds of pages of repeat plays at the same times, usually across a whole season at the same time. Wondering if maybe my updating and flagging things as watched caused multiple re-syncs to occur the same time?

    The last crazy play count I have is from Alone: Frozen on July 8 where at 9:38pm = Episode 1 (8 plays), 2 (80 plays), 3 (79 plays), 4 (79 plays), 6 (81 plays), 7 (80 plays), and 8 (77 plays). All on the same timestamp, quite possibly the time I added it to Jellyfin. The same day has stacks of other mentally high play counts, though July 11 I added Two & A Half Men, and so far none of the 11 episodes watched have a play count higher than 1. Other shows added on July 11 and watched only have 1 play count, but when I look at July 8 shows (Alone: Frozen, WWE Legends) they have high play counts but other shows added the same day (Beavis & Butthead, Shark Tank, From, etc.) only have 1 play count which is accurate.

    Anyone else with the Trakt integration able to see if their Trakt profile has similar play count issues? I'll check to see if that 246 count changes over the next few days to see if it is the sync.

    Does anyone know how to do a play count re-set either through the app or on the Trakt site to get it back to 1?
    Last edited: Aug 22, 2023
  13. Nathan W

    Nathan W Member

    Same thing happened to me recently with the Vanilla/Official Jellyfin App. I use the trakt plugin with jellyfin and PlexTraktSync for plex, so I have watch status across Jellyfin/Plex synced with Trakt as the middle-man/common ground. My Trakt API account which PlexTrakySync uses got flagged and was disabled because of this. Just had to reach out and explain my setup and they re-enabled it
  14. Six66Mike

    Six66Mike Member

    Luckily Trakt haven't killed my account. Is it still happening or has it resolved itself?

    As of this morning Mythbusters episodes incremented to 247 plays though the Africa episode is still 260. No increment to Alone: Frozen episodes yet either but that will probably happen later. I'll keep an eye on Animaniacs as well, current total plays for season 1 is 3,468. If Mythbusters went up once, I think each day a portion of the library updates through the API and the play count increases by 1 each time.

    I'm guessing now this is a plugin bug.
  15. ya_boy_danny_rand

    ya_boy_danny_rand New Member

    I'm currently using the Official Jellyfin client on my z9x to play only tv shows. I tried using it for movies too but they all skip and freeze, especially the 4K movies. not sure what the problem is as i have transcoding turned off so everything should direct play. I actually see when i start up a movie that it says it's direct playing on the server dashboard but they still skip and freeze. I have all my movies set up in HT4 and they seem to work fine on that and honestly it's much easier to set up movies and leave them on HT4. Jellyfin is much more flexible with shows than HT4 in my opinion. I wish though i could get them all running on Jellyfin so i wouldn't have to switch back and forth between apps.
  16. Markswift2003

    Markswift2003 Well-Known Member SUPER Administrator Beta test group Contributor

    Can't think of a reason they'd do that unless you have the wrong player selected in Jellyfin.
  17. ya_boy_danny_rand

    ya_boy_danny_rand New Member

    I have no idea. I have it on "External Player" in the options on the z9x, which i think from what i've read here is the option i'm supposed to have checked. network is hardwired, so not a wifi issue. i had a small switch in the mix and removed it and tested and that didn't change anything, so put it back in. i have the jellyfin server running on my main pc and not a nas or other box, so just wondering if that has something to do with it. hoping to build a custom separate nas at some point soon.
  18. Markswift2003

    Markswift2003 Well-Known Member SUPER Administrator Beta test group Contributor

    That's right, although mine says "External app" rather than "External Player" so maybe there's a version conflict?

    But it just calls the Zidoo player and with a few caveats (BD Menu and chapters for example) it behaves as if you'd played the file from HT.

    I have Jellyfin Server running on a PC sitting 3 switches and a monstrous amount of CatV away from my player.

  19. ya_boy_danny_rand

    ya_boy_danny_rand New Member

    You're correct, it was just a typo on my end. mine says "External App" as well.
  20. I had this issue initially after installing the new android app. I'm not entirely sure what fixed it, but I changed some settings and all of a sudden it worked fine. I thought it was changing the bandwidth from Auto to whatever the max was, but I don't know if that was actually it. Maybe it just randomly started working for me and was unrelated to your issue, but thought I'd mention it as I did get it working properly.

Share This Page