How to prevent the Mele F10 pro controller sound issue

Discussion in 'ZIDOO X6 Pro' started by cyber7, Mar 3, 2016.

  1. cyber7

    cyber7 Active Member Beta test group

    Hi Guys
    I just picked this up from a South African forum and thought it could be of use? It does, however, disable Audio through the Mele...

    kind regards
    cyber7 (aka Aubrey Kloppers; Cape Town; South Africa)

    The Thread:

    How to prevent the Mele F10 pro controller sound issue
    The Mele F10 pro controller comes with built in sound but it's designed specifically for the Mele TV box and doesn't work on other makes. When connected to other boxes, it causes android to switch to the Mele F10 sound card which disrupts video playback (stuttering) and there's no sound.

    There are two ways to resolve this:
    1. (Less technical) Install Soundabout and make sure that HDMI is selected as the sound output (or whatever output you are using - in other words, not USB which is the Mele device). Some people have reported an issue where the HDMI option disappears from soundabout which requires a reinstall of the app to bring it back.

    2. (a little more tech but permanent - my personal fav.) Install ES File explorer and edit the audio policy file to disable USB as an audio option

    • Recommend you do this with a proper keyboard / mouse attached.
    • Install and run ES File Explorer
    • Under tools (left), make sure root explorer is 'on'
    • Click root explorer and then Mount R/W - make sure /system is set to RW
    • Then under local (left), select / then in the main window navigate to /system/etc and click 'audio_policy.conf' to edit it (chose ES Note Editor)
    • Click the menu and select 'edit'
    • Find the line that starts with USB and comment out all the lines in that section like this:

    Code:
    # usb {
    # outputs {
    # usb_accessory {
    # sampling_rates 44100
    # channel_masks AUDIO_CHANNEL_OUT_STEREO
    # formats AUDIO_FORMAT_PCM_16_BIT
    # devices AUDIO_DEVICE_OUT_USB_ACCESSORY
    # }
    # usb_device {
    # sampling_rates 44100
    # channel_masks AUDIO_CHANNEL_OUT_STEREO
    # formats AUDIO_FORMAT_PCM_16_BIT
    # devices AUDIO_DEVICE_OUT_USB_DEVICE
    # }
    # }
    # inputs {
    # usb_device {
    # sampling_rates 8000|11025|16000|22050|32000|44100|48000
    # channel_masks AUDIO_CHANNEL_IN_MONO
    # formats AUDIO_FORMAT_PCM_16_BIT
    # devices AUDIO_DEVICE_IN_USB_DEVICE
    # }
    # }
    # }

    • Click back then save.
    • After that reboot (not sure if it's required, but it won't hurt).


    Problem sorted!
     
  2. spring

    spring Well-Known Member Zidoo TECH Supporter

    Hi:
    thanks!
    we are working for this issue, and maybe nest version will fix.
     
    cyber7 likes this.
  3. cobra78

    cobra78 Member

  4. grummel2005

    grummel2005 Well-Known Member

    o.t. but near the theme here

    you told us some weeks ago before your holidays that you will include the logitech k400
    how is this working?
     

Share This Page