Chat Help getting me started setting up new X9S by Ourglass

Discussion in 'ZIDOO X9S' started by framednlv, Sep 18, 2018.

  1. framednlv

    framednlv New Member

    I bought a Zidoo x9s from ebay and it is a rebranded one by Ourglass.

    Do I need to update the original Ourglass firmware to become an actual Zidoo? If so, could I get a link to the instructions that apply to this Box?

  2. litlgi74

    litlgi74 Member

    If you found the deal on AVSForum... I was the original poster... but the thread was taken down.

    This should get you going...

    Flash your player following this procedure:

    Then upgrade your player to the newest FW...

    After the you restart the player... A pop up (image attached) appears on the screen when the player tries to access the internet...

    You just need to email a photo of the pop up or the MAC address to Zidoo @ ... Once they respond... you'll just need to restart the player and everything works as it should.

    What the pop up looks like:
    framednlv likes this.
  3. Tony77

    Tony77 Member

    Thank you LITLG74!

    I was one of the people who saw your post and happily took your advice! I hade to wait over the weekend for activation but both units working TODAY!! YAYY
    I was an unhappy camper for 3!

    Anyway the thread from avs forum can still be found by doing a GOOGLE search and selecting CACHE view.. I have included the link below of their cached version of the thread... And for future reference...anytime you are looking for old threads you can you the "WAY BACK MACHINE".. google it... it keeps a SEARCHABLE COPY of almost EVERY public accessible webpage everyday going back approx. 20yrs..

    Im curious WHY the thread was removed ??? do you know?

    Last edited: Sep 18, 2018
  4. litlgi74

    litlgi74 Member

    Someone reported me for Spam Advertisement... I was given three points and told not to speak about the player on the forum or via private message... Or I would be permanently banned!
  5. framednlv

    framednlv New Member

    Thanks Litlgi74.
    I read about it last week and decided to submit an offer. Needless to say, offer was accepted.
    I got the firmware upgraded after a couple of tries. I ended up holding the reset button in while turning it on with the remote.
    Pop up was found and picture sent to

    After the update I'll have more questions.

  6. framednlv

    framednlv New Member

    My next task our to get Hulu and Netflix to run. It seems like there was a downloadable app that would work, any ideas on these two? Or is there setting that will help?

    I should mention that Hulu installed from BigBrother's Playstore, but gave me the 3(-996) error.
  7. litlgi74

    litlgi74 Member

  8. framednlv

    framednlv New Member

    Have not tried that. I did download an older version and it plays, but no time to watch anything and evaluate.

    I need to fix my setup for watching TV, due to the fact that we just sent our DishNetwork back ($$$ saved). Yesterday my AV receiver stopped sending video to the TV. I might just use a HDMI switch and keep one cable to the AV receiver to feed sound.

    Antenna is pulling in some good stations. I bought cheap tuner to help with recording one movie at a time. But am thinking about buying the Tablo 4 as the wife has alot of local network shows she watches. DVD player no longer plays Hulu but work fine with Netflix. My phone can cast Hulu chromecast and works fine.

    I need to re-evaluate what I need and try to bring everything together to work as one unit.

    Any ideas how to bring Netflix, Hulu, Amazon and OTA all together and play from one device?

    Thanks for anyone that wants to participate in my ramblings.
  9. Tony77

    Tony77 Member

    That's BS.. Is PM MSGS available here?? if you know how can you please contact me, as I can't figure it out..

    Im having some issues & have questions like OP. After I upgraded to 2.1.1 firmware half my apps DISAPPEARED!! starting with ZDMC AND HOMETHEATRE????????? WTF? I was able to actually reflash back to initial firmware, but oddly afterwards it shows my firmware as 2.1.1????? but hometheatre DID get installed somehow??? not sure what is going on here... I downloaded apk of zdmc but it is not SAME version that came with 2.0.34????

    Even though Im still trying to get an initial setup going and haven't figured out where this app store is, in reference to other apps "Netflix, hulu, amazon etc", I would assume these should install just like you do on your android phone... From what I see it appears the box is running a regular android version..(it even thinks its on a phone).. So installing an apk off a usb or from google play if available SHOULD work... If Im wrong about this can someone pls explain..

    ps.. if anyone knows how I can get back to my initial setup from 2.0.34 before upgrading to firmware 2.1.1 would be highly appreciated...

    thnx..and HELLO to everyone here! lets help eachother.. ;)
  10. litlgi74

    litlgi74 Member

    To PM... Click on a user's profile name and click start a conversation...

    I sent you one. It should be in your inbox.
  11. litlgi74

    litlgi74 Member

    Last edited: Sep 21, 2018
  12. tim_b

    tim_b New Member

    Did they answer you? How long did it take?

    I tried to sent a picture (jpeg) and the email was rejected with the permanent 550 error
    'Mail content denied'. Sent another email with the pop up message typed as a plain
    text - no answer since Friday.

  13. Tony77

    Tony77 Member

    Still not working? if your attachment (jpeg) is too large it probably rejects..

    1) reduce resolution of jpeg, or take new pic at MINIMUM resolution.
    2) send ur pic as a tinypic or share link from your google drive or dropbox.
  14. tim_b

    tim_b New Member

    It's not that big. 199KB. Shouldn't be more than 300KB after encoding.
    I thought about sending a link or maybe renaming the picture file to use
    some fake extension or no extension at all. But I haven't received a reply
    even to the plain text messages. Which were accepted by the remote side,
    according to my mail server's logs. That's why I asked how long did it
    take for them to answer. Maybe it's normal and I just have to wait for
    a few more days.
  15. K.W.H.

    K.W.H. New Member

    I got my response back saying that it was activated and to reboot the box but no matter how many times I reboot I still get the activation failed error. How long does it take and is there another method to force it?
  16. K.W.H.

    K.W.H. New Member

    Never mind... activation finally took.
    litlgi74 likes this.
  17. framednlv

    framednlv New Member

    Sorry guys,
    I was busy doing other things.
    Activation was about an hour. Must have been good timing.

    Got Netflix and Hulu working by searching the internet for android 6.0 and the Netflix and Hulu. I added and uninstalled so many times that I had to connect a USB keyboard and mouse.

    Can I cast to the x9s from other android devices? If so, what app is needed?
  18. framednlv

    framednlv New Member

    The HDMI in does not seem to work with any device I connect. I tried my security NVR at every resolution it has and nothing worked. I tried my TV converter box at all resuluions and it didn't work. I tried a chromecast and it didn't work.

    Any ideas how to get the HDMI in to work?
  19. framednlv

    framednlv New Member

    I gave up on this, went to bestbuy and bought the Roku Ultra.
  20. aresjose

    aresjose New Member

    Hi, I just purchased a
    ZIDOO X9S 4K Smart TV Box Android 6.0 Realtek Quad Core 2G+16G WiFi BT 3D 64bit ( Ourglass rebranded ) on Ebay.
    I follow your instructions to upgrade the unit then I got a reply from Zidoo saying these is not their unit and to get in touch whit the seller of it, After I upgrade the unit, has sun I connect it to internet It gives Me the error message and the applications don't work, can I get some help on these issue or it is not possible to do some thing? Please some one help Me. I will appreciate.

Share This Page