[FIXED] Home Theater 2.0 crashing upon adding SMB source

Discussion in 'HDD Media player(RTD 1295)' started by Lexou, Jun 19, 2018.

  1. Lexou

    Lexou New Member


    Owner of a new Zidoo X9 player for 2 months, I was never able to have HT 2.0 to work.
    When purchased, I updated the player to FW 2.0.15.
    I could then add my SMB sources to Media Center without issue (I only have SMB medias) or into ZDMC.
    But whenever I tried to add those source to HT 2.0, it crashes displaying the famous Android message "The application has stopped" (or something similar) : I can browse the SMB folders, select the any folder to add, and then crash. If restarting the application as it is, it will crash right away.
    I then need to clear the application data, then the app can start, but will crash again if I try to add a new SMB source.
    I created a log using ZidooLog at that moment (file attached).

    Since then, I updated the player to FW 2.0.25, but unfortunately, the result is the same (even if the HT 2.0 app has been updated in this FW). I also attached a log made with this firmware.

    Does anybody have encounter this issue ?
    I've tried to look in the forums, but it seems that no one has ever had this particular issue.

    Funny thing is that looking at the logs, the first exception raised after the crash is a String OutOfBound... :)

    Thanks for any help.

    Attached Files:

  2. mirror

    mirror Well-Known Member SUPER Administrator Zidoo TECH Supporter

    ƀhanks for your feedback.we are checking it.
  3. lic

    lic Member Zidoo TECH Supporter

    I guess the most likely thing is that your password has special characters.
  4. Lexou

    Lexou New Member

    Thanks for the suggestion, it indeed has some. I'll try a simpler one and check.
    This doesn't explain why it works fine in media center or ZDMC though.
  5. lic

    lic Member Zidoo TECH Supporter

    "We have found the problem caused by the "&" in the password, which has now been resolved, please note the latest release --Zidoo TECH"
  6. Lexou

    Lexou New Member

    Hi Lic,

    Thanks for this info.
    For the latest release, are you referring to the beta FW 2.0.32 ?

  7. Lexou

    Lexou New Member

    Hi all,

    Sorry for the late reply.
    I can confirm that the issue no longer occurs with the FW 2.0.34, and that I can my SMB sources in HT2.
    Thanks to the support team for this fix.


Share This Page