cant flash x9s

Discussion in 'ZIDOO X9S' started by Marathin, Oct 24, 2017.

  1. Marathin

    Marathin New Member

    Hi There,

    tried to flash my device as described:
    - downloaded Firmware
    - Unzip it
    - Copy to Root of USB
    - Press Reset Button at the Back of device With needle
    - Push Power at Remote
    - At device Display is shown for 2 seconds "Up..."..then "Hello" with Powerlight is red
    - In TV Screen the Zidoo Logo comes....

    ...and stays for hours with "hello" at device Display and Red Light.....

    can someone help me ????
  2. looun

    looun Member

  3. Nice Monkey

    Nice Monkey Well-Known Member Beta test group

    Zidoo uses a different method for emergency recovery than (most) media players do. It has a special boot-loader (tiny Android independent program) which re-stores a full working Flash Memory image from USB The restore does not rely on any Android code at all, which is the good news as it may recover from any condition as long as the boot-loader code is still intact. The nasty thing is that during the actual restore nothing may go wrong, keeping the box running during the process (including power) is absolutely essential.

    A side effect is that one can only do emergency restores to FW versions with associated Flash IMG files made available. In most cases a second action will be required to update that version to the desired FW level.
  4. Marathin

    Marathin New Member

    thx alot!!!!!

    so where can i get the mentioned Files and how to Install IT???
  5. Nice Monkey

    Nice Monkey Well-Known Member Beta test group

    Given above by looun!
  6. Marathin

    Marathin New Member

    ok so far thx to all, but.....

    when i want to have older firmware taken by offered firmwares here on Zidoo i.e. can i get them on device...?
  7. Nice Monkey

    Nice Monkey Well-Known Member Beta test group

    You can do manual upgrades/downgrades by putting the firmware on an USB stick and install it next. Upgrades to the latest FW will be offered automatically via OTA. There is even a help in Zidoo menu which tells the how to do this.
    Last edited: Oct 25, 2017
  8. Dairy_Farmer

    Dairy_Farmer Member

    Go to post #93 at
    When I did it the front USB2 port didn't work. The second USB2 port did.
  9. Marathin

    Marathin New Member

    when i tried to downgrade by USB there comes a hint " verifying failed...Firmware is Power than installed"
  10. PacoRabanne

    PacoRabanne Well-Known Member Beta test group

  11. Marathin

    Marathin New Member

    can anyone Post a Link of img File of Firmware 1.3.0..??

Share This Page