Beta version v1.0.60 for Z9X Pro release

Discussion in 'HDD Media player(RTD 1619BPD)' started by Markswift2003, Nov 3, 2023.

  1. sandyj

    sandyj Member

    Here goes try this I have written this for others as well so not all comments are aimed at you.
    The goal here is to give the file system the greatest chance too perform at its best when used with a Zidoo player or any other media player.

    The issue I was having "MKV files suffer from micro stutter, frame skipping or playback slowing down" and don't have them now after doing the below.

    First make sure you have the following

    1. The latest Synology DSM updates 7.2
    2. Check the app update and make sure you have all the SMB updates these are found in the package center there has been a lot of fixes for this.
    3. Under HDD hibernation set - internal and external drives to not hibernate do this for both settings in there - you may be able to change this back latter but for purposes of elimination don't have these on until the problem is resolved.
    4. If you’re Synology has more than one network connection only use one.
    5. Don't use wireless connections in the chain.
    6. Check network cables are good or swap out with different ones
    7. Don't use USB connected drives for now
    8. Make sure the network connection is at least 1000 Mbps at the NAS and Zidoo
    9. A failing hard drive can cause slowness and bad performance. Check logs and storage manager for warnings.
    10 Defrag your storage drives once in a while or schedule them to run.

    Ram 8GB is a good start.
    Add as much ram as possible this is used for the Synology file cache which improves performance of the file system. There is a certain amount used for apps although this is important to have the file system greatly benefits from extra Ram being available.
    example my NAS system is currently using 11.3 GB just for the file cache during movie playback it often uses nearly all the available ram up to 32GB. Please note I am not necessarily saying you need as much as this just increasing the memory helps a lot.

    Resource monitor is you friend use it check the CPU and memory tabs you never want to see the swap file being used in there either.

    Settings in Control panel
    Under hardware & power

    1. General - disable Memory compression - Ram compression is designed for ram starved systems don’t use it increase your physical ram there is no free lunch here.
    2. General - Fan speed - cool mode - generally this is fine as long as the environment is not overly warm. Poorly cooled drives can lock up and slow down if overheating.
    Note: I have seen many USB drives do this as there cooling is usually very bad and can greatly affect the life of the drive. I won’t use them for any system with sustained high loads either.
    3. HDD hibernation - Turn all hibernation modes to off

    Settings in Control panel
    File services
    1. SMB - advanced settings SMB3 Maximum - SMB2 Min
    2. SMB - advanced settings - General - Transport encryption - Disable
    3. SMB - advanced settings - General - Enable server signing - Disable
    4. SMB - advanced settings - General - Enable opportunist locking - enable
    5. SMB - advanced settings - General - Enable SMB2 lease - enable
    6. SMB - advanced settings - General - Enable SMB durable handles - May help but mine is currently off.
    7. SMB - advanced settings - macOS - all off
    8. SMB - advanced settings - others - Enable Dirsort VFS - enable
    9. SMB - advanced settings - others - Enable asynchronous read - enable ***
    10. SMB - advanced settings - others - Enable performance analysis - Don't use this bad for file performance
    11. AFP - all Disabled
    12. NFS - All Disabled
    13. FTP - All Disabled
    14. Advanced - file fast clone off

    *** important
    The network settings are tricky here as there is many combinations that can be used however these are the ones that work for me.

    I also use a SSD cache but that's another subject for latter.
    Last edited: Nov 5, 2023
    Onwrathz, blenky and fattire like this.
  2. fattire

    fattire New Member

    It is 4K 23.9 from the Zidoo. Moving the Zidoo HDMI cable to the Xbox, the Xbox is stable at 4K120 HDR. The Zidoo is the problem.
  3. blenky

    blenky Well-Known Member

    Thanks for that really helpful. A couple of points

    I've ordered a 4GB RAM module for my DS220+. It has 2GB as standard and the maximum you can upgrade to is 6GB. All helps!
    I don't think I can defrag my internal hard drives. DSM help states "File system defragmentation can only be performed on volumes in the Btrfs file system'.
  4. fpinna

    fpinna New Member

    It happens right out of the gate on both the two 4K DV/HDR10 MKVs I have for the moment. The files are MKV remuxes with video untouched from the UHD Blurays and are played from a USB 3.0 external drive connected to the USB 3.0 port on the rear of my Z9X Pro. I also have tested these same files from my QNAP NAS connected via SMB and I have the same issue. The movies are Elemental 4K DV (Disney/Pixar) and Avatar - The Way Of Water 4K HDR10 (20th Century Fox/Disney). On Elemental the stutter is very apparent at the very beginning in the Disney clip with the castle, during the camera movement along the waterfall upward to the castle, but it's consistent throughout the movie anytime there is a lateral or vertical panning. Same goes for Avatar - The Way Of Water. If I select another audio track, in my case Dolby Digital plus for both the MKVs, the movie is played smoothly. I don't know if there is a meaningful link but both the movies are from Disney.
  5. sandyj

    sandyj Member

    Ram really helps here and is often over looked and miss understood unfortunately most NAS systems come with the bare minimum amount. Btrfs is the recommended file system format for synology NASs as it is a very advanced format which brings it inline with features Microsoft has however you may have your reasons for using other formats.
  6. sandyj

    sandyj Member

    Can you check the bit rates under video file stream in the file using Media info might shed some light ?
    What software did you use to create the MKV with ?
  7. fpinna

    fpinna New Member

    Video Bit rate: 40.7 Mb/s - Overall bit rate mode : Variable

    Avatar - The Way Of Water:
    Video Bit rate : 43.9 Mb/s - Overall bit rate mode : Variable
  8. sandyj

    sandyj Member

    Can you rip with fixed bit rate and see if the issue exists when the pans occur the bit rate will be higher can you see what the max bit rate is ?
  9. blenky

    blenky Well-Known Member

    I have two internal WD Reds which are ext4 and two connected external USB drives which are NTFS.
  10. blenky

    blenky Well-Known Member

    Are you able to create a 5 minute clip using MKVToolNix and then upload to somewhere like Mega? I can the d/l and see if I see same issue. This would rule in\out the video file itself.
  11. essam

    essam New Member

    Hello.connected z9x pro to a sounbar does not display 4k resolution,only 1080p i have an oled tv,directly with cable, tv works 4k.
  12. andy22

    andy22 Active Member

    Quick question regarding two issues i noticed with my new box + this FW version:

    1) If i enable subtitles it actually takes like 30s until the first subtitles appear, are rendered. The info screen directly reports that i have the subtitle track selected, but they are not immediately shown.
    2) For me the dynamic "lake hdr10+" test file, is still not using any dynamic HDR10+ metadata, either in "Auto" mode and my TV reporting a "HDR10+" stream, i also tried in "DV" mode.
    Wasn't this supposed to be fixed for the new boxes? At least i did read something regrading this on the Zidoo product page?
  13. Kenshin

    Kenshin Member

    Hi Mark ..why is the soundtrack in H.T. limited to 16Bit only !!! 24bit and 32bit do not work !!! ??? thx.
  14. Markswift2003

    Markswift2003 Well-Known Member SUPER Administrator Beta test group Contributor

    1) No problem here with PGS or SRT - do you mean that if the subtitles appear in the first 30s of video they don't show, or do you mean the first subtitle, regardless of when it starts, takes 30s to show?

    2) HDR10+ lake test is working fine here - just tested now.

    HDR10+ metadata won't work in any VS10 mode because unlike Dolby Vision, HDR10+ metadata isn't converted by VS10, but it works fine natively (HDR > Auto)
  15. Markswift2003

    Markswift2003 Well-Known Member SUPER Administrator Beta test group Contributor

    24-bit TrueHD Atmos and 24-bit DTS-HD obviously play fine.
  16. Kenshin

    Kenshin Member

    YES,right 24Bit works! but 32Bit doesn´t work. ??? on zidoo Z9x Pro but on zidoo Z9X works fine.
    Last edited: Nov 6, 2023
  17. andy22

    andy22 Active Member

    @Markswift2003 Check your convos for the test videos from my TV PoV.

    For the subtitles what happens is that if i start a file from 0:00 it takes like 20-30s until the first subtitles are rendered, even when the sub track is already set and should be visible immediately.
    This also happens when i resume from a position, it again takes a very long time until i actually see the subtitles, while the track is set/listed as enabled 1-2s after i resume play and hit the info button.

    This also "often" happens if you switch subtitles, from one language to the next.

    This used to work in like 3-4s on the old Z9X.
    Last edited: Nov 6, 2023
  18. Kenshin

    Kenshin Member

    so to the problem with the 32bit file there is also a problem with the resolution which always changes after some time itself from 4k to 1080p ?
  19. AziraphaleUK

    AziraphaleUK New Member

    Does the soundbar support 4K ?
  20. Markswift2003

    Markswift2003 Well-Known Member SUPER Administrator Beta test group Contributor

    Can you provide a sample?

Share This Page