Beta version v1.0.60 for Z9X Pro release

Discussion in 'HDD Media player(RTD 1619BPD)' started by Markswift2003, Nov 3, 2023.

  1. fattire

    fattire New Member

    5 drives using SHR with single parity drive (3 x 8GB, 2 x 18GB)
    Data was rebalanced across drives when the 2 x 18GB drives were added

    Edit: Not that it's relevant here, but I also have 2 x 2TB M2 drives configured as R/W cache with metadata pinned there.
  2. sandyj

    sandyj Member

    "Edit: Not that it's relevant here, but I also have 2 x 2TB M2 drives configured as R/W cache with metadata pinned there"
    Yes this is relevant which models of M2 did you use as some do a reset intermittently which will cause issues e.g pausing and even reset the NAS that's why snology have got really picky about which ones to use in there compatibility testing recently ?

    Also just for everyone else here don't bother with SATA SSD caching its not of much benefit only the NVME M.2 are worth using and best to be enterprise type M.2.
    If using consumer grade M.2 some say they get away with it by only formatting part of the drive and leaving the rest in reserve I tried this under load testing and it failed.
  3. sandyj

    sandyj Member

    How much Ram do you have ?
  4. fattire

    fattire New Member

    8 GB; never more than 20-25% used.

    Not sure why this is relevant. My Nvidia Shield Pro has zero issues playing any files from the same device/shares. The Z9X before the Pro had zero issues with the exact same config as well.
  5. fattire

    fattire New Member

    Sorry to double post, but I missed this.

    Samsung EVO 970 Plus. These are not for movies. These are for random R/W. IIRC synology sees large sequential operations and bypasses the RW cache automatically.

    And to restate above, the Z9X had zero issues with this exact config. Neither does the Nvidia Shield. Nothing has changed in the environment except the Z9X Pro.
    fnhanks likes this.
  6. sandyj

    sandyj Member

    Yes and that's what I am saying my previous zidoo and current one both had the same problem as you are describing but not after I went all out to resolve the issue and it was the NAS causing the problem in my case.
    Ram is relevant as it does file caching like every OS out there this appears to help with pausing, rewinding and fast forwarding I believe the Zidoo boxes are sensitive too this if you take a look at the resource meter you will find that the file cache grows as files are played back.
    The M.2 issue is well know and is also a potential fault point.
    Just because the shield works does not mean other devices behave the same way in your local environment. Not to mention its also a different version of the OS and hardware which also has had its fair share of problems and still does.
  7. sandyj

    sandyj Member

    Samsung EVO 970 Plus.
    Yes I fully understand what you are doing here with the cache I have setup many of these and the Evo drives don't work reliably in this scenario I would not use them in any systems for R/W caching. The evo drives are not on the compatibility list for your snology I have used the Samsung enterprise M.2 successfully in there cards but unfortunately they won't fit in the slot in your unit as they are 110mm long not the standard 80mm.
  8. fattire

    fattire New Member

    I'm not trying to argue (just to be clear). My background is in enterprise NAS systems so I'm very aware of how NAS devices function. I also know there is nuance.

    It seems the difference between us is that in my environment, the Z9X worked flawlessly. Literally zero playback issues with any of my content. The NAS and network are *exactly* the same. Same NAS, same RAM, same drives, same SSDs, same network config, same cables, everything. The only change is the Z9X Pro. If everything is the same, and the one thing that changed has issues, then the thing that changed is the problem.
  9. blenky

    blenky Well-Known Member

    Does this happen as soon as you start watching or after awhile? Does it happen with all such MKV's?

    I'm playing an MKV version of Top Gun Maverick. Its 4K DV with a lossless TrueHD Atmos soundtrack. Playing fine - smooth as silk.

    I have had an issue where my 1 Gbps ethernet only connected at 100 Mbps - as reported in the Zidoo Settings>Network>Ethernet. I only noticed when I played a high bit rate video that was exceeding 100 Mbps - as it started stuttering. To fix I to unplugged and reconnected my ethernet connection which reset the connection to 1Gbps
  10. fattire

    fattire New Member

    I haven't been able to find a pattern. Some start fine and then stutter at some random point. Some start off stuttering. It's just not consistent. E.G., maybe this time it starts fine and then stutters. Maybe next time the same movie stutters out of the gate. Maybe next time it plays fine. Some are full movies and some are demo clips that I've cut out of the original MKV myself. All MKVs are personally ripped from the original 4K UHD Blu-ray discs. I can re-rip things if I find issues consistently with the same file(s), but I haven't found such consistent issues yet.

    It certainly seems limited to 4K with TrueHD+Atmos; that is the one consistent point. I just realized I haven't tested anything that's 4K HDR but NOT TrueHD+Atmos. Amost everything I have is TrueHD+Atmos. I'll try that in a bit. I have the Harry Potter series in 4K as well as a few others (I think Atomic Blonde is DTS-HD MA).

    My network is very stable and everything is 1 GbE. Good suggestion though; I've been bitten by auto-negotiate on speed (and duplex back in the day) more than I care to admit.
  11. sandyj

    sandyj Member

    My background is server design and system engineering for the last 25 years I will post some settings latter. My issues were mainly around playback of Movies and was not related to tv series.
    fattire likes this.
  12. fattire

    fattire New Member

    I haven't tried TV. I only have 2 series of TV - Band of Brothers and The Pacific. Both are 1080p and I can't remember the audio. I'm interested in any settings you have!
  13. cucnz

    cucnz Active Member

    AS stated with the .52 f/w and my Z9X Pro and now also with this latest

    Zero issues with stutters pauses ,or anything else NOT related to the edid lose issues on last f/w
    Thats playing both on SMB to PC with usb HDDs or direct to usb HDD on the Z9X pro

    since getting this new model over a month ago ,ive watched 20 -30 movies from MKV Iso or completes and majority were DV with a lot also having Atmos

    OF course simplest way to prove if its your NAS at issue is play some of the failing movies direct to the Zidoo USB 3
    Also is your HDMI cable up to data rates required for 4k DV DA stable playback ,ie a few ppl have said the supplied one wasnt ,for them
    (mine all passed cos on the Denon i can check their playback rates and only use the ones that passed )
  14. fattire

    fattire New Member

    I don’t have any external USB drives with which to test.

    HDMI issues cause resyncs with complete audio and or video dropouts. I have none of that. Just a stuttering picture with consistent audio. All cables are certified and work with 4K120. I actually upscale everything via MadVR Envy Extreme to 4k120 using their motion interpolation. I bypass MadVR for 4k120 HDR gaming on Xbox Series X. Zero HDMI issues from any source though any route in the system. I’m not using the included HDMI cable from Zidoo.

    Trinnov can also test HDMI cables but only up to the 2.0 spec. The 2.1 board hasn’t shipped yet (but I will upgrade when it does).

    EDIT: this is 100% the same config and cables with the former Z9X. Only the Z9X Pro has changed.
  15. cucnz

    cucnz Active Member

    could you use a drive from the nas , plug it in to side of the Z9x pro using the supplied sata cable to direct test

    Direct access usually best way to show where issues coming from

    Wouldnt 4k120 be an issue too ? ie
    How much bandwidth is needed for 4K 120Hz?

    If you want to take advantage of 4K @ 120Hz or 8K you'll need an HDMI 2.1 cable with bandwidth capability of up to 48 Gbps.

    How do normal 4k 23.9 khz stuff play as comparrison ?
  16. fattire

    fattire New Member

    No I can’t do that. The NAS is raid protected and a drive just can’t be removed without putting all data at risk of loss.

    The Zidoo and all other sources are 4K 23.9 into MadVR which is then 4k120 with Motion AI to the projector. All devices including current and former Zidoo are set to match content frame rate and HDR. What is in the MKV is what goes to MadVR.
  17. cucnz

    cucnz Active Member

    can you run a few movies thru at say 4k 60 DV DA to see if they have no stutter (ie like a lot of us get)
    4k120 DV DA is right on the 48gb/s requirement for cables /ports and may not be correctly implemented by Zidoo ,since its not a standard used on most tvs or devices yet

    ie if no issues at 4k60 ,and only at 4k120 DV DA then Zidoo will have something to work with
  18. fattire

    fattire New Member

    I think you misunderstand. This worked 100% with the Z9X. Same setup. Same cables. Same ports on equipment. Same content settings (resolution, frame rate, HDR, etc). I literally removed the Z9X and put the Z9X Pro into it's place. This is not an environmental issue.

    This is 100% an issue with code, firmware, or hardware on the Z9X Pro.
    fnhanks likes this.
  19. cucnz

    cucnz Active Member

    yes i understand that
    This Pro has a newer 2.1 hdmi port and lot later android OS
    All im suggesting is prove its stable at a more normal data rate like 4k 60 ,with the madvr upscaling device removed temporarily
    There may be some interction in the newer OS or newer hdmi 2.1 port causing issues integrating to the madvr
    A direct connection of the Pro to the display device will help locate where issues are ,hopefully
    Last edited: Nov 5, 2023
  20. cucnz

    cucnz Active Member

    Can confirm this isnt fixed
    My custom set EDID 4k 24hz vs10 for all changed to 4k 60 Auto after watching one series epi and backing out to start a new one
    Least it changed to a watchable one ,only noticed cos menu screen wasnt as bright

Share This Page