Audio works only with HDR set to LLDV (Z9X)

Discussion in 'HDD Media player(RTD 1619DR)' started by MikeD, Dec 13, 2022.

  1. MikeD

    MikeD New Member

    Hello, I've got a Samsung TV (so no Dolby Vision support), but I've also got a Vertex (not Vertex2), and I've got it set up to process DV signals in LLDV mode. My Z9X runs to my Vertex, which then sends the signal to both my AVR and my TV.

    With my Z9X HDR setting set to LLDV mode, everything works great -- video looks great and my AVR plays all the audio formats. However, if I change that HDR setting to something like Auto and play something that doesn't have any DV metadata, the video is correctly sent to the TV and plays in the appropriate HDR format (even HDR10+), but no audio comes out of my AVR, regardless of the audio format.

    Any thoughts? I thought at first it was a bandwidth issue with my HDMI cables, but I've got all Monoprice 18 Gbps cables (well, and the HDMI cable that came with the Zidoo -- hopefully that's not a weak link!) in the chain, so I think I'm good there. Now I'm thinking it has something to do with the custom EDID I've loaded into my Vertex (which I got on this message board, and can upload if needed), but I haven't been able to use my very limited knowledge of EDIDs to troubleshoot....
  2. Markswift2003

    Markswift2003 Well-Known Member SUPER Administrator Beta test group Contributor

    It certainly isn't the cables so we can discount that.

    It also can't be the custom EDID per se because if it works when the Zidoo is set for LLDV then the audio part of it is there.

    Which EDID are you using?

    So if you set HDR > Auto, DV movies play with audio but all other formats do not? Is that correct?

    With the Zidoo set HDR > Auto:

    When you play a movie with DV what does the AVR say on the front
    When you play a movie without DV what does the AVR say on the front (Pics would be good)
  3. MikeD

    MikeD New Member

    Hi Mark, I'll have to take pics later this evening, but in the meantime I've attached the EDID I'm using with my Vertex.

    I don't recall exactly what happens with HDR set to Auto when I play a DV movie, but certainly when I play a movie without DV, the correct badge flashes on the screen (HDR10+ for HDR10+, etc.). It's just completely silent :)

    Attached Files:

  4. Markswift2003

    Markswift2003 Well-Known Member SUPER Administrator Beta test group Contributor

    It's the front of the AVR I'm interested in which would show what's coming into it as far as audio is concerned.

    Also, press the info button and see what the Zidoo info screen says.

    The EDID is one of mine and has the full audio block, so no problem there:

    Audio Data Block #1
    1 L-PCM, channels=8, rate=192,176,96,88,48,44.1,32kHz, bits=24,20,16
    2 AC-3, channels=6, rate=48,44.1,32kHz, MBR=640
    7 DTS, channels=6, rate=96,88,48,44.1kHz, MBR=1536
    9 One Bit Audio, channels=6, rate=44.1kHz, AFCdv=0
    10 Enhanced AC-3, channels=8, rate=48,44.1kHz, AFCdv=1
    11 DTS-HD, channels=8, rate=192,176,96,88,48,44.1kHz, AFCdv=1
    12 MAT, channels=8, rate=192,176,96,88,48,44.1kHz, AFCdv=1
  5. Markswift2003

    Markswift2003 Well-Known Member SUPER Administrator Beta test group Contributor

    Just for the sake of sanity I loaded that EDID into my Vertex 2 and played an HDR10 file with HDR set to Auto and audio (in this case TrueHD Atmos) was fine as expected.

    The only difference in using a Vertex over a Vertex 2 in your case would be that in order to play LLDV you have to set a permanent custom HDR message - the Vertex 2 allows you to do that only if LLDV is detected - there's no difference in EDID handling.

    The only way I can think to replicate what's happening here is to load an EDID (or use Automix) with LPCM only and turn the Zidoo volume to zero.
  6. MikeD

    MikeD New Member

    OK, I tried a bunch of movies, and here's what I found.

    Scenario 1: HDR set to LLDV
    Everything is exactly as I expect. Full Audio reported by my AVR (even DTS-X and TrueHD7.1+Atmos), and the appropriate badge flashes on screen for video (DV or VS10). If I can't fix the behavior noted below, I can always just resort back to LLDV, and the only drawback is I can't watch HDR10+ in their native form. (Whether I'd be able to notice a difference between HDR10+ and LLDV is another matter!)

    Scenario 2: HDR set to Auto
    Class A: Movies without DV (HDR or HDR10+; I see now I forgot to try any SDR movies)
    Result: I never get any sound, whether it's DTS, AC3, DDP, 5- or 7-channel. My AVR reports "No Information," however my Vertex OSD will report AUD: bitstream or HBR bitstream (the latter for TrueHD/DTS-MA).

    Class B: Movies with DV
    Result: I mostly don't get sound. However, I was able to get sound if (a) the audio was natively 5.1, such as TrueHD 5.1, DTS-HD MA 5.1, or DD+ 5.1; or (b) I enabled the toggles for Downmix AC-3 (intended for an optical connection, rather than HDMI, but I thought I'd give it a go anyways) and played a TrueHD 7.1 file. Interestingly, enabling the DTS downmixing still failed to produce sound with a DTS-HD MA 7.1 track. As expected, my AVR reported only 5 channels with this downmixing.
  7. Markswift2003

    Markswift2003 Well-Known Member SUPER Administrator Beta test group Contributor

    Really odd one...

    It's got to be the Vertex, but I'm still not sure how.

    The downmix options in the Zidoo are misnamed - they do not downmix - the case of TrueHD, if the accompanying AC3 track is present, it will play that as an AC3 bitstream and in the case of DTS-HD, it will play the DTS core as a bitstream.

    The only downmix option in the true sense is in Settings/Audio/HDMI Audio and SPDIF Audio where Dolby/DTS can be downmixed to Stereo PCM only (the zidoo is not licensed for 5.1/7.1 downmixing).

    Can you try connecting Zidoo > AVR > TV and disconnect the Vertex for now - set HDR to Auto and see what happens.

    If this fixes it, can you connect the Vertex to a PC and in the GUI export the config file and post here.

  8. MikeD

    MikeD New Member

    Dis-/reconnecting my Vertex is non-trivial, given my setup, but I'll try to do that this weekend. In the meantime, I've attached my Vertex config. Maybe I'll get lucky and there's a 1 when there should be a 0....

    P.S. I really appreciate your help! In my job, I provide support for a product that requires a lot of expertise to even get started with, so I'm quite confident in saying that you're good at what you do.

    Attached Files:

Share This Page