2.2.82 is bad: proved!

Discussion in 'ZIDOO Z9S' started by xtripsnova, Jul 30, 2019.

  1. xtripsnova

    xtripsnova New Member

    Hello,

    I ran a test with a movie that froze all the time with 2.2.82. Then I set a repeatable procedure that worked all the time. I did the procedure twice and it didn't fail to prove that 2.2.82 is bad.

    The movie is Black Hawk Down, the UHD full bd version. After chapter 10 it freezes several times until the end. Skipping 2 or 3 seconds (1 click to the right) helps continue but it freezes again and again at the exact same spots, this is important!

    The procedure is simple:

    1) Factory restore to 1.7.8 than USB update to 2.2.82 then my settings (auto frame rate and resolution, 10 bit RGB 444). Than the movie at chapter 10+ and the freezes comes at every run.

    2) Factory restore to 1.7.8 than USB update to 2.2.61 then my settings (auto frame rate and resolution, 10 bit RGB 444). Than the movie at chapter 10+ and the movie is smooth until the end.

    I did this procedure twice as I said and got the same results.

    I am sticking with 2.2.61 !!!
     
    Last edited: Jul 30, 2019
  2. Nice Monkey

    Nice Monkey Well-Known Member Beta test group

    Good find. The title is a bit misleading as we talk a (new?) problem introduced with FW 2.2.82 which unfortunately happens regularly too. Could be a seamless branching related problem (freeze points were jumps to a new scene?).

    This is number 3 I am aware of:
    - Seamless Branching bad as in the past (the partial fix seems to have gone)
    - USB3 HDD drop outs
    - Direct play of BD (Kino Lorber releases?) not finding included single subtitle. Found and played with BD Menu correctly.

    Will watch this movie as it is on my list for a long time. Is this the 2in1 version with Extended Cut / Theatrical Cut? That one obviously needs seamless branching which was reported to be worse again than after an earlier partial fix. Seamless branching problems are the biggest on UHD+HDR+Atmos movies which this is an example of.

    If these are serious problems then moving back can be an option. For me it has many more essential things which were improved/solved.
    USB handling improved for me a lot for other issues like plug & play not working as it should. Eject now works as it should too etc.
     
    Last edited: Jul 30, 2019
  3. xtripsnova

    xtripsnova New Member

    Sorry but I am done testing. I already had a nervous breakdown with this player in the past and it took several firmware iterations to reach stability for me with 2.2.61.
    I use my player exclusively for playing movies from my NAS on a LAN network, so I don't encounter any of the above mentioned problems about USB etc....
     
  4. woody

    woody New Member

    I would politely disagree with OP

    I use the Zidoo Z9S purely to play all sorts of files from 4 HDD attached to 4 USB ports . Even used one of the SATA ports too temporarily.
    I don't have Google play store. No browser , no Kodi. No IPTV etc. No playing from NAS.

    For me its does the job. Just fine .Been upgrading to each firmware this year.

    I would consider myself a heavy media playback user.
     
  5. Nice Monkey

    Nice Monkey Well-Known Member Beta test group

    OK watched "Black Hawk Down, the UHD full bd version". Very realistic war movie but frankly far too bloody for me.

    As already suspected this is a UHD BD with 2 versions on it using Seamless Branching a lot. What is confirmed that it works worse than after the partial improvement. It video stutters and audio is lost for a few seconds obviously always at scene changes. I could not reproduce the full freeze reported by xtripsnova but I have my HDD SATA attached which is the best condition, with NAS the problems are likely even bigger.

    So no not a new problem but yes a confirmation that Seamless Branching is back to square one. I updated the FW 2.2.82 review results accordingly. Lucky there are not that many BD's like this (with multi cuts), but UHD BD's use it more frequently.

    The Seamless Branching problem can be bypassed by making an MKV of it obviously. My bypass is playing it with another media player without this nasty problem. None of HiSillicon based players have this problem, it seems to be SOC/SDK correlated. Both RTD1295/RTD1296 based players exhibit this flaw and was reported by me more than 2 years ago:
    http://forum.zidoo.tv/index.php?thr...ng-not-working-with-blu-rays.4439/#post-22232
    So probably Realtek needs to provide a fix here causing the extreme long time to fix it?
     
    Last edited: Jul 31, 2019

Share This Page