Z9X - SMB playback issues while streaming from NAS

Discussion in 'HDD Media player(RTD 1619DR)' started by matty2k, Dec 30, 2020.

  1. Markswift2003

    Markswift2003 Well-Known Member SUPER Administrator Beta test group Contributor

    Hopefully by tomorrow my laptop should have finished downloading all the cumulative "god knows what the hell it's downloading now..." fixes and I can do some proper testing...
     
  2. matty2k

    matty2k New Member

    In advanced settings - Realtek developer options - today I found Playback with less reserved buffers switched on. Seems to be default setting. I switched of and experienced way less stutter, could watch one DV movie without any problems. Started another one with some stutter in the beginning and then was running smooth. Need some more testing but could be useful to switch of for all who experience problems. On NAS actually I have minimum SMB profile 2 and maximum profile 3.
    Cheers
     
  3. cucnz

    cucnz Active Member

    the thing is Mark
    we didnt have this inttermittent freeze issue pre .85/.90 DV DA fix while playing to zidoo via smb etc
    Everything NOT DV DA was playing smoothly with none of these freezes
    Now i cant play any 4k movie via smb without the intermittant freeze for half a sec or so
    Play the same movie file direct to usb3 and ZERO of these pauses everytime

    Still get the occassional movie that locksup half way thru/restart continue plays the rest fine and you already have bug reports in for that
     
  4. Rob W

    Rob W Member

    Yes I also disabled that when I enabled playback performance mode. Interesting that it's now the default and could be why lots of people suddenly have stutter.
     
  5. Markswift2003

    Markswift2003 Well-Known Member SUPER Administrator Beta test group Contributor

    That's exactly what I want to debug - If I can replicate the stuttering on .85 onwards and create a debug file and then create a debug file on earlier firmware with no stutter on the same file then the comparison between the two should tell us where the problem is - as always with these things it's replicating the issue on a level playing field that's the problem - without that you can't find out what's wrong.
     
  6. Markswift2003

    Markswift2003 Well-Known Member SUPER Administrator Beta test group Contributor

    It's also set on as default on earlier firmware (checked on v6.0.60)
     
  7. Like I posted in prior messages, I get stuttering from x45 firmware to the newest.
    X45 was little better, but still had stutter even on low bitrate material.
    The z9s and x9s all work perfect.

    Unfortunately I have spent too many hours trying to get this simple issue fixed.
    I love zidoo and had their hardware for years..
    But very disappointed with this new model..

    I have now unfortunately retuned my zidoo and am now going to stick with my z9s..

    For fun, I even tried over weekend an apple tv4 with Infuse, using my same SMB shares...
    And all movies I threw at it played perfect.. not one stutter..

    Jellyfish I could get 250mbs perfect, but 300mbs had 1 or 2 stutters..

    I'm sad... but hope they fix this issue..
     
  8. MovieUwe

    MovieUwe New Member

    I have now tested almost all versions once. Unfortunately, there is no version that works without problems. Even the versions below 0.40 have the stuttering.
     
  9. ghostshadow

    ghostshadow Member

    Hello Mark, on firmware 0.66 and 0.60 I had no problem with the network (0.60 I'm on), my nas in smb 2 and 3. The stuttering are on the series and film (dv, hdr, sdr , hd, 4k).
    I had already mentioned this cache problem during the problems we had with the Dovi (since resolved), because for me it is linked to the filling of the cache which suddenly constrains the network, and it is less noticeable on an internal disk since the reactivity with an internal disk is faster. This is true since when you do a quick return the problem disappears.
    In addition if we reset the factory settings and start a movie, no stuttering. It will appear after playing 2 or 3 movies.
    When fixing the TrueHD Dovi bug, the code for filling the cache was not changed?
     
  10. Kritjuu

    Kritjuu Member

    How do I get to the Developer Realtek Options
     
  11. Tawatchai Wog

    Tawatchai Wog New Member

    Hello, I have two tests:

    1. Connect to windows10 via LAN cable CAT6E 1Gbps port.

    2. Via Wi-Fi AC 5G.

    Both tests link to the same windows10 Link via a gigabit switch hub. It's funny because my Z9S was never this stuttering.

    Let’s see
    1 Gbps lan connection. There is a stuttering video when playing through a LAN cable.


    Wifi access point AC 5G 450/AC867 Mbps (802.11 a/b/g/n/ac). When playing video via wifi, it is smooth.


    Z9X fw:V6.0.90G
     
    elpablo and MovieUwe like this.
  12. McBluna

    McBluna Active Member

    You've to enable the developer options first. The images are from Z9S but should be the same for Z9X.
     

    Attached Files:

    MovieUwe likes this.
  13. Markswift2003

    Markswift2003 Well-Known Member SUPER Administrator Beta test group Contributor

    The problem I have is I'm having trouble replicating the issue - as I've said on several occasions I use Western Digital NAS drives and have never had as much as a skipped frame from them so I figured I'll try a Windows 10 share.

    My Windows 10 laptop finally finished updating last night - this is an old (maybe 15 years old) Sony Vaio TZ which rarely gets switched on that I use for calibrating and has a gigabit ethernet card.

    Expecting stutter, my plan was to create a debug log while that was happening but I've tested the Jelly Fish demos played from the internal SSD, which will play up to 400Mbps and I'm currently testing a UHD BluRay remux played from a USB drive attached to the laptop's USB 2.0 port, and so far that's playing perfectly too (I had to play the remux from a USB drive since the internal SSD is too small).

    I'll keep the remux playing to the end, but it's at 47 minutes now so I'd have expected any network problems to manifest way earlier than that.

    The overall average bitrate of the remux as shown in MediaInfo is 47.9Mbps and the info screen on the Zidoo shows a bitrate of 85Mbps (no idea where that number comes from though).

    This is with v6.0.90.
     
    elpablo and MovieUwe like this.
  14. rozel

    rozel Active Member

    Hi again

    I dug out the Jellyfish files and gave some of them a run out earlier today. Since I previously played them, my system has been updated quite substantially but remains Cat5e wired - around 50 meters in length from Router (Sky - latest model 1Gbit connections) from study to living room. Passes through 2 wall sockets and a 1Gbit switch. Originally had a Dune Max 3D MP, which has been replaced first with an Egreat A11 a few years ago and my Zidoo Z1000 Pro a few months ago. Files stored and played for todays test on my 4 Drive NAS (which is located near the router) and using the NFS Protocol. I've yet to test using the Zidoo's 12Tb Internal hdd which I use for all my quality titles. I ran the test this way as I felt this was more inline with the nature of this thread.

    All the Jellyfish files played with no stuttering at all including the 400mbps file.
     
    boxerfan likes this.
  15. Kritjuu

    Kritjuu Member

    Ik have Z1000 pro. Must be different. Can not find it
     
  16. McBluna

    McBluna Active Member

    Do you know how to access the settings?
     
  17. rozel

    rozel Active Member

    In system settings. find the About device->Build number and click on the Build number box seven times. The Developer options will display on Settings now. Open USB debugging and click OK.

    Hope this helps - AFAIK it's in the pdf which came with your Zidoo
     
    MovieUwe likes this.
  18. Markswift2003

    Markswift2003 Well-Known Member SUPER Administrator Beta test group Contributor

    I'm kind of glad it's not just me!!
     
  19. cucnz

    cucnz Active Member

    Problem is theres too many of us getting it thou

    and again it NEVER happened over smb b4 .85 / .90
    and it doesnt happen usb3 direct to Z9X
     
  20. Kritjuu

    Kritjuu Member

    Jellifish files are very short files.
    Play very well. I noticed that sometimes the stuttering starts after An hour or so.
    And always random.
     

Share This Page