Zidoo X6 Pro freezes even after factory reset

Discussion in 'ZIDOO X6 Pro' started by Amit K, May 10, 2018.

  1. Amit K

    Amit K New Member

    hey guys.. it'll be nice if someone can help. Using a X6 pro for 20 months now.. all was working fine.. suddenly 2-3 days back the box froze.. nothing was working so had to pull the power plug from the wall to turn it off.. tried many times to turn it on.. it got stuck on the zidoo logo screen... left it overnight then in the morning it turned on fine after a few attempts.. did the factory reset but it still freezes after 5 mins of using it & then have to pull out power plug to turn it off. Have not installed any new apps or havent changed any settings after reset.

    Don't know what to do. Spoke the shop i bought it from & he said that most probably there is something wrong with the motherboard & that it cannot be fixed. Dont understand how suddenly the motherboard can break cuz the box never use to heat up.. no scratches.. never fallen on the ground.. was using the box watching a movie & in the middle it got stuck & never worked properly again after that.

    Please help. Many thanks

    Zidoo X6 Pro
    Andoid Version: 5.1.1
    Kernel Version: 3.10.0 xiaoweihua@Zidoobeta #24
    Software Version: v1.0.39 (tried to update but it says latest version is installed)

Share This Page