Zidoo x 6 Pro Screen Flash

Discussion in 'ZIDOO X6 Pro' started by David Mahon, Aug 24, 2016.

  1. David Mahon

    David Mahon New Member

    Can anyone tell me if I have a software problem. My Zidoo x 6 pro box is flashing black, green, blue, on my television screen. It's like looking at a negative from a photograph, after a while it flashes one of the colours again and revert back to normal.
    Is there a software update to solve this problem !!!! I'm convinced it's a software problem as I had the same problem with the first box I got, I returned that one thinking it was faulty, this is happening when I use Mobdro. Any help would be much appreciated.
     
  2. HaoSs

    HaoSs Well-Known Member

  3. David Mahon

    David Mahon New Member

    :(Just checked the software version is v 1.0.39
     
  4. Syaoran

    Syaoran New Member

    The latest version of the software seems to be a little buggy. I would wait for the next update to see, if you can hold off. If not, try rolling back to the previous update to see if that solves it.
     
  5. grummel2005

    grummel2005 Well-Known Member

    which tv set do you have?
     
    Anton Bernd likes this.
  6. David Mahon

    David Mahon New Member

    Phillips 42 " VHF+S+H+UHF about 5 years old
     
  7. ReneVeen57

    ReneVeen57 New Member

    Look in this forum for Phillips green screen problem, there is a special Phillips firmware v.1.0.39
    That might solve your problem.
     
    grummel2005 likes this.
  8. David Mahon

    David Mahon New Member

    Cheers ReneVeen57, will try that
     
  9. ReneVeen57

    ReneVeen57 New Member

  10. grummel2005

    grummel2005 Well-Known Member

    Anton Bernd likes this.
  11. David Mahon

    David Mahon New Member

    Thanks ReneVeen57 & grummel 2005 will check both suggestions over the week end
     
  12. David Mahon

    David Mahon New Member

    I have a second 32" LCD colour Toshiba model 32BV500B with 2 HDMI ports that are not working. If I got a Scart adaptor would a HDMI to Scart work !!!! as the Scart is working fine on that television. The reason I know the HDMI ports aren't working is, that I bought the Zidoo for that television but nothing happened when I connected the HDMI cable.
    Didn't even recognise the box, just a blank screen.
     
    Last edited: Aug 24, 2016
  13. Sarco

    Sarco Active Member Beta test group

    some users of X9 also had problem, did you try the display key on remote? It switch between 1080 and 720 if tv do not report correct info.
     
  14. ReneVeen57

    ReneVeen57 New Member

    Was this solved with the special Philips firmware?
     
  15. David Mahon

    David Mahon New Member

    Sorry for not getting back to all who responded to my problem, was away the past few days.
    Regretfully nothing worked on the phillips tele. However I have a cheap smaller Blue Diamond tele, and low and behold when I connected it up to that one everything worked perfectly. No lag no freezing brilliant picture.
    Thank you all for the help given much appreciated and again sorry for delay in responding.
     
  16. Carmine Sapio

    Carmine Sapio New Member

    Hi, my zidoo x6 pro has Got upgrade to the 1043, but unfortunately does not accept the 1040 version for the Green Screen Problem. There are New Updates AFTER 1,043 for the Philips Screens problem?
     
  17. Carmine Sapio

    Carmine Sapio New Member

    Is there a way to bring the zidoo x6 pro to a version prior to 1039?
     

Share This Page