Z9s Firmware 2.3.3

Discussion in 'ZIDOO Z9S' started by leonkoum, Dec 14, 2019.

  1. Nice Monkey

    Nice Monkey Well-Known Member Beta test group

    This is on the change list! It now wraps instead. So is a planned change.
  2. Siju Thomas

    Siju Thomas New Member

    wraps? can you share a video? of this wrap? and where is it mentioned in the change log?

  3. Nice Monkey

    Nice Monkey Well-Known Member Beta test group

    File manager

    2. Cancel the top navigation category and add the list rotation function

    Most other media players/browsers do the same: Wrap around!
  4. Carsten Busch

    Carsten Busch Member

    Got LPCM 2 channel Audio output with HDMI on RAW
    Changed to AUTO then it worked, back

    - After rebooting the same problem: LPCM 2 channel till I switch the audio back from AUTO to RAW and vice versa.

    - Colour mapping in 1080p is wrong when in UI. Movies are ok.
  5. pcristi

    pcristi Active Member

    Is was usefully special for video to get easy witch file to play when in a folder are also external subtitles, poster, fanart, thumb, nfo, etc.
  6. vman

    vman Member

    Thanks, but I don't understand how to replace the file. What is an adbshell or how do I know if my box is rooted?
  7. wilsonganks

    wilsonganks Member

    Wow, was excited about a new firmware until i read through, it seemed like there are more problems than fixes. I won't be upgrading to this.
  8. skywalker1978

    skywalker1978 Member

    I did not instal the 2.2.97 FW for causing more problems than fixing issues. It seems I will skip this one too. Sad :(

    DELUCAS Well-Known Member

    This is a beta so possible early issues flagged maybe addressed with a newer more stable firmware later on :)
  10. skywalker1978

    skywalker1978 Member

  11. pcristi

    pcristi Active Member

    Sometimes hope never dies, after more then a year I still hope they will fix audio 3 letter abbreviation of rum will not be Russian anymore. ISO_639-1_codes.
    Last edited: Dec 18, 2019
  12. Nice Monkey

    Nice Monkey Well-Known Member Beta test group

    This is a bit negative! Just see my aggregated overview reply #2. Overall I do rate it better than any previous FW. No big issues and USB3 seems to be working fine again (reported by multiple very critical German users).
    Setup incompatibilities are merely an inconvenience but may be confusing. To be sure a Factory Reset is recommended.
    Eject not working is a bad move though (not the first time that an update jeopardised it).

    There are also things reported here which I can't confirm:
    - HDMI RAW Audio working as LPCM Stereo: Had it initially only
    - Front display not showing clock: Did not see this myself
    Last edited: Dec 18, 2019
    pcristi likes this.
  13. catorcio

    catorcio Member

    can you install it on the Z10?
  14. leonkoum

    leonkoum Active Member Beta test group

    Don’t even think about it..
    Just wait a few hours/days
  15. catorcio

    catorcio Member

    Thanks, I thought the Z10 and Z9S had the same firmvare
  16. Nice Monkey

    Nice Monkey Well-Known Member Beta test group

    They are very close indeed. The Z10 has a fan extra and the Front Display is functional different for sure. So it might work with a display flaw, but is still a risk.

    I agree with leonkoum crossflashing in general is never a good idea and asking for (serious) troubles. The wait will be short for sure.
  17. x9suser

    x9suser Member

    I want to know this too. How to activate the zoom feature ? Anyone knows ?
  18. talkron

    talkron New Member

    Just updated to this after skipping multiple FW releases. Seams reasonably stable to me, bud sadly even after doing the upgrade twice, the blu ray menus i lost with factory reset of the FW i used before, are still absent. The player lets you choose if you want play a file as a single file or with BD menu, but proceeds then play without menu, whatever you choose. If seamles branching is preseent,it automaticaly plays the largerst playlist avaliable. This is not pressing matter to me,
    as i have maybe 7-8 blu rays and 2 UHDs with seamless branching, but i was buying the player as something able at least partialy play BD menus. Remember somebody to be able repair this problem by multiple times flashing the player, but i have not a flash disk and was not even able to find online under what description are they sold in my country(the terminology is one big mess here) and genuinly prefered some simplier and less risky way to repare the FW. So nobody found alternative way how to repair this problem?
  19. Nice Monkey

    Nice Monkey Well-Known Member Beta test group

    Are you talking KODI using ZDMC or the standard Zidoo Video Players? Accessing from Media Center or Home Theater 2.0?

    Not normal as BD Menu's should work with all methods. The player can do it for sure. Once knowing the details we should be able to get it solved.
    Read some experiences that the Factory Reset does not (always) do what it is supposed to do.
    Flashing is simple and well described.

    The ultimate reset is doing an Emergency Flash first with a ROM image: ZIDOO_Z9S_N_v1.7.8_201809292102_usb-install.img
    Once a stable release is available maybe we get a newer one from Zidoo?
    Next a regular FW upgrade is needed to bring it up to level again.

    @x9suser Good question; did not see it anywhere.
    Last edited: Dec 21, 2019
  20. talkron

    talkron New Member

    Hi, i remember somebody having the same problem months ago. Originaly the BD menus worked (using only the standard Zidoo player FW) , but i was forced to make soft factory reset (the player was constantly crashing), the one avaliable in settings under Others. After that the playback became stable, but the BD menus stoped working. I hoped simbly upgading to new FW could fix it, but it did not. Problem with flashing for me is, i am unable find u-disk avalible in my country, i was not even able find how it is called here...searches show just normal flash disks...

Share This Page