Z10 stucked help me plase

Discussion in 'ZIDOO Z10' started by Edward, Jan 9, 2019.

  1. Edward

    Edward New Member

    Hello everyone,

    I got today my z10, i installed newest firmware v2.1.22 successfully, after upgrade everything worked perfect but when i was watching some 4k movie i pause film for 10 minuts and i coudnt continue it. Z10 display frozen with playback time, any key on the remote not working so i shut it down using power of button on the back side.

    After that my Z10 cannot boot. Z10 display totally black, no hdmi signal on the tv, works only cooling fan with high speed.

    I tried to flash it by FAT32 usb drive, i did everything what says support page about z10 flash but z10 not flashing not booting :( i tried maybe 20 times but no success.

    I dont even use it 1 day. I am so sad plase help me what should i do?
  2. slavensiz

    slavensiz New Member

    Now it's too late to talk about it, but for the future. http://4pda.ru/forum/index.php?s=&showtopic=772588&view=findpost&p=68996445

Share This Page