Z10 Constant Blank Screen Issues

Discussion in 'ZIDOO Z10' started by Zigourney, Feb 8, 2019.

  1. Zigourney

    Zigourney New Member

    Hi - I have the Z10 and X9S and also had the Z9S.

    Both the Z10 and the Z9S have constant blank screen issues.
    The Z9s is worse than the Z10 for blank screens issues and I had to return the Z9S for a refund.

    Is anyone else having this blank screen issue on the Z10?
    I know this is a firmware issue as I also have the X9S and I don't have any blank screen issues on my X9S.

    I thought I would create this thread to get the attention of the Zidoo tech guys.
     
    gymnos likes this.
  2. Ovidiu Necula

    Ovidiu Necula New Member

    Hi,
    Same here, I own Z10 and I have had X9S in the past. The last one was superb but Z10... is too buggy.
    Last night I tried to watch an 4k h265 movie but constant black screens every 15-30seconds.
    I have factory default Z10 and select on Deep Space Color, Priority 8bit and I watched the whole movie without any black screen. Before factory default, the deep space color was on Auto.
    I put the settings back to Auto mode and no issues with the same movie. What the heck?

    Definitely an issue in the software.
     
  3. DIKKE

    DIKKE New Member

    The 8 bit setting was the solution here?
     
  4. Zigourney

    Zigourney New Member

    I didnt try the 8bit setting, but tried 10bit and auto only. Both did not work for me.
    It got annoyed and I packed it back in the box and am using the X9S again, I am hoping Zidoo fix it via a new firmware soon.

    I will get the z10 back out the box again at some point this weekend and try the 8bit setting to see if it works or not.
     
    Last edited: Feb 8, 2019
  5. Ovidiu Necula

    Ovidiu Necula New Member

    I am not sure. Before reset it was on auto and after it was on 8 bit by default. I left it 8bit and watched the whole movie without issues. Now, is back on Auto setting and no black screens after 30 minutes of watching the same video. I guess the fix was the reset to factory settings, at least temporary. Along with that, I have the issue with missing signal on tv from Z10 after standby resume. I have to shut it down and start it again in order to have image back on tv. It happens almost every time, no matter the version on firmware was installed. Pretty annoying...

    I have also an Apple 4k Tv and no issues whatsoever including hdmi cec.
     
  6. Zigourney

    Zigourney New Member

    I also have an APTV4K with infuse pro and everything works perfectly on that, including the HDMI-CEC function. The one feature missing on the Apple TV 4K is Atmos and DTS-X playback on local files.
    Did you just do the factory reset option from the quick setting menu? or a different method?

    I need to try that and see if it makes a difference.
     
  7. Ovidiu Necula

    Ovidiu Necula New Member

    From the quick settings.
    That's why I bought z10, for dts x and Dolby atmos offline. Both player are passthrough soundbar sony ht-z9f with rear wireless kit.
     
  8. Zigourney

    Zigourney New Member

    Exactly the same reason why I bought the Zidoo players!
    From the 3 players that I bought I prefer the design of the Z10, I like the size and the larger screen on it as the Z10 looks better in my media cabinet than the smaller X9S/Z9S.
    I do not need the internal hard drive space of the Z10 as all my media is stored on a Synology NAS and is streamed via cat6 gigabit network.

    Lets see what happens, I will hold on to the Z10 for a little longer and see if the stability improves in the next couple of firmware releases.
    If it doesn't get fixed soon I will get rid of the Z10 and stick to the X9S which is working great minus the hdmi cec issues.
     
  9. Ovidiu Necula

    Ovidiu Necula New Member

    Surely Zidoo could fix the black screen issues in future release. Not sure about hdmi cec issues where the problem applies almost all media players out there with Android preinstalled. ATV has proprietary linux installed, same for Vero+ and all linux based mediaplayers have no issues with hdmi cec.

    I have also a synology nas and gigabit network, I like the look of Z10 like you and I don't use internal hard drive at all :)
     
    Zigourney likes this.
  10. Zigourney

    Zigourney New Member

    I tried the factory reset and the 8bit setting as well as the auto setting and it didn’t work for me, still I got the random blank screen issue

    Also someone else said try leaving everything on auto and change the range only to 16-235 but that didn’t work either. I just spent the last two hours trying different combination of settings after I did a factory reset but nothing has worked, still getting blank screen issues.

    I’ve given up now, going to unplug the Z10 and plug the X9S back in and use that for now. Will wait for the next firmware update for the Z10.

    One thing for sure I will not be updating the firmware on my X9S anymore because that’s working as it should lol
     
    Last edited: Feb 12, 2019
  11. Miguel Ramos

    Miguel Ramos Member

    Returning back Z10 and keep my old X10. No issues with this one...
     
    Zigourney likes this.

Share This Page