X9S incompatible with Netflix

Discussion in 'ZIDOO X9S' started by Perfman, May 11, 2017.

  1. Perfman

    Perfman New Member

    Hi,

    Just got my new X9S. Everything was going fine until I tried Netflix. Advertisement says this unit supports the app but I can't get it to install. Started with v1.2.11. Upgraded to v1.4.4, still no luck. Google Play Store doesn't list Netflix app as an option. When I try through Netflix.com, it refers me to Google Play Store which then gives an error "Your device isn't compatible with this version." So now what do I do? I use Netflix a lot so really need this to work.

    Thanks,

    Perfman
     
  2. Andydigital

    Andydigital Member

    The advert I saw on Amazon specifically says that the X9S and X10 are not for streaming from the likes of Amazon and Netflix etc.

    Wouldn't means would not support. Not very good English I admit, but it does not say it does support Netflix. The Amazon app does work but its crap as its a phone app and only supports low res and stereo.
     
  3. Techead

    Techead New Member

    I came across this as well. I found the APK of Netflix form http://www.apkmirror.com/apk/netflix-inc/ and it looks to work ok.

    Up to you if you want to try this but if you have issues you will have to wait for the supported app.
     
    Andydigital likes this.
  4. Perfman

    Perfman New Member

    Tried the link, installed but when opened, Netflix says device not supported. However it provides help to another apk. Followed the second link and install again. Now it is working. A lot of hoops to jump.

    Next problem, not getting 5.1 audio from Netflix or any other web source. Tried all the X9S audio options with no luck :) Ideas?
     
  5. HaoSs

    HaoSs Moderator Beta test group Contributor

    ^ already replayed in another thread, those apps will threat tv box like a phone/tablet and not as a native streaming box ( not that it can't , its just that they block the app intentionally, selling the DRM for HD and 5.1 to specific vendors )
     
  6. cyber7

    cyber7 Active Member Beta test group

  7. Sarco

    Sarco Active Member Beta test group

  8. cyber7

    cyber7 Active Member Beta test group

    Unfortunately there is no tool to actually root the X9S. Tried the onekeyroot tool, just says "root faile"...
     
  9. nikos_a

    nikos_a Member

    I have to add also another app. WWE app used to work but I noticed that even though I was getting updates in my Samsung Android cell phone, no updates were coming to x9s. I removed it and was impossible to have it listen on Play Store on the x9s. :(
     
  10. Sarco

    Sarco Active Member Beta test group

    Even if you could install there is a glitch: binary. I presume OpenWRT does inclued binary, so when X9S not root there is binary folder somewere that apk seing X9S root, on the other end when trying to root app does not install binary seing that folder but that folder can not be access in android so the result is missing binary. That just what I think this is not what realy happen but maybe....
     
  11. grapenose

    grapenose New Member

    OneKeyRoot actually works on my X9S, however the app that I'm trying to get to work then tells me that it is incompatible with the box . Before I used OKR it gave me the message that it dosn't support rooted devices.
     
  12. HaoSs

    HaoSs Moderator Beta test group Contributor

    sometimes incompatible with the box also means it detects the HDMI port, you can try testing root+ HDMI deception app.
     
    grapenose likes this.
  13. Dantoine

    Dantoine New Member

  14. grapenose

    grapenose New Member

    The X9S doesn't seem to have the HDMI deception app in latest firmware but I managed to find it.
    Sad to say it didn't work,still getting same message.
     
    Last edited: May 25, 2017 at 6:05 AM
  15. HaoSs

    HaoSs Moderator Beta test group Contributor

    was a long shot anyway, worth testing tho. To bad did not work
     
    grapenose likes this.

Share This Page