1. Dear Users, Happy New Year! In order to celebrate the traditional Chinese Spring Festival, Zidoo company is scheduled for a holiday from 18th Jan to 31st Jan. We will be back to work on 1st Feb. If there is urgent message, pls contact service@zidoo.tv Your understanding will be highly appreciated if our holiday brings you any inconveniences.We are looking forward to your support in the coming new year and hope you have have a happy and joyful time in 2020! Best regards, ZIDOO Team
    Dismiss Notice

x8 with fw v2.1.22 unable to run Kodi 18.1 & RSS Player

Discussion in 'ZIDOO X8' started by William Ho, Apr 5, 2019.

  1. William Ho

    William Ho New Member

    I have a Zidoo X8 about two years ago and since then I have not upgraded the firmware at all, it was on v1.4.12. Two days ago I found that there is a new version v2.1.22 in the Zidoo web page (Downloads tab), I then decided to upgrade the firmware to the latest version.

    I use the Zidoo X8 box mainly with Kodi 18.1 (Leia) and RSS player. These two apps work very well with no problem at all in firmware v 1.4.12. However, after I upgraded the x8 to v2.1.22, I found out that Kodi keep on dying, Kodi will launch to the main menu for about 5 seconds and then dropped back out to the Zidoo main page, sometimes it has a message "Unfornately, Kodi has been stopped" and kick out to the Zidoo main/first page. I tried rebooting x8 as well as reinstalling a new Kodi 18.1, but Kodi kept dropping back to the main page after a few second.

    In addition, there was no problem when I ran RSS Player in v1.4.12. Now after upgraded to v2.1.22, the RSS Player launched and showed the TV program selection pages correctly, but once a TV program is selected to play, it showed a black screen (no video) but the audio is working fine as the program runs. There must be something wrong with the video buffer as there is no video on screen, only audio.

    Also, I have done a factory reset, but the problem still persists for both Kodi & RSS Player.

    However, I tried YouTube in v2.1.22, it worked fine with no problem at all.

    I tried to downgrade it back to v1.4.12, but the "update" app did not allow me to do that as the firmware is lower than the current one.

    Not sure why this happens. If someone can shed some light to me, it would be appreciated. Thank you.
     
  2. Sarco

    Sarco Active Member Beta test group

    In kodi forum some said kodi on android need to be start with ethernet connection for the first start... After it work normaly. Worth a try.
     
  3. William Ho

    William Ho New Member

    Thanks Sarco for the quick help, that fixed my Kodi problem.
     

Share This Page